Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-02-2010, 01:28 PM   #1326
phong
Scooby Newbie
 
Member#: 10884
Join Date: Oct 2001
Chapter/Region: NESIC
Location: Fayston, VT
Vehicle:
2002 WRX Wagon

Default

Quote:
Originally Posted by Pinned View Post
That would be interesting to see.

Wolf, I'm sure that car is fun on the top end, but as others have said it's a bit perplexing that the 19T is having those results! I know you mentioned the silicone coupler on the intercooler as a potential issue, though I'm curious as to what intercooler you're running? I know you mentioned earlier that it was pretty big.

I just bought that hyperflow, so I'm hoping that I don't run into any late spool issues with it.
You should have no issues with the Hyperflow; it fits like a glove, at least in the GD body. I noticed no drop off in spool whatsoever.
* Registered users of the site do not see these ads.
phong is offline   Reply With Quote
Old 07-02-2010, 02:10 PM   #1327
Phatron
Scooby Guru
 
Member#: 36033
Join Date: Apr 2003
Chapter/Region: SCIC
Location: Tuning Lab
Vehicle:
CEO PhatBottiTuning
2006 STi GTX3582 + Meth

Default

Quote:
Originally Posted by ForesterWTi View Post
I hit 130mph today with ease WITH 4 ADULTS in my GF8 "Pink Vader" we all together did a few 60-100 sprints in 4th and some 80-130 sprints from 4th to 5th --- ALL of the runs were amazingly fast and strong in terms of pull strength. My PT "Monstah" may hit towards the 4000's to top end, but it's a lot of pull till red line . And that's now at 520miles on the turbo at 7k ft with the boost turned down to 16psi on pump 91 gas!

Cheers,
~Wolf
WTi
i'd love to see a learning view after that....
Phatron is offline   Reply With Quote
Old 07-02-2010, 02:38 PM   #1328
rubinm
Scooby Specialist
 
Member#: 63483
Join Date: Jun 2004
Chapter/Region: RMIC
Location: Ski Town USA
Vehicle:
2005 STi HTA68'd+e85
Aspen White

Default

Hrmm.. 130 in Steamboat.. lets see.. you were either on hwy 131.. headed down Rabbit Ears, or headed up towards Clark..
rubinm is offline   Reply With Quote
Old 07-02-2010, 02:59 PM   #1329
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by Pinned View Post
That would be interesting to see.

Wolf, I'm sure that car is fun on the top end, but as others have said it's a bit perplexing that the 19T is having those results! I know you mentioned the silicone coupler on the intercooler as a potential issue, though I'm curious as to what intercooler you're running? I know you mentioned earlier that it was pretty big.

I just bought that hyperflow, so I'm hoping that I don't run into any late spool issues with it.
Yeah I kind of wished I had purchased a JDM TMIC, or 08 STi TMIC instead.

I am running the CX Racing TMIC, it's about 21" long and 4.5" thick.

Cheers,
~Wolf
WTi
ForesterWTi is offline   Reply With Quote
Old 07-02-2010, 03:03 PM   #1330
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by rubinm View Post
Hrmm.. 130 in Steamboat.. lets see.. you were either on hwy 131.. headed down Rabbit Ears, or headed up towards Clark..
haha whats up buddy, don't forget about 20 mile rd!

I was on 131 heading towards Oak Creek.

We also did that long sweeping corner at 90 and came out of it at about 120 lol... the one by Catamount .

Cheers,
~Wolf
WTi
ForesterWTi is offline   Reply With Quote
Old 07-02-2010, 03:08 PM   #1331
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by jarencibia View Post
Wolf can you post a datalog to show how this spools on the street in 3rd?
I believe that Harvey has the road plots saved on his computer. He is going to send me all of them and the videos today. I called him yesterday.

Cheers,
~Wolf
WTi
ForesterWTi is offline   Reply With Quote
Old 07-02-2010, 03:11 PM   #1332
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by Phatron View Post
i'd love to see a learning view after that....
huh?

Cheers,
~Wolf
WTi
ForesterWTi is offline   Reply With Quote
Old 07-02-2010, 03:17 PM   #1333
Phatron
Scooby Guru
 
Member#: 36033
Join Date: Apr 2003
Chapter/Region: SCIC
Location: Tuning Lab
Vehicle:
CEO PhatBottiTuning
2006 STi GTX3582 + Meth

Default

learning view.....it snaps a screen shot of your IAM, fueling trims and FLKC table.

I bet that during the high rpm high load driving you were knocking like a mofo.

http://www.romraider.com/forum/topic2772.html
Phatron is offline   Reply With Quote
Old 07-02-2010, 03:23 PM   #1334
Scooby921
Merci Buckets
Moderator
 
Member#: 88606
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Clarkston
Vehicle:
2011 GMC Sierra
'13 JCW

Default

Quote:
Originally Posted by Phatron View Post
learning view.....it snaps a screen shot of your IAM, fueling trims and FLKC table.

I bet that during the high rpm high load driving you were knocking like a mofo.

http://www.romraider.com/forum/topic2772.html
I was kinda thinking the same thing. After hauling my bike around on the roof rack for a couple months I pulled the LV log on my car. IAM down to 15 and plenty of knock correction. Guess I should be doing my WOT tuning pulls with the bike on the car so the loads are more accurate. I should probably log and tune for my wonderful stop-and-go daily commute too. So much for having power and fun .
Scooby921 is offline   Reply With Quote
Old 07-02-2010, 03:38 PM   #1335
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by Phatron View Post
learning view.....it snaps a screen shot of your IAM, fueling trims and FLKC table.

I bet that during the high rpm high load driving you were knocking like a mofo.

http://www.romraider.com/forum/topic2772.html
Thanx! That's sweet to have.

Oh and I have never hit WOT since the tune, and I really had not before it - possibly a handful of times.

I baby her as she IS at 122k miles now... always accelerating slowly, always using the full clutch each shift, including rev matching heel toe downshifts

Cheers,
~Wolf
WTi
ForesterWTi is offline   Reply With Quote
Old 07-02-2010, 04:20 PM   #1336
xsnapshot
Scooby Newbie
 
Member#: 170973
Join Date: Feb 2008
Location: Lincoln, NE
Vehicle:
2004 WRX 4EAT
PSM

Default

Quote:
Originally Posted by ForesterWTi View Post
Thanx! That's sweet to have.

Oh and I have never hit WOT since the tune, and I really had not before it - possibly a handful of times.

I baby her as she IS at 122k miles now... always accelerating slowly, always using the full clutch each shift, including rev matching heel toe downshifts

Cheers,
~Wolf
WTi
how have you not managed to go WOT since the tune?.....having done many 100mph+ pulls to redline (as you posted earlier)? Are you saying you took it to redline at 50% throttle or something? Never cared to enjoy all that power?
xsnapshot is offline   Reply With Quote
Old 07-02-2010, 04:22 PM   #1337
Scooby921
Merci Buckets
Moderator
 
Member#: 88606
Join Date: Jun 2005
Chapter/Region: MWSOC
Location: Clarkston
Vehicle:
2011 GMC Sierra
'13 JCW

Default

Quote:
Originally Posted by ForesterWTi View Post
Thanx! That's sweet to have.

Oh and I have never hit WOT since the tune, and I really had not before it - possibly a handful of times.

I baby her as she IS at 122k miles now... always accelerating slowly, always using the full clutch each shift, including rev matching heel toe downshifts

Cheers,
~Wolf
WTi
Only 122k? I'm over 150k in my '05 and still flog it daily . I just got my oil analysis back from Blackstone yesterday and they told me everything looked good...better than the averages .
Scooby921 is offline   Reply With Quote
Old 07-02-2010, 04:40 PM   #1338
SHARP_DAL
Scooby Newbie
 
Member#: 183247
Join Date: Jun 2008
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
2005 WRX
WRB

Default

yeah Wolf.. I think someting is up with your setup.. there is no way you should be hittin gbooat at 4400rpm.. thats unheard of!

If everythign is sound... is the turbo excessively noisey? Before my turbo died it was boosting real slow (5000rpm), that progressivley got worse are the bearings failed.. I don't mean to scare you but, I think you should go over your setup again..

Were you boosting at relatively the same rpm on your stock setup? You should be boost only about 500rom later with the PT TD04H trim.. somehting to consider..
SHARP_DAL is offline   Reply With Quote
Old 07-03-2010, 12:40 AM   #1339
PAImportTuner
Scooby Newbie
 
Member#: 141669
Join Date: Feb 2007
Chapter/Region: MAIC
Location: PeeAy 610
Vehicle:
A EJ205 with
E316G

Default

Quote:
Originally Posted by ForesterWTi View Post
I just wanted to say that the point of this thread is 2.0 wrx's running a 19T upgraded TD04...

Correct, originally the thread was for 19T (mainly Deadbolt and Blouch) but it turn into a a PT19T > all else because of price, then some PTs starting blowing, James of PT got butt hurt and now doens't make them anymore. So now Blouch 19T is the only option but you can get your stock td04 ported, a small 16g or even a Evo316G from almost anywhere. You will be surprised how fast the E316G spools but I prefer a small 16G or ported Blouch 19T for auto-x because they produce torque sooner.

After I sell my FMIC setup and UTEC, which is soon, then I will get a ported/clipped Blouch 19T. Ray Arroyo or Jorge Carillo will be tuning it on Sunoco 93.

*Plans changed now going Evo316G

Last edited by PAImportTuner; 07-04-2010 at 03:26 AM.
PAImportTuner is offline   Reply With Quote
Old 07-03-2010, 05:04 PM   #1340
trinistyles
Scooby Specialist
 
Member#: 71627
Join Date: Sep 2004
Chapter/Region: Tri-State
Location: Ny/Nj/Li
Vehicle:
780 Wrx/Fozzy/Legee
Wbp/Dark gray/Bergundy

Default

Well its time finish my 19T,I was just going to sell it or just let it sit,(which it was) all thats missing is the turbine wheel (44.-52. mm) and P+P the exhaust side housing,I do know I could just go with a 39 and call it a day but I built this and all my work will pay off,I will keep you guys updated on if it fail or not.
Blessed.
ing.
trinistyles is offline   Reply With Quote
Old 07-04-2010, 01:18 AM   #1341
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by xsnapshot View Post
how have you not managed to go WOT since the tune?.....having done many 100mph+ pulls to redline (as you posted earlier)? Are you saying you took it to redline at 50% throttle or something? Never cared to enjoy all that power?

haha I know it seems crazy, but I have not. She's my baby, and I really do love her. It's enough just to enjoy the now STi awhp of my 2.0 GF8 .

Cheers,
~Wolf
WTi

Last edited by ForesterWTi; 07-04-2010 at 01:32 AM.
ForesterWTi is offline   Reply With Quote
Old 07-04-2010, 01:27 AM   #1342
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by SHARP_DAL View Post
yeah Wolf.. I think someting is up with your setup.. there is no way you should be hittin gbooat at 4400rpm.. thats unheard of!

If everythign is sound... is the turbo excessively noisey? Before my turbo died it was boosting real slow (5000rpm), that progressivley got worse are the bearings failed.. I don't mean to scare you but, I think you should go over your setup again..

Were you boosting at relatively the same rpm on your stock setup? You should be boost only about 500rom later with the PT TD04H trim.. somehting to consider..
She was boosting at 15 psi because the previous owner had open sourced it (found this out when I went to Harvey's Boost Creep to dyno) and basically a stock 2.0 wrx set up... just a tbe and cai. The boost came on just about 800 rpms faster than before I replaced the stockie TD04 for the "Monstah". On my tune date my PT had 250 miles on her, we did a pull before doing any tuning at all, I put down 181.5 awhp at only 9psi CR:0.

BTW I'm almost at 600 miles on my PT, it's been making the same noise as it always has --- nothing I've been worried about... I did get a CEL today and also have had three times in the past two days where I'm having a hard time on hot starts keeping her at idle --- after a little gas petal fluttering she's 100% fine. In these past three days she has driven exactly the same since my tune.

Cheers,
~Wolf
WTi

Last edited by ForesterWTi; 07-04-2010 at 01:36 AM.
ForesterWTi is offline   Reply With Quote
Old 07-04-2010, 03:25 AM   #1343
PAImportTuner
Scooby Newbie
 
Member#: 141669
Join Date: Feb 2007
Chapter/Region: MAIC
Location: PeeAy 610
Vehicle:
A EJ205 with
E316G

Default

Wolf,
I will give you credit for taking the positive of this setup, I would be upset.. when you/we were specifically looking for a fast spooling close to stock td04 characteristics, you now essentially got a 18G without the top end hp.

Anyways I've broke down and bought an Evo316G.
PAImportTuner is offline   Reply With Quote
Old 07-04-2010, 03:47 AM   #1344
ForesterWTi
Scooby Newbie
 
Member#: 173892
Join Date: Mar 2008
Chapter/Region: RMIC
Location: Steamboat Springs, CO
Vehicle:
2005 OB EZ30R LLBean
champagne gold

Default

Quote:
Originally Posted by PAImportTuner View Post
Wolf,
I will give you credit for taking the positive of this setup, I would be upset.. when you/we were specifically looking for a fast spooling close to stock td04 characteristics, you now essentially got a 18G without the top end hp.

Anyways I've broke down and bought an Evo316G.
Haha thanx, I'm a glass half full kind of guy.

I'm actually looking at trying to find a deadbolt "monster" TD04...
...And dare I say a VF23/24 ---- just to see what the costs will be like .

I really want another 19T, but I would like to have full boost in the 3.5k range.

Cheers,
~Wolf
WTi
ForesterWTi is offline   Reply With Quote
Old 07-04-2010, 03:53 AM   #1345
SilentDoomWgn
Scooby Newbie
 
Member#: 246729
Join Date: May 2010
Chapter/Region: SWIC
Location: abq, NM
Vehicle:
03 wrx wgn
blue

Default

the blouch 16g-xt is what i ended up buying while it was on sale for cheaper than the evo316g, with it being pnp and ceramic coated. =) its in the mail currently so i hope to see it like mid to late this week with all the holiday crap going on. ill post picks of it in the box and outta the box and so forth as i get it on the car, then later dyno tuned. im looking like a month out for enough cash to get it dyno tuned but i will have it driving by mid july.

the car will be as: stg 1 of build
cobb post maf tube
perrin turbo inlet
turbo xs tbe
turbo xs up pipe
255fp
820cc mod'd stockers
sti tmic with aftermarket hoses
td05 16g-xt turbo with ceramic coating and pnp
one step colder plugs

was thinking stg2 as: stg1+
pnp/ceramic coated stock headers/xpipe
cobb sri with heat shield
phenolic spacers
other possible pnp
not likely but maybe an ewg
SilentDoomWgn is offline   Reply With Quote
Old 07-04-2010, 04:04 AM   #1346
Sean2.5Black
Scooby Specialist
 
Member#: 150647
Join Date: Jun 2007
Chapter/Region: NWIC
Location: Beaverton, OR
Vehicle:
98 Impreza 2.5RS
Ej20G hybrid

Default

Quote:
Originally Posted by ForesterWTi View Post
She was boosting at 15 psi because the previous owner had open sourced it (found this out when I went to Harvey's Boost Creep to dyno) and basically a stock 2.0 wrx set up... just a tbe and cai. The boost came on just about 800 rpms faster than before I replaced the stockie TD04 for the "Monstah". On my tune date my PT had 250 miles on her, we did a pull before doing any tuning at all, I put down 181.5 awhp at only 9psi CR:0.


Cheers,
~Wolf
WTi
You made those numbers on the stock td04 or the 19t upgrade?


I have been looking into a 19t after going through the vf39


I put down 199awhp/174tq on 8psi with the vf39, 270cc injectors and no tune! Wonder how well a 19t would work once tuned... :P
Sean2.5Black is offline   Reply With Quote
Old 07-04-2010, 11:48 AM   #1347
xsnapshot
Scooby Newbie
 
Member#: 170973
Join Date: Feb 2008
Location: Lincoln, NE
Vehicle:
2004 WRX 4EAT
PSM

Default

Quote:
Originally Posted by ForesterWTi View Post
haha I know it seems crazy, but I have not. She's my baby, and I really do love her. It's enough just to enjoy the now STi awhp of my 2.0 GF8 .

Cheers,
~Wolf
WTi
You do know that going WOT is not inherently bad right? I mean.....you ARE tuned for it. And you have an MBC, so your getting the same boost at 75% throttle as you would at 100% throttle.
xsnapshot is offline   Reply With Quote
Old 07-04-2010, 11:50 AM   #1348
xsnapshot
Scooby Newbie
 
Member#: 170973
Join Date: Feb 2008
Location: Lincoln, NE
Vehicle:
2004 WRX 4EAT
PSM

Default

Quote:
Originally Posted by Sean2.5Black View Post
You made those numbers on the stock td04 or the 19t upgrade?


I have been looking into a 19t after going through the vf39


I put down 199awhp/174tq on 8psi with the vf39, 270cc injectors and no tune! Wonder how well a 19t would work once tuned... :P

say what?

Sounds like you need a RRFPR and meth injection. Both should lower your IDC, which I can't imagine is anything less than 100....
xsnapshot is offline   Reply With Quote
Old 07-04-2010, 03:54 PM   #1349
Sean2.5Black
Scooby Specialist
 
Member#: 150647
Join Date: Jun 2007
Chapter/Region: NWIC
Location: Beaverton, OR
Vehicle:
98 Impreza 2.5RS
Ej20G hybrid

Default

Quote:
Originally Posted by xsnapshot View Post
say what?

Sounds like you need a RRFPR and meth injection. Both should lower your IDC, which I can't imagine is anything less than 100....
Yeah man, stock RS injectors...

I had 450cc injectors but ended up selling them and buying 800cc's so i could run meth and a bigger turbo... Now I have to wait to get a rotated mount and a tune...

I prefer e85 over meth :P
Sean2.5Black is offline   Reply With Quote
Old 07-05-2010, 11:54 AM   #1350
xsnapshot
Scooby Newbie
 
Member#: 170973
Join Date: Feb 2008
Location: Lincoln, NE
Vehicle:
2004 WRX 4EAT
PSM

Default

man the 16G is holding up well so far. Stuck my homemade MBC in and accidentally hit 25 psi for about 1000 RPM! Yikes!

I turned it down and now run 21 down to 18 or so. Running about 13 degrees of timing at peak torque, ramping up to about 24 at redline. Do you guys think 13 degrees on 21 psi is too much for the stock rods? Should i turn it down?

In other news, I adjusted my closed loop rich/lean limits, and am now targeting 15.2:1 gas equiv AFR. I was running rich before at 14.4:1 AFR in closed loop, so now its time to see what I can pull out of this turbo as far as gas mileage goes. So far i have noticed no loss in power going to 15.2:1 and the ECU seems to be happy.
xsnapshot is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
td04 19t blouch upgrade. WhiteBgeye02 Private 'Wanted' Classifieds 1 06-23-2010 08:35 PM
WTB td04 for 19t upgrade tanner127 Private 'Wanted' Classifieds 3 04-13-2010 08:04 PM
Blouch TD04 19T upgrade on 4EAT. Opinions Brock31 Transmission (AT/MT) & Driveline 6 12-17-2009 10:35 AM
Blouch TD04 19T Upgrade lackofhp Factory 2.5L Turbo Powertrain 8 10-31-2008 01:57 PM
TD04-19T questions. ringe Factory 2.5L Turbo Powertrain 6 06-07-2008 07:19 PM


All times are GMT -4. The time now is 03:29 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.