Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-25-2008, 11:31 PM   #1
jmlaser
Scooby Specialist
 
Member#: 125529
Join Date: Sep 2006
Chapter/Region: MWSOC
Location: Central Ohio
Vehicle:
02 WRX 18G EJ205
1/4 mi stock block record

Default Boost dropping/hesitation odd problem please help

Ok so THIS is where the car sits currently,... It runs very well as you can see. The problem is this... When we turned up the boost at the last tune to 21 it developed what I would desribe as boost stutter. It only does this under MAX load in 5th gear. When you hear the noise (which sounds like blaster fire from Star Wars) the boost drops aprox 1 to 2 psi and recovers quickly. As long as you stay in it at WOT you will get the Jitter/hesitation aprox every 2 seconds over and over again.
During the tune I had some electrical voltage issues and we thought it may be spark blowout due to weak spark. These issues have been fixed (Bad Neg. Batt. cable). I also thought the stock bpv was not holding boost and dumping so I replaced it with an APS to no avail.
I need to get this resolved so I can utilize my Meth kit or get a race gas tune(read Turn up the boost). Thanks in advance
* Registered users of the site do not see these ads.
jmlaser is offline   Reply With Quote
Old 10-26-2008, 12:07 AM   #2
Venividivichi
Scooby Newbie
 
Member#: 176793
Join Date: Apr 2008
Chapter/Region: Tri-State
Vehicle:
2009 pontiac G8
black

Default

what boost control system do u have?
Venividivichi is offline   Reply With Quote
Old 10-26-2008, 11:46 AM   #3
jmlaser
Scooby Specialist
 
Member#: 125529
Join Date: Sep 2006
Chapter/Region: MWSOC
Location: Central Ohio
Vehicle:
02 WRX 18G EJ205
1/4 mi stock block record

Default

Perrin style EBCS

I may try to get a log done today,.... I am certain the tune is fine or Jorge would have thrown frowns all over when it was on the dyno
jmlaser is offline   Reply With Quote
Old 10-26-2008, 12:02 PM   #4
gto7419
Scooby Specialist
 
Member#: 44256
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2002 WRX Wagon

Default

To be perfectly honest, it sounds like some sort of fuel cut... check your logs, your boost limit tables, and your boost control disable tables... And LOG!!!
gto7419 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
'03 Legacy w/ Odd Audio Problem - Please Help ejcookso Car Audio, Video & Security 1 10-07-2009 10:03 AM
05 WRX hesitation problem, please help. Sir Wagon Factory 2.0L Turbo Powertrain 5 11-28-2008 02:25 PM
Boost gauge install problem please help dolinga Factory 2.0L Turbo Powertrain 2 10-28-2001 10:24 PM
Hesitation problems......please help! Italiano Technical Forum Archive 6 08-22-2000 09:00 AM
Low RPM hesitation problems.. please help! (cont. ) Orbiter Technical Forum Archive 0 08-18-2000 03:47 AM


All times are GMT -4. The time now is 11:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.