Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > UTEC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-29-2008, 10:32 PM   #1
DjKlown
Scooby Newbie
 
Member#: 167104
Join Date: Dec 2007
Default 2.0 to 2.5L with blown 2.0 ecu????? AUTO

ok here is the lay down.

04 wrx auto with Utec. has blown B84 24 connector/internal (BCS), im doing the 2.5 hybrid setup(with all supporting mods), so i need a new stock ECU.( i beleive) i get 6.45 Volts coming out of the ECU and something over 10 V coming out of the piggy back.( i will re test over the weekend to confirm). so over 10V is good according to ALLDATA. to do the hybrid do i need to get a new UTEC that is meant for 2.5L or can i keep the UTEC i have now, and there is a setting in there to change displacement?


AUTOMATIC TRANS

so here the questions lazy ones....

1. do i need to change UTEC to a 2.5 L one or can i keep it and change a setting?

2. does the UTEC up the voltage for certain drivers? BCS specific...

3.could the piggyback been damaged at all from this bad connector...?


4. ANy other INFO be great...


Thanks

Mike
* Registered users of the site do not see these ads.
DjKlown is offline   Reply With Quote
Old 11-20-2008, 07:58 PM   #2
DjKlown
Scooby Newbie
 
Member#: 167104
Join Date: Dec 2007
Default

Update: Everything keeps checking out ok. all connectors(2) are all good.= blown ecu...

am able to go to 2.5l setting in the software.

any other info folks...

mike
DjKlown is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
o snap!! heads up to you guys with turbo 2.5's kumanchu Mid Atlantic Impreza Club -- MAIC 19 04-08-2008 11:15 AM
Newbie to this site with Stg 2 07 Sti Rollin07Sti Newbies & FAQs 7 10-07-2007 01:09 AM
Ok to run vf39 with stage 2 map? swiftwrx06 AccessPort 7 01-04-2007 01:07 PM
Where to find STI with blown motor? rebos123 Newbies & FAQs 9 05-02-2006 06:58 PM
what is the difference between a 2.5rs and the ts with the 2.2 engine for the gc8 bebeGDB Subaru Conversions 8 01-26-2004 10:08 AM


All times are GMT -4. The time now is 08:24 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.