Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-01-2008, 10:16 PM   #1
boxer4power
Scooby Newbie
 
Member#: 163545
Join Date: Nov 2007
Chapter/Region: Tri-State
Location: upstate NY / north lake tahoe
Vehicle:
2002 impreza 2.5ts
Green

Default 02 2.5l rough idle sputters...

so i noticed it first while i was coming home one night up this big mountain. the motor or something else would cut out for a second every time i would ease up on the gas a little. also when the car is at idle and i give it some gas it hesitates, sputters for a second and then revs up. once its up in the RPM's it runs ok. Sometimes it kinda cuts out when i shift but rarely. Today i was on my way up the mountain and the car barley made it. I had no power and had to stop the car and take off again keeping the revs up just to have a little power. I can't figure out what's causing it. any of you guys had a similar problem? thanks
* Registered users of the site do not see these ads.
boxer4power is offline   Reply With Quote
Old 11-02-2008, 01:44 AM   #2
warpspeedwrx
Scooby Newbie
 
Member#: 36318
Join Date: May 2003
Chapter/Region: NWIC
Location: OR
Vehicle:
2002 wrx
sold :(

Default

are you up to date with your maintenance? if not i would start with a tune up . spark plugs , fuel filter etc and go from there
warpspeedwrx is offline   Reply With Quote
Old 11-02-2008, 10:37 AM   #3
soulhassorrow
Scooby Specialist
 
Member#: 150732
Join Date: Jun 2007
Chapter/Region: NWIC
Location: Chicago/Malmstrom AFB
Vehicle:
2011 WRXXXX
LRP

Default

yea sounds like you need a tune-up!!!unless you already did one, it could be your throttle position sensor!!!
soulhassorrow is offline   Reply With Quote
Old 11-02-2008, 07:27 PM   #4
boxer4power
Scooby Newbie
 
Member#: 163545
Join Date: Nov 2007
Chapter/Region: Tri-State
Location: upstate NY / north lake tahoe
Vehicle:
2002 impreza 2.5ts
Green

Default

yeah thats what i figured it probably is. I replaced the fuel filter not that long ago... couldve just been a bad tank of gas or something. ill start with that.
boxer4power is offline   Reply With Quote
Old 11-04-2008, 11:18 AM   #5
bobko
Scooby Newbie
 
Member#: 64646
Join Date: Jun 2004
Location: Northern Virginia
Vehicle:
1995 Legacy wagon
Green

Default

A leaky vacuum line will cause the engine to run rough at idle and can cause the engine to stall. Check all the rubber vacuum lines to see if there is a leak. With the engine running, flex the hoses and listen for hissing air. The fix can be as cheap as a new $1 length of hose.

Good luck!

--Bob
bobko is offline   Reply With Quote
Old 11-04-2008, 09:04 PM   #6
Burnout
Scooby Specialist
 
Member#: 4721
Join Date: Mar 2001
Chapter/Region: South East
Location: Asheville
Vehicle:
2002 2.5 RS
1997 Brighton

Default

If you still have problems after the tune-up I would suspect the A/F sensor. I'd hook it up to a scan tool and check the Short term and long term fuel trims. If either is +/- 10% or more then thats probably going to be the calpret. There is also a reprogram for some 02's, you would have to go to a dealership to check if it applies to your car.
Burnout is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1995 2.2 liter rough idle and an occasional stall stevefazek Normally Aspirated Powertrain 2 09-20-2009 11:16 PM
2.5L Hybrid Idle Problem cn4m Built Motor Discussion 4 05-03-2009 10:37 AM
'99 RS 2.5L - Erratic Idle, CEL code P0106 ?? w chapman Service & Maintenance 0 06-04-2006 08:35 PM
99-02 2.5L Service Information OKRS25 Alaskan Impreza Club Forum -- AKIC 2 02-25-2004 02:42 PM
00-02 2.5L ecu recall? inpreza kid Canada Region Forum 7 10-30-2002 11:19 AM


All times are GMT -4. The time now is 04:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.