Welcome to the North American Subaru Impreza Owners Club Saturday May 23, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-04-2008, 11:15 AM   #1
eodtech
Scooby Newbie
 
Member#: 172492
Join Date: Feb 2008
Location: Grafenwohr, Germany
Vehicle:
06 Evo IX, JERRV
Graphite Grey

Default Oil galley plug leak? Or crush gaskets on oil sending line?

I've had major problems with my sending line blowing out, replaced it, missed installing the return line, replaced again, reinstalled, and now i'm still having a slow oil leak. Its drip drip drip, as opposed to POOOUUURRRR. I've heard quite a few times that there is a good chance it's my galley plug gasket / plug or i figure that there is a good chance that my crush gaskets from the oil sending line are bad. Any suggestions? I'm sooooooo horribly frustrated with this car, i haven't been running in about 4 months.
* Registered users of the site do not see these ads.
eodtech is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-04-2008, 11:26 AM   #2
tazswing
Scooby Specialist
 
Member#: 63767
Join Date: Jun 2004
Chapter/Region: NWIC
Location: PDX
Vehicle:
2009 OXT 5-spd
2011 STi hatch

Default

So I guess in my ignorance I am not sure the application you are talking about. My oil plug has my oil temp sensor embedded in the middle but I am not running oil pressure off there. If I do not replace my crush washer with every oil change, it will leak. If it gets replaced, no problems. But maybe you are talking about oil pressure?
tazswing is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: Subaru Oil Galley Plug for pressure sender or sensor Gro Harlem Engine/Power/Exhaust 4 06-19-2009 02:48 PM
wd-40 on oil galley plug??? litowrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 04-26-2009 07:33 PM
WTB: Oil galley plug for oil sensor. 04RCSTI Private 'Wanted' Classifieds 4 07-19-2006 03:37 PM
Oil Galley plug or Sandwich adapter? audiophil2 Interior & Exterior Modification 10 08-18-2005 02:26 AM
Oil galley plug for temp probe leaking like crazy! CapeRex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 3 07-03-2005 09:07 PM


All times are GMT -4. The time now is 12:40 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.