Welcome to the North American Subaru Impreza Owners Club Thursday November 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-10-2008, 08:01 PM   #1
supasweetr34skyline
Scooby Specialist
 
Member#: 113060
Join Date: Apr 2006
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2000 Built GC8
Aiming for 10's

Default 1993-1996 Need Picture Help!

ok, yet another swap and I may have problems with my fuse box. I lost my orginal ones that went to my 1996 brighton harness. I ordered 1996 boxes and I noticed an extra plug and fuse on the new fuse boxes. IS THERE ANYBODY THAT HAS AN EARLY YEAR 1996 IMPREZA OR LOWER year that can verify that this fuse isnt there?



* Registered users of the site do not see these ads.
supasweetr34skyline is offline   Reply With Quote
Old 11-10-2008, 08:57 PM   #2
gc8awdsti
Scooby Specialist
 
Member#: 192848
Join Date: Oct 2008
Chapter/Region: South East
Location: The Carolinas.
Vehicle:
1998 GC8 rsti
BDP

Default

hey that is def diffrent from my 1995 ej20g/ 98 rs.
gc8awdsti is offline   Reply With Quote
Old 11-10-2008, 11:40 PM   #3
Matt Monson
Scooby Guru
 
Member#: 832
Join Date: Jan 2000
Chapter/Region: RMIC
Location: Teh Ghetto Garage, CO
Vehicle:
99 2.5RS, '85 911
'73 914 and 2012 BRZ

Default

That fuse is not present on my '93 Impreza. But if memory serves it was present on '91 Legacy. I'd have to look up some diagrams but just pulling from memory here I think it might be for the ABS.
Matt Monson is offline   Reply With Quote
Old 11-11-2008, 01:33 AM   #4
gc8awdsti
Scooby Specialist
 
Member#: 192848
Join Date: Oct 2008
Chapter/Region: South East
Location: The Carolinas.
Vehicle:
1998 GC8 rsti
BDP

Default

the wires do run towards the abs unit area through the thick wire loom. also his ecu isnt getting any power if i heard him correct. cmon guys he is trying to get this car going any help would be great. good luck kev.
gc8awdsti is offline   Reply With Quote
Old 11-11-2008, 11:06 AM   #5
supasweetr34skyline
Scooby Specialist
 
Member#: 113060
Join Date: Apr 2006
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2000 Built GC8
Aiming for 10's

Default

Thanks everybody. Id like to know what these 2 wires are for Because my Ecu is not getting any power! All my accessories work though(other fuse box is ok).
supasweetr34skyline is offline   Reply With Quote
Old 11-11-2008, 03:34 PM   #6
azn0boi04
Scooby Specialist
 
Member#: 164172
Join Date: Nov 2007
Chapter/Region: NWIC
Location: Covington, WA
Vehicle:
97 OBS EJ20G ZILLA
87 GL

Default

hey PM me if u still need help... i have USDM 95 impreza L with JDM 94WRX ej20g... fuse boxes are the from the USDM 95 impreza L
azn0boi04 is offline   Reply With Quote
Old 11-12-2008, 05:17 PM   #7
colchon
Scooby Newbie
 
Member#: 133812
Join Date: Dec 2006
Default

i'll look into mine, y have the full spec one, abs and airbag 1995/1996! ansewer later if you need it!
colchon is offline   Reply With Quote
Old 11-29-2008, 05:48 AM   #8
supasweetr34skyline
Scooby Specialist
 
Member#: 113060
Join Date: Apr 2006
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2000 Built GC8
Aiming for 10's

Default

bump? i still dont have any answers :-/
supasweetr34skyline is offline   Reply With Quote
Old 11-30-2008, 09:52 PM   #9
Wannabe WRX
Scooby Newbie
 
Member#: 130623
Join Date: Oct 2006
Chapter/Region: MAIC
Location: Philadelphia, PA
Vehicle:
1999 Impreza RS
Rally Blue

Default

95 L Coupe AWD checking in.

That fuse is there.
Wannabe WRX is offline   Reply With Quote
Old 12-01-2008, 03:29 AM   #10
i_c_the_light
Scooby Guru
 
Member#: 88618
Join Date: Jun 2005
Chapter/Region: SCIC
Location: New Zealand
Vehicle:
1994 Legacy
"The Silver Slug"

Default

From memory, that is for the ABS. I have an MY90 Legacy GT and it is not there. Just a big gaping hole.
i_c_the_light is offline   Reply With Quote
Old 01-15-2009, 04:35 AM   #11
supasweetr34skyline
Scooby Specialist
 
Member#: 113060
Join Date: Apr 2006
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2000 Built GC8
Aiming for 10's

Default

bump. can somebody please post pictures of a 93-96 Manual Tranny 1.8 BRIGHTON under hood fuse box?!
supasweetr34skyline is offline   Reply With Quote
Old 01-15-2009, 07:29 AM   #12
RealDealTarheel
Scooby Specialist
 
Member#: 142447
Join Date: Mar 2007
Chapter/Region: South East
Location: Best BBQ State In America
Vehicle:
**** Texas

Default

I have a 94 WRX and it is there, I pulled it and the car started just fine. The lid said something like "H/L" Relay, though it didn't quite correspond with the location in the box and the lid.
RealDealTarheel is offline   Reply With Quote
Old 01-15-2009, 01:29 PM   #13
kingsubi
Scooby Specialist
 
Member#: 19239
Join Date: May 2002
Chapter/Region: NESIC
Location: Maine/Indiana
Vehicle:
2011 WRX
SWP

Default

Its a 45A fuse b/w the alternator and the ABS pump.
kingsubi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone have a pioneer avic u310bt need some help cosanostra Car Audio, Video & Security 5 06-04-2010 01:20 PM
WTB 1993-1996 Impreza L parts AKGC8 Mid Atlantic Impreza Club -- MAIC 0 04-14-2004 11:59 PM
1993-1996 front seat rails N/A Mid Atlantic Impreza Club -- MAIC 13 02-08-2003 05:27 PM
1993-1996 Workshop Manual larkspeed Service & Maintenance 0 10-05-2002 12:27 PM


All times are GMT -4. The time now is 01:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.