Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-11-2008, 09:08 PM   #1
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Exclamation Factory Alarm/Keyless Entry...All you need to know!!

I have seen quite a few posts regarding the Factory Alarm Keyless Entry System. Hopefully this will answer a majority of your questions without having to start another thread.....

How do I program a remote?
Depending on the year of your vehicle, programming the remote is pretty simple:

For 2001-2006 Models:
(the oblong remote with either 2 grey buttons or a blue and orange button)
EDIT: Replacement remotes are the newer teardrop shape, but are programmed the same way. The 'trunk' button is another way to put the alarm in and out of valet mode.

**Make sure all windows, doors, hood and trunk are closed.
**Get in and close the door.
**Turn the key in the ignition to the 'ON" position 10 times within 15 seconds
**You should hear the horn/chirp
**Open and close the drivers side door.
**Press one button on the remote
**Open and close the drives side door
**If you have other remotes, repeat the last 2 steps for all remotes
**Remove key from the ignition
**The horn should beep/chirp again
**Check remote(s)

NOTE: If you mess up during any of the steps, remove the key from the ignition, open and close the drivers side door and start over.

NOTE: You must program all remotes at the same time. Remotes not programmed at the same time will no longer work.

PROBLEMS:

1. I can't get the horn to beep/chirp after turning the key in the ignition:
**Make sure you are turning the key fast enough.
**Make sure the car is not in valet mode (If you have a working remote.--See below for info on valet mode)
**Disconnect the battery for approx. 1 min. This will reset the alarm back to factory settings. HOWEVER: It is possible the alarm will start going off. Turn the key in the ignition 3 times and the alarm will stop.

2. The remote did not program:
**Try programming again.
**Check/replace the remote battery
**Try another remote if you have one. If the others took the programming, the remote is defective/dead battery

3. The door locks unlock/lock but there is not horn/chirp
**See below 'VALET MODE"
**See below 'Turn Off/On Horn Chirp'


For 2006-2008 Models:
(the 'teardrop' remote)

This process is a little more difficult. You can either attempt the process below or take the vehicle to a dealer.

NOTE: You need the transmitters 'ID' code. This is either located on the bag the remote came in or inside the remote on the circuit board. It is an 8 digit number.

**Close all doors, trunk and windows.
**Sit in vehicle and close the door
**Perform the following steps within 45 seconds
**Open and close the drivers side door once
**Turn the key in the ignition 10 times within 15 seconds. You will hear a beep. If you do not hear a beep, start over.
**Open and close the drivers side door again within 15 seconds of the beep. You will hear a tone that lasts for 30 seconds.
**Before the tone stops, press the door lock switch (on the door) to the lock position the same number of times as the first digit of the code. (For example, if the 1st digit is a 2, press lock 2 times). Do not wait more than 5 seconds between pressing lock each time
**The tone will stop when you start pressing lock.
**After entering the number, push the door lock switch to unlock within 5 seconds.
**Perform the steps with pressing lock and unlock for each additional number, remembering to press unlock between each number. For example, for the number 1234, press lock 1 time, then unlock, lock 2 times, then unlock, lock 3 times, then unlock, lock 4 times, unlock....
**After the 8th digit, the tone will sound again for 30 seconds
** Before the tone stops, repeat the lock/unlock steps and enter the code again
**When finished entering the code the second time, a beep will be heard and the door locks will operate on their own, indicating the remote is programmed.
**If you need to program another remote, start with the open and close door step for each additional remote

NOTE: You only have to program new remotes. Old remotes will still work without reprogramming them again. They each have their own individual codes.

PROBLEMS:

1. I didn't hear the chirp/tone
**You waited too long between steps, you need to start over.

2. I heard all the beeps/tones, but the remote still does not work
**The remote is defective.


My exterior lights no longer flash when I lock/unlock with the remote:

The vehicle is in VALET MODE
**Make sure the alarm is disarmed.
**Open the drivers side door.
**Press and hold unlock on the remote until the security light on the dash stops flashing.

EDIT: If you used to have an older style remote for MY 02-06, the trunk release button on the replacement (teardrop) remote can also be used to put the alarm in and out of valet mode.

NOTE: To put back in VALET MODE, repeat the above steps.

The security light on my dash is flashing:

If the light is flashing blink, pause, blink, pause, etc:
**This means the security system is armed. This is normal when the system is armed.

If the light is flashing blink blink, pause, blink blink, pause, etc:
**The alarm is in VALET MODE, see above.

The horn no longer beeps/chirps when I lock/unlock the car:

**Make sure all the doors, windows, trunk and hood are closed.
**Disarm the alarm.
**Press and hold BOTH buttons on the remote until the horn/chirp sounds.

NOTE: To turn the beep/chirp back off, repeat the steps above.


My alarm goes off when I use the key to unlock the door:

**Once the door is open, turn the key in the ignition 3 times to stop the alarm.
**OR, put the alarm in Valet Mode, see above
**Use the remote!

I Just replaced/disconnected my battery and now my lights are blinking and there is a clicking noise that can be heard inside the vehicle:

You need to reset your alarm:

**If you have an older model vehicle, 2001 and under, and have a remote, press unlock on the remote
**If you have an older model vehicle, 2001 and under, there is a reset button for the alarm located on the drivers side, left side of steering colum, down near where the dash trim ends. (Your owners manual has a pretty good picture of where it is located and what it looks like) Press and hold button for a second or two until the alarm is reset.


The horm/chirp does not work when I press lock or unlock. There is no sound:

**Try seeing if your alarm chirp/horn is disabled. (See above)
**If not, try information in this thread:

http://forums.nasioc.com/forums/showthread.php?t=608657


If I forgot anything, let me know and I will add it!!
* Registered users of the site do not see these ads.

Last edited by RexyGirl; 10-17-2012 at 09:04 PM.
RexyGirl is offline   Reply With Quote
Old 11-11-2008, 09:13 PM   #2
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

is the valet mode for the lights for bugeyes as well?
Jncominco2 is offline   Reply With Quote
Old 11-11-2008, 09:23 PM   #3
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Jncominco2 View Post
is the valet mode for the lights for bugeyes as well?
Yes, it applies to all 2001-2006 vehicles. The 2008-2009 vehicles have it as well, but the process is a little different for turning it on and off.
RexyGirl is offline   Reply With Quote
Old 11-11-2008, 09:29 PM   #4
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

thank you! that always bugged the crap out of me, and the horn was way too loud for night time hah
Jncominco2 is offline   Reply With Quote
Old 11-11-2008, 09:37 PM   #5
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

ok i actually tried it, and my lights arent flashing. i held it for a good 30 seconds and i dont see anything changing
Jncominco2 is offline   Reply With Quote
Old 11-11-2008, 10:40 PM   #6
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Jncominco2 View Post
ok i actually tried it, and my lights arent flashing. i held it for a good 30 seconds and i dont see anything changing
Make sure the car is disarmed
Open the drivers side door
Press and hold unlock on the remote for about 5 seconds
The light on the dash should stop flashing
RexyGirl is offline   Reply With Quote
Old 11-11-2008, 11:19 PM   #7
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

ya im not seeing anything happen
i dont even see a light on the dash....where should it be located?
Jncominco2 is offline   Reply With Quote
Old 11-11-2008, 11:43 PM   #8
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

The security light is located in the lower center of the instrument panel.

Are you sure you have a factory alarm?
Does your remote otherwise work?
RexyGirl is offline   Reply With Quote
Old 11-12-2008, 12:34 AM   #9
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

ya its a factory alarm, and yes my remote works
Jncominco2 is offline   Reply With Quote
Old 11-12-2008, 09:28 PM   #10
Wrx1624
Scooby Newbie
 
Member#: 186862
Join Date: Aug 2008
Location: Chicago
Vehicle:
05 WRX
Black

Default

what's the purpsoe of putting your car in valet mode?
Wrx1624 is offline   Reply With Quote
Old 11-13-2008, 11:22 AM   #11
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Wrx1624 View Post
what's the purpsoe of putting your car in valet mode?
Think of the word 'valet'. The most common use of this feature is when you give the 'valet' your key, and not your remote. If you open the door with the key when it is not in valet mode, the alarm will go off. If it is in valet mode, it disables that part of the alarm. It also works good if you only have one remote and two different people drive the car with their own set of keys.
RexyGirl is offline   Reply With Quote
Old 11-13-2008, 02:24 PM   #12
Aaron'z 2.5RS
Scooby Guru
 
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
Vehicle:
'00 RS/WRX Stg5
'98 RS Stock

Default

Wow, YOU ROCK...!!!

I don't mess with factory alarms anymore, but I see the questions ALLLLLLLLLL the time... bout time this got put up...

+1000
Aaron'z 2.5RS is offline   Reply With Quote
Old 11-13-2008, 03:49 PM   #13
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

so rexy, any ideas on why i cant get my lights to flash when locking/unlocking?
Jncominco2 is offline   Reply With Quote
Old 11-13-2008, 04:00 PM   #14
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Quote:
Originally Posted by Jncominco2 View Post
so rexy, any ideas on why i cant get my lights to flash when locking/unlocking?

Are you sure your car actually has the full alarm/security system? Keyless entry was standard, but the security upgrade was an option. If you don't have the alarm, the lights won't flash on lock/unlock and the security light on the dash will not work.
To verify that you have the alarm-
-Look under the hood, there should be an extra horn on the passenger strut tower. That is the security horn.
-Look for the security module which is located under the center armrest next to the e-brake.
-Lock the car with the remote, then open the door manually with the key. If you have an alarm it will go off (unless it's in valet mode).
Mulder is offline   Reply With Quote
Old 11-13-2008, 04:03 PM   #15
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

Quote:
Originally Posted by Mulder View Post
Are you sure your car actually has the full alarm/security system? Keyless entry was standard, but the security upgrade was an option. If you don't have the alarm, the lights won't flash on lock/unlock and the security light on the dash will not work.
To verify that you have the alarm-
-Look under the hood, there should be an extra horn on the passenger strut tower. That is the security horn.
-Look for the security module which is located under the center armrest next to the e-brake.
-Lock the car with the remote, then open the door manually with the key. If you have an alarm it will go off (unless it's in valet mode).
ok ill look when i get off work, thanks
im guessing its just the keyless entry because of what you said, but the remote says
Lock/Arm/Panic on the orange button
and Unlock/Disarm on the blue button
not sure if thats just how they made all of them
i have the option for the horn too with pushing both buttons
dunno if this helps to clarify it, but ill still try it
Jncominco2 is offline   Reply With Quote
Old 11-13-2008, 04:13 PM   #16
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Yup the remotes are all the same, the keyless system will sound the horn on lock/unlock and has a panic function. The security module is an add-on that provides the alarm functionality/light flashing/security light.
Mulder is offline   Reply With Quote
Old 11-13-2008, 05:51 PM   #17
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

i dont see the security thing by the ebrake, so i guess not
i see the place above the mirror switches thats empty
Jncominco2 is offline   Reply With Quote
Old 11-16-2008, 11:30 PM   #18
chapelhilldoc
Scooby Newbie
 
Member#: 39043
Join Date: Jun 2003
Vehicle:
2004 WRX Wagon
Silver

Default Valet Mode without lights flashing

For the past 5 years on my 04 WRX, I have had the alarm turned off, and never had any flashing lights after I closed and locked the door (looking in the window, there is nothing flashing).

Now, all of a sudden, after the dealer had the car for an unrelated repair, when I turn off the alarm, it does that 2-flash valet mode thing. I don't want it to flash at all! Can anyone help me out?

Thanks!
chapelhilldoc is offline   Reply With Quote
Old 11-16-2008, 11:35 PM   #19
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

i imagine this is what your talking about...
My exterior lights no longer flash when I lock/unlock with the remote:

The vehicle is in VALET MODE
**Make sure the alarm is disarmed.
**Open the drivers side door.
**Press and hold unlock on the remote until the security light on the dash stops flashing.

NOTE: To put back in VALET MODE, repeat the above steps.

same steps should apply i would guess
Jncominco2 is offline   Reply With Quote
Old 11-16-2008, 11:41 PM   #20
chapelhilldoc
Scooby Newbie
 
Member#: 39043
Join Date: Jun 2003
Vehicle:
2004 WRX Wagon
Silver

Default

Thanks....but I mean the little red security light is now flashing when it never was before. I want the alarm off, but not have the little red security light be flashing at all.
chapelhilldoc is offline   Reply With Quote
Old 11-16-2008, 11:51 PM   #21
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

If the light is flashing blink, pause, blink, pause, etc:
**This means the security system is armed. This is normal when the system is armed.

If the light is flashing blink blink, pause, blink blink, pause, etc:
**The alarm is in VALET MODE, see above.
Jncominco2 is offline   Reply With Quote
Old 11-16-2008, 11:58 PM   #22
chapelhilldoc
Scooby Newbie
 
Member#: 39043
Join Date: Jun 2003
Vehicle:
2004 WRX Wagon
Silver

Default One last time

Thanks again....but....just to be 100% clear....I want to have no security light blinking ever after I lock the car. It seems now if the alarm is on, it blinks once. If I'm in valet mode, it blinks twice. I don't want it to blink at all after I lock it up and walk away.

Maybe I'm crazy...it's just that for so long, it never blinked.
chapelhilldoc is offline   Reply With Quote
Old 11-17-2008, 12:03 AM   #23
Jncominco2
Scooby Specialist
 
Member#: 170212
Join Date: Jan 2008
Chapter/Region: RMIC
Location: West Point, Utah
Vehicle:
02 WRX Sedan
MBP

Default

well if you arm your car, its going to blink regardless
and yes, being in valet mode will make it blink twice
you can make it blink once by turning it off
it will always blink at least once if you arm it...i guess you could always just disconnect the bulb
Jncominco2 is offline   Reply With Quote
Old 11-17-2008, 12:07 AM   #24
chapelhilldoc
Scooby Newbie
 
Member#: 39043
Join Date: Jun 2003
Vehicle:
2004 WRX Wagon
Silver

Default

Yes, that's the thing. My alarm has been off for over 5 years now, but it never did the blinking twice valet thing until now. I wish there was an off mode, but not in valet mode.
chapelhilldoc is offline   Reply With Quote
Old 11-17-2008, 12:09 AM   #25
Board Dad
Scooby Newbie
 
Member#: 193776
Join Date: Nov 2008
Chapter/Region: NESIC
Location: Wells, Me / Mittersill Village
Vehicle:
2003 Impreza WRX
Platinum Silver

Question Not sure what to look for

I have looked all over and found photos, and part numbers for the remote entry, and security module. I am certain that my car had these to begin with, as there is a logo about factory security. I don't have a keyless entry remote provided with the car when I bought it, and there is a horn under the hood (which has had wires cut to it) I already bought a new remote (hoping that it would just program, and go) Now I don't want to buy anything I don't need, but the symptoms are this: I can only lock/unlock driver door with key, or the tab next to inside door handle. The buttons on driver or pass. side un/lock all 3 other doors though. I am wondering if this sounds like someone has made changes on purpose, or if this car was a victim of a crime sometime way back? I saw the mention that a security module would be found under the armrest, so I will look there in the morning. Any help or guidance would be sweet.
Board Dad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory Alarm + Keyless entry from 04 FXT Skidd Interior/Dressup/Audio & Security 0 01-22-2009 08:26 PM
Factory alarm/keyless entry install - Anyone want to help?! NickWRX Tri-State Area Forum 3 07-06-2008 09:22 PM
All you need to know about ass hair. WRick Off-Topic 22 01-23-2006 07:22 PM
Factory Alarm / Keyless entry Woody Vancouver Impreza Club Forum -- VIC 3 04-21-2002 11:51 PM
Factory alarm/keyless entry on MY01 Safir Car Audio, Video & Security 1 02-08-2001 01:01 PM


All times are GMT -4. The time now is 03:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.