Welcome to the North American Subaru Impreza Owners Club Tuesday September 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-04-2012, 08:27 PM   #376
Rickh_779
Scooby Newbie
 
Member#: 305882
Join Date: Jan 2012
Chapter/Region: MWSOC
Vehicle:
2012 Impreza 5-door
Metalic gray

Default remote start

Do you know a way to keep the car running when you use the remote start to start the car. When you open the door the car turns off and you have to restart it. Can you by pass this option so you dont have to restart it just put the key in and turn it to "run"?
* Registered users of the site do not see these ads.
Rickh_779 is offline   Reply With Quote
Old 01-07-2012, 08:32 PM   #377
abooker13
Scooby Newbie
 
Member#: 306184
Join Date: Jan 2012
Chapter/Region: South East
Location: Atlanta
Vehicle:
2006 Impreza RS
Silver

Default

car: '06 impreza rs, auto transmission, type "a" factory audio


1. i just installed a new pioneer head unit (no new speakers) into my car with the guides on the forum and everything went fine with the install. my problem now is that my remote to the car (factory lock/unlock only) doesn't work - lock, unlock, panic (hold lock) nothing.

i think it's probably something easy but i have checked all my connections and they look solid and i couldn't find anything in the search function. the remote was working fine literally right before i did the install and i've tried the battery and that didn't fix it.


2. also, i think this is unrelated, but since it occurred during installation i wanted to see if this is common or heard of: the interior light above the center console went out completely. i reckon it's just a bulb but i wanted to throw that in here in case someone heard of this happening when wiring the audio up.


anyone have any suggestions or had these happen? thanks for the views and replies in advance.


[edit]: fixed by changing one fuse, 20A

Last edited by abooker13; 01-10-2012 at 12:40 PM.
abooker13 is offline   Reply With Quote
Old 01-14-2012, 07:51 PM   #378
Browzer
Scooby Newbie
 
Member#: 306433
Join Date: Jan 2012
Chapter/Region: Tri-State
Location: Orange County NY
Vehicle:
2005 Subaru WRX
Black

Default

I have an 05 wrx, but the dealer gave me the tear drop one.

is this a mistake? can I program this keyless entry to my car? or do I have to get a new one...which Id like to not have to do
Browzer is offline   Reply With Quote
Old 01-14-2012, 09:08 PM   #379
It_wasntt_me
Scooby Specialist
 
Member#: 300955
Join Date: Nov 2011
Chapter/Region: Tri-State
Location: Bethel
Vehicle:
2004 WRX
Java Black Pearl

Default

Quote:
Originally Posted by Browzer
I have an 05 wrx, but the dealer gave me the tear drop one.

is this a mistake? can I program this keyless entry to my car? or do I have to get a new one...which Id like to not have to do
It will work fine
It_wasntt_me is offline   Reply With Quote
Old 01-14-2012, 09:21 PM   #380
Browzer
Scooby Newbie
 
Member#: 306433
Join Date: Jan 2012
Chapter/Region: Tri-State
Location: Orange County NY
Vehicle:
2005 Subaru WRX
Black

Default

Quote:
Originally Posted by It_wasntt_me View Post
It will work fine
Thanks man! gonna give it a shot now
Browzer is offline   Reply With Quote
Old 01-15-2012, 05:30 AM   #381
SamOntario
Scooby Newbie
 
Member#: 302645
Join Date: Dec 2011
Chapter/Region: E. Canada
Location: NC or ON
Vehicle:
2005 Impreza RS
Red

Default

Works on my 05 2.5RS and I have to program it with 04's method. Actually the tear drops came with the car and I bought 2 more used.

Quote:
Originally Posted by Browzer View Post
I have an 05 wrx, but the dealer gave me the tear drop one.

is this a mistake? can I program this keyless entry to my car? or do I have to get a new one...which Id like to not have to do

Last edited by SamOntario; 01-15-2012 at 05:34 AM. Reason: Adding more info.
SamOntario is offline   Reply With Quote
Old 01-15-2012, 12:55 PM   #382
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

Question... I got the teardrop key to work on my outback sport, but thing is that it kind sometimes doesn't respond to the clicks.

Like I have to click the button a few times before the car will actually respond to it. Is this normal or should I try programming?
theoutbackdream is offline   Reply With Quote
Old 01-15-2012, 03:39 PM   #383
SamOntario
Scooby Newbie
 
Member#: 302645
Join Date: Dec 2011
Chapter/Region: E. Canada
Location: NC or ON
Vehicle:
2005 Impreza RS
Red

Default

You may need a new battery.
SamOntario is offline   Reply With Quote
Old 01-16-2012, 01:30 PM   #384
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Browzer View Post
I have an 05 wrx, but the dealer gave me the tear drop one.

is this a mistake? can I program this keyless entry to my car? or do I have to get a new one...which Id like to not have to do
The old style remotes are no longer available and the teardrops are being used as the replacements.

It will work fine
RexyGirl is offline   Reply With Quote
Old 01-16-2012, 01:32 PM   #385
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by theoutbackdream View Post
Question... I got the teardrop key to work on my outback sport, but thing is that it kind sometimes doesn't respond to the clicks.

Like I have to click the button a few times before the car will actually respond to it. Is this normal or should I try programming?
It it works once and awhile, it is a remote issue, probably not a programming issue.

Try replacing the battery first (its a watch battery). Also, make sure there is no interference in the area......(the owners manual describes the types of interference that influence how the remote works). Also, make sure you are close enough to the vehicle.
RexyGirl is offline   Reply With Quote
Old 01-18-2012, 12:57 PM   #386
BugeyedWREX
Scooby Specialist
 
Member#: 141734
Join Date: Feb 2007
Chapter/Region: South East
Location: Camp Lejeune
Vehicle:
02 BUG-I WAGON
EJ25 Hybrid, 314HP- 280tq

Default

My alarm won't disarm after turning key 3 times. What could be my problem? I've reset the battery, unplugged the turbo timer, and reconnected the green wire to the keyless entry module.
BugeyedWREX is offline   Reply With Quote
Old 01-23-2012, 08:45 PM   #387
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by BugeyedWREX
My alarm won't disarm after turning key 3 times. What could be my problem? I've reset the battery, unplugged the turbo timer, and reconnected the green wire to the keyless entry module.
Unplug the green connector under the dash.....(your check engine light is probably flashing

It's also possible it's an aftermarket alarm
RexyGirl is offline   Reply With Quote
Old 01-27-2012, 01:17 AM   #388
shawnleechang
Scooby Newbie
 
Member#: 295786
Join Date: Sep 2011
Chapter/Region: NWIC
Location: Sammamish
Vehicle:
2005 WRX
OBP

Default

I called in the dealership and they asked for $130 for a keyless remote. I decided to buy from ebay for $40. Hopefully, it works because it's definitely much cheaper.


Also, I'm buying an additional keyless remote, does that mean I have to reactivate my current fob right after I program the new one?

Last edited by shawnleechang; 01-27-2012 at 02:51 AM.
shawnleechang is offline   Reply With Quote
Old 01-30-2012, 10:56 AM   #389
BugeyedWREX
Scooby Specialist
 
Member#: 141734
Join Date: Feb 2007
Chapter/Region: South East
Location: Camp Lejeune
Vehicle:
02 BUG-I WAGON
EJ25 Hybrid, 314HP- 280tq

Default

Quote:
Originally Posted by RexyGirl

Unplug the green connector under the dash.....(your check engine light is probably flashing

It's also possible it's an aftermarket alarm
I have a cel but it's from my maf. It is def the factory alarm, and keyless entry.
BugeyedWREX is offline   Reply With Quote
Old 02-02-2012, 09:54 PM   #390
Asanti185
Scooby Newbie
 
Member#: 296249
Join Date: Sep 2011
Location: Omhah, NE
Vehicle:
03 wrx wagon
white

Default

I have an 03 wrx with the factory security system. Recently I had the fuel line recall done by a dealership and after getting it back the lights dont flash when I lock/unlock my car and the security light blinks 2 times, pause, then 2 times untill I turn the key to the on position.

I called the dealer and they said I need to come back so they can hook something up to reset it but their hours are the same as mine so I was wondering if there is a different way to reset it so it works again.
Asanti185 is offline   Reply With Quote
Old 02-03-2012, 11:40 PM   #391
Asanti185
Scooby Newbie
 
Member#: 296249
Join Date: Sep 2011
Location: Omhah, NE
Vehicle:
03 wrx wagon
white

Default

^Anyone??
Asanti185 is offline   Reply With Quote
Old 02-04-2012, 11:45 AM   #392
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: Mountain View, California
Vehicle:
2013 WRX Limited
SWP

Default

^Make sure its not in valet mode. Look at first post in this thread about it.
theoutbackdream is offline   Reply With Quote
Old 02-04-2012, 02:14 PM   #393
Asanti185
Scooby Newbie
 
Member#: 296249
Join Date: Sep 2011
Location: Omhah, NE
Vehicle:
03 wrx wagon
white

Default

Thats what I thought it was in at first but did what it said and did not work.
Asanti185 is offline   Reply With Quote
Old 02-17-2012, 05:01 PM   #394
shawnleechang
Scooby Newbie
 
Member#: 295786
Join Date: Sep 2011
Chapter/Region: NWIC
Location: Sammamish
Vehicle:
2005 WRX
OBP

Default

I'm going to program my sisters Impreza 06. You have two programming methods for the 2006, which one do I use?

I programmed my 2005 WRX easily with the teardrop key fob but i'm not sure which method i'm suppose to be using for the 2006 impreza.
shawnleechang is offline   Reply With Quote
Old 02-18-2012, 05:01 PM   #395
cphillips515
Scooby Newbie
 
Member#: 310148
Join Date: Feb 2012
Default

I just bought an '05 Impreza 2.5RS wagon, but it didn't come with a key. I bought a teardrop remote on eBay, and I was able to get the unlock button to work, but not the lock button. I thought a teardrop should work on an '05...any suggestions?
cphillips515 is offline   Reply With Quote
Old 02-20-2012, 04:32 AM   #396
juan03
*** Banned ***
 
Member#: 309763
Join Date: Feb 2012
Default

thank you! that always bugged the crap out of me
juan03 is offline   Reply With Quote
Old 02-21-2012, 06:16 PM   #397
shawnleechang
Scooby Newbie
 
Member#: 295786
Join Date: Sep 2011
Chapter/Region: NWIC
Location: Sammamish
Vehicle:
2005 WRX
OBP

Default

I'm trying to do the 2006 impress. After doing the 10 turns, I hear nothing but when I open and close the door, I hear the tone sound for 30 sec. Do I need to hear the chirp/horn after turning 10 times?
shawnleechang is offline   Reply With Quote
Old 02-22-2012, 02:25 PM   #398
Doug02wrx
Scooby Newbie
 
Member#: 226670
Join Date: Oct 2009
Location: Somerset, NJ
Vehicle:
2002 Wrx
Silver

Default

I have an 02 wrx and I just want to completely disable the security system and just lock/unlock the car manually. No alarm or anything. This stupid thing now randomly unlocks and doesn't lock with the fob. Any suggestions?
Doug02wrx is offline   Reply With Quote
Old 02-22-2012, 04:19 PM   #399
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Doug02wrx View Post
I have an 02 wrx and I just want to completely disable the security system and just lock/unlock the car manually. No alarm or anything. This stupid thing now randomly unlocks and doesn't lock with the fob. Any suggestions?
Put it in valet mode....this way the alarm will not go off when you open the door with the key.

However, your alarm will no longer function.

Something is wrong with the remote....try a new one or replace the battery
RexyGirl is offline   Reply With Quote
Old 02-22-2012, 05:35 PM   #400
Doug02wrx
Scooby Newbie
 
Member#: 226670
Join Date: Oct 2009
Location: Somerset, NJ
Vehicle:
2002 Wrx
Silver

Default

You think its the remote? That would cause it to unlock as soon as I hit the lock button (both on the fob and if I try to lock it with the button inside the car)? It also will unlock itself after a certain amount of time usually overnight.
Doug02wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory Alarm + Keyless entry from 04 FXT Skidd Interior/Dressup/Audio & Security 0 01-22-2009 08:26 PM
Factory alarm/keyless entry install - Anyone want to help?! NickWRX Tri-State Area Forum 3 07-06-2008 09:22 PM
All you need to know about ass hair. WRick Off-Topic 22 01-23-2006 07:22 PM
Factory Alarm / Keyless entry Woody Vancouver Impreza Club Forum -- VIC 3 04-21-2002 11:51 PM
Factory alarm/keyless entry on MY01 Safir Car Audio, Video & Security 1 02-08-2001 01:01 PM


All times are GMT -4. The time now is 10:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.