Welcome to the North American Subaru Impreza Owners Club Thursday November 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-14-2012, 08:16 PM   #426
seb28
Scooby Newbie
 
Member#: 291749
Join Date: Aug 2011
Chapter/Region: E. Canada
Location: Québec, Canada
Vehicle:
2007 Impreza WRX
WHITE

Default

Today the alarm goes off when I opened the trunk... So now the only moment it dont goes off is when I open the doors ( I tried driver and passenger side )
* Registered users of the site do not see these ads.
seb28 is offline   Reply With Quote
Old 04-16-2012, 12:39 AM   #427
CSVT_2004
Scooby Specialist
 
Member#: 182213
Join Date: Jun 2008
Chapter/Region: MWSOC
Location: Madison
Vehicle:
1999 Contour SVT

Default

Quote:
Originally Posted by seb28 View Post
I know it has the OEM alarm because i heard it last summer and now it goes off but only when I the the key to "ON"... I just don't understand why does it don't work with the door and the trunk now
Do the dome lights come on for those doors when they are opened?
CSVT_2004 is offline   Reply With Quote
Old 04-16-2012, 12:44 AM   #428
Chrisbande
Scooby Newbie
 
Member#: 280580
Join Date: Apr 2011
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2002 WRX WAGON
World Rally Blue

Default

Quote:
Originally Posted by CSVT_2004

Have you tried rolling down the drivers window, arming it, waiting 1 minute, and then reaching in and opening the door from the inside? The alarm should disarm if you put the key in any door/trunk key cylinder so you don't set off your alarm when entering or opening the vehicle.

An aftermarket alarm. Example, Viper 350hv. If you want remote start alarm Viper 5701.
Ended up getting a viper 350 plus thx for the advice.
Chrisbande is offline   Reply With Quote
Old 04-16-2012, 12:55 AM   #429
CSVT_2004
Scooby Specialist
 
Member#: 182213
Join Date: Jun 2008
Chapter/Region: MWSOC
Location: Madison
Vehicle:
1999 Contour SVT

Default

Quote:
Originally Posted by Chrisbande View Post
Ended up getting a viper 350 plus thx for the advice.
No problem. Where from, because if it was bby it includes install labor... Also if you bought it from an website be prepared to probably not have a viper warranty.
CSVT_2004 is offline   Reply With Quote
Old 04-16-2012, 08:43 AM   #430
seb28
Scooby Newbie
 
Member#: 291749
Join Date: Aug 2011
Chapter/Region: E. Canada
Location: Québec, Canada
Vehicle:
2007 Impreza WRX
WHITE

Default

Quote:
Originally Posted by CSVT_2004 View Post
Do the dome lights come on for those doors when they are opened?
Yes! My done light is 24 LED so its hard to miss
seb28 is offline   Reply With Quote
Old 04-16-2012, 11:54 AM   #431
Chrisbande
Scooby Newbie
 
Member#: 280580
Join Date: Apr 2011
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
2002 WRX WAGON
World Rally Blue

Default

Quote:
Originally Posted by CSVT_2004

No problem. Where from, because if it was bby it includes install labor... Also if you bought it from an website be prepared to probably not have a viper warranty.
I went to a shop and had them install it. Works great
Chrisbande is offline   Reply With Quote
Old 04-17-2012, 06:51 PM   #432
Jaybfox4
Scooby Newbie
 
Member#: 316662
Join Date: Apr 2012
Chapter/Region: NWIC
Vehicle:
2002 Subaru WRX
Aspen White

Default Tried reprogramming remote and now wont work

So i tried to reprogram my remote today and i put the key in and turned it 10 times and the horn chirped. Then i didnt apparently open the door and push a button on the keypad right. Took my key out and the horn chirped again(off). Now i have no working remote... Tired to start over but couldnt get the horn to chirp??

and i just looked at the flashing light and it looks like it in valet mode. blink blink pause. so i cant get it out of valet mode cause my remote dont work.

So what do i do now to program my remote?
Jaybfox4 is offline   Reply With Quote
Old 04-18-2012, 01:06 AM   #433
CSVT_2004
Scooby Specialist
 
Member#: 182213
Join Date: Jun 2008
Chapter/Region: MWSOC
Location: Madison
Vehicle:
1999 Contour SVT

Default

Quote:
Originally Posted by seb28 View Post
Yes! My done light is 24 LED so its hard to miss
Maybe someone had a security system in there prior, know how to use a multimeter?
CSVT_2004 is offline   Reply With Quote
Old 04-18-2012, 08:03 PM   #434
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by Jaybfox4 View Post
So i tried to reprogram my remote today and i put the key in and turned it 10 times and the horn chirped. Then i didnt apparently open the door and push a button on the keypad right. Took my key out and the horn chirped again(off). Now i have no working remote... Tired to start over but couldnt get the horn to chirp??

and i just looked at the flashing light and it looks like it in valet mode. blink blink pause. so i cant get it out of valet mode cause my remote dont work.

So what do i do now to program my remote?
Repeat the procedure...follow the steps in the first post of this thread. There is also a section there if the car is in valet mode
RexyGirl is online now   Reply With Quote
Old 04-21-2012, 09:38 PM   #435
YamahaBoi
Scooby Newbie
 
Member#: 317646
Join Date: Apr 2012
Default

new here. was browsing through the forums and this was one of the many things i needed! thanks much!
YamahaBoi is offline   Reply With Quote
Old 04-25-2012, 11:54 PM   #436
04nhbpep3
Scooby Specialist
 
Member#: 264798
Join Date: Nov 2010
Chapter/Region: MAIC
Location: Harrisonburg, Va
Vehicle:
2002 WRX
WRB

Default

So if I get any older remote, could I program it to work with my car? My car didn't come with one and I've already locked myself out three times
04nhbpep3 is offline   Reply With Quote
Old 04-27-2012, 03:07 AM   #437
CSVT_2004
Scooby Specialist
 
Member#: 182213
Join Date: Jun 2008
Chapter/Region: MWSOC
Location: Madison
Vehicle:
1999 Contour SVT

Default

Quote:
Originally Posted by 04nhbpep3 View Post
So if I get any older remote, could I program it to work with my car? My car didn't come with one and I've already locked myself out three times
2 remotes, @bby it'll include install except for the 5 material fee assuming they don't need any extra parts.
http://www.viper.com/P-412V/Viper-21...s-Entry-System
CSVT_2004 is offline   Reply With Quote
Old 05-04-2012, 04:21 PM   #438
iiibbb
Scooby Newbie
 
Member#: 227273
Join Date: Oct 2009
Vehicle:
7&11 Imprez$Forester

Default

I have a 2007 Impreza 2.5i. For the life of me I cannot get the car to go into program mode. Is there some special way one needs to turn the key. Should the key be in the ignition when I open and close the door?

The stupid dealership wants to charge me $50 per remote just to program them because I already have a couple of used remotes... since I spent a ghastly amount of money having non-transponder keys cut- I couldn't let myself knowing there was a manual way that I hadn't gotten working yet.

EDIT-----

This is an apparent variant of the instructions widely distributed. This worked on a 2007 Impreza 2.5i

1) Make sure everything is shut (same as other instruction).
2) Get in, sit down, shut door (same as other instruction).
3) Open and shut door (same as other)
4) Put key in Ignition and turn key from "lock" to "on" 10 times, and finish in "lock" (slightly different from described)
- no tones or flashing lights occur as described
5) Open and shut door
- a faint tone is heard
6) Enter numbers as directed. Push lock the number of times that equals the value, then unlock between each digit.
- a tone is heard for each press
7) After <unlock> of last digit of the first sequence, hit unlock an additional time.
- tone flutters
8) Reenter sequence.
- tone for each press
9) for additional remotes or to push other codes out skip to 9a)
10) Open and shut door
- long tone
11) Remove ignition key

9a) Open and shut door
9b) Enter first sequence as described above
9c) After <unlock> of last digit of the first sequence, hit unlock an additional time.
9d) Reenter sequence.
9e) Continue to step 10 or 9a


Your mileage may vary - but that's what worked for me after a frustrating afternoon. I got my hint here http://www.clubwrx.net/forums/interi...tructions.html that the process may deviate from the description... and dumb luck opening and shutting the door when the lights weren't blinking.

Last edited by iiibbb; 05-04-2012 at 05:41 PM.
iiibbb is offline   Reply With Quote
Old 05-04-2012, 10:39 PM   #439
pj2002wrx
Scooby Newbie
 
Member#: 311204
Join Date: Feb 2012
Default

i been trying to program my fob but i cant get the car to flash the lights or beep the horn is there a sensor or fuse that could be blow if so were is it iocated? i been trying for over a month to get this to work on my 02 wrx any ideas?
pj2002wrx is offline   Reply With Quote
Old 05-04-2012, 11:06 PM   #440
iiibbb
Scooby Newbie
 
Member#: 227273
Join Date: Oct 2009
Vehicle:
7&11 Imprez$Forester

Default

Quote:
Originally Posted by pj2002wrx View Post
i been trying to program my fob but i cant get the car to flash the lights or beep the horn is there a sensor or fuse that could be blow if so were is it iocated? i been trying for over a month to get this to work on my 02 wrx any ideas?
No horn of flashing lights for me... the standard programing method didn't work either...

...see my most directly above. Worth a try. There seems to be some variability.

Maybe you have the button? Our '99 had a button underneath the dash for that.
iiibbb is offline   Reply With Quote
Old 05-04-2012, 11:20 PM   #441
pj2002wrx
Scooby Newbie
 
Member#: 311204
Join Date: Feb 2012
Default

no button under dash on 02wrx i unhitched batt no luck i found a plug unhitched under the kick panel hooked back up no go
pj2002wrx is offline   Reply With Quote
Old 05-06-2012, 03:20 PM   #442
pj2002wrx
Scooby Newbie
 
Member#: 311204
Join Date: Feb 2012
Default

Well found out my keyless entry unit is no good
pj2002wrx is offline   Reply With Quote
Old 05-06-2012, 07:30 PM   #443
iiibbb
Scooby Newbie
 
Member#: 227273
Join Date: Oct 2009
Vehicle:
7&11 Imprez$Forester

Default

Quote:
Originally Posted by pj2002wrx View Post
Well found out my keyless entry unit is no good
Used, cheap(er)

http://www.carandtruckremotes.com/
iiibbb is offline   Reply With Quote
Old 05-09-2012, 12:21 AM   #444
cboettch
Scooby Newbie
 
Member#: 301752
Join Date: Nov 2011
Default

Quote:
Originally Posted by iiibbb View Post
No horn of flashing lights for me... the standard programing method didn't work either...

...see my most directly above. Worth a try. There seems to be some variability.
iiibbb
Thanks ever so much for finding these crazy voodoo instructions and posting them. This was very well timed. I've just programed a new remote (on the 2nd try) using this write up (after not being able to do it following the factory instructions??) on my '07 2.5i.

I had purchased the car last fall with only one remote and the lock button did not work. So after purchasing a new remote on line. I attempted to program it. Well after hours of frustrating failure (nothing after 10x on/lock), I discovered, here, on another post that apparently the chirp/buzzer had to be functioning in order for the programing to work. Until then I did not know there was a chirp, because mine didn't work. So I left it for the winter, and today once again following this thread http://forums.nasioc.com/forums/showthread.php?t=608657&page=17 I got my chirp working, only to find I still could not get any further in the steps.

Of course now that the remote is working I've turned the chirp off. Just wonder now if I really needed it to be functioning in order to program the remote.

And why the heck does this method work and not the one in the owners manual??

Thanks again
Chris
cboettch is offline   Reply With Quote
Old 05-09-2012, 07:22 AM   #445
iiibbb
Scooby Newbie
 
Member#: 227273
Join Date: Oct 2009
Vehicle:
7&11 Imprez$Forester

Default

Quote:
Originally Posted by cboettch View Post
iiibbb
Thanks ever so much for finding these crazy voodoo instructions and posting them. This was very well timed. I've just programed a new remote (on the 2nd try) using this write up (after not being able to do it following the factory instructions??) on my '07 2.5i.

And why the heck does this method work and not the one in the owners manual??

Thanks again
Chris
Just dumb luck-- I mostly figured it out on my own through trial and error, but I credit the hint I got from that website to clue me that it might be different. I wasn't paying the dealership $100 after they burned me for $60 for a couple of keys.
iiibbb is offline   Reply With Quote
Old 05-09-2012, 10:14 AM   #446
iiibbb
Scooby Newbie
 
Member#: 227273
Join Date: Oct 2009
Vehicle:
7&11 Imprez$Forester

Default

as to why the other instructions don't work. I suspect the changed it and didn't tell the people who write the manual. The above are actually simpler than that other craziness.
iiibbb is offline   Reply With Quote
Old 05-09-2012, 03:34 PM   #447
SubieCS
Scooby Newbie
 
Member#: 252747
Join Date: Jul 2010
Chapter/Region: Tri-State
Location: Nassau County
Vehicle:
'02 Impreza WRX
PSM

Default

My lights flash when lock/unlock and the horn sounds. The remote functions perfectly...but the security light on the dash doesn't flash or anything. I used to lock the car with the remote, tap the car and the horn would honk once, now it doesn't do so anymore; i'm convinced the alarm is not armed.

I tried the steps but it doesn't seem to be working and when i cycle the key 10 times- 15 times, the horn doesn't beep.

Any tips?

Thanks guys!
SubieCS is offline   Reply With Quote
Old 05-11-2012, 09:02 PM   #448
GRUMPY514
Scooby Specialist
 
Member#: 112285
Join Date: Apr 2006
Chapter/Region: MAIC
Location: NOVA/DC
Vehicle:
2014 BMW 535i
Alpine White

Default

Lost the key to my 2011 STi. Found a key fob online, well the process listed on the first page work with this key?
GRUMPY514 is offline   Reply With Quote
Old 05-22-2012, 04:23 AM   #449
airkareem
Scooby Newbie
 
Member#: 293700
Join Date: Sep 2011
Chapter/Region: NWIC
Default

So i have a 2011 impreza and i managed to lose a set of key and remote. I need to get it replaced but the dealership told me it would be $300. Any ideas that are cheaper and i can do on my own? Any help would be super appriciated.
airkareem is offline   Reply With Quote
Old 05-22-2012, 10:09 AM   #450
iiibbb
Scooby Newbie
 
Member#: 227273
Join Date: Oct 2009
Vehicle:
7&11 Imprez$Forester

Default

Quote:
Originally Posted by airkareem View Post
So i have a 2011 impreza and i managed to lose a set of key and remote. I need to get it replaced but the dealership told me it would be $300. Any ideas that are cheaper and i can do on my own? Any help would be super appriciated.
Locksmith would likely be a little cheaper.

I also noticed that some hardware stores (an ACE hardware specifically) are doing transponder keys as long as you have another.
iiibbb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Factory Alarm + Keyless entry from 04 FXT Skidd Interior/Dressup/Audio & Security 0 01-22-2009 09:26 PM
Factory alarm/keyless entry install - Anyone want to help?! NickWRX Tri-State Area Forum 3 07-06-2008 10:22 PM
All you need to know about ass hair. WRick Off-Topic 22 01-23-2006 08:22 PM
Factory Alarm / Keyless entry Woody Vancouver Impreza Club Forum -- VIC 3 04-22-2002 12:51 AM
Factory alarm/keyless entry on MY01 Safir Car Audio, Video & Security 1 02-08-2001 02:01 PM


All times are GMT -4. The time now is 11:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.