Welcome to the North American Subaru Impreza Owners Club Wednesday October 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-19-2008, 04:01 PM   #1
SubieL98
Scooby Newbie
 
Member#: 194025
Join Date: Nov 2008
Chapter/Region: NWIC
Location: Issaquah, WA
Vehicle:
98 Impreza

Default Turbo Ping

I have a 98 Impreza L with a TDO4 02 Wrx turbo. I hooked up a turbo xs boost controller and changed the boost (changed the ecu fuel also) and when i would hit boost there would be a pinging sound not the wind of the turbo but a ping sound. Do you guys have any ideas?
* Registered users of the site do not see these ads.
SubieL98 is offline   Reply With Quote
Old 11-19-2008, 05:41 PM   #2
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

yeah, read up on turbo'ing NA cars before turning up the boost. ping is bad. what are you running for now? what octane are you using?
yarrgh is offline   Reply With Quote
Old 11-19-2008, 05:54 PM   #3
SubieL98
Scooby Newbie
 
Member#: 194025
Join Date: Nov 2008
Chapter/Region: NWIC
Location: Issaquah, WA
Vehicle:
98 Impreza

Default

I'm just running 7 psi boost and 92 octane

I took the boost controller off but it only did it when i hit boost
SubieL98 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: NoVA: Draco Performance Turbo Blanket for Small Frame Turbo. adjasont Engine/Power/Exhaust 4 06-05-2010 03:15 PM
Turbo Ping SubieL98 North West Impreza Club Forum -- NWIC 8 11-19-2008 06:05 PM
Ping! Ping! Ping..ping! Ping! BacDoc Off-Topic 56 12-29-2007 03:06 PM
How much pinging can a turbo car take? d00f Factory 2.0L Turbo Powertrain 1 12-01-2001 01:50 AM


All times are GMT -4. The time now is 03:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.