Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-19-2008, 08:04 PM   #1
Smythe
Scooby Newbie
 
Member#: 91359
Join Date: Jul 2005
Default radiator is leaking at only 33,600 miles

Hello,

I only have 33600mile on my 05WRX and I already am seeing a coolant leak. I'm guessing it is coming from the seam where the plastic tank meets the core, there is coolant on both side of the engine bay and in the joing all along the top of the radiator. Has anyone else heard of this happening so soon?

I guess I'm going to have to replace it, what does people replace these with? I'm looking at the Mishimoto because its all aluminum and rather cheap.

Thanks for the help,

Smythe
* Registered users of the site do not see these ads.
Smythe is offline   Reply With Quote
Old 11-19-2008, 08:19 PM   #2
flstffxe
Scooby Specialist
 
Member#: 155358
Join Date: Jul 2007
Location: Coon Rapids, MN
Vehicle:
2008 Forester
Steel Silver

Default

Do a search, it happens and most go aftermarket as you are thinking.

Edit: a few threads down from yours
http://forums.nasioc.com/forums/show....php?t=1640139
flstffxe is offline   Reply With Quote
Old 11-19-2008, 10:38 PM   #3
rick-l
Scooby Specialist
 
Member#: 33868
Join Date: Mar 2003
Location: Chesterfield, MO
Vehicle:
2003 wrx
srp

Default

Does the TSB about half way down (post #5) in THIS THREAD apply to your car?

I got rid of the bent wire hose clamps and life is good. 120,000 miles
rick-l is offline   Reply With Quote
Old 11-20-2008, 11:55 AM   #4
Smythe
Scooby Newbie
 
Member#: 91359
Join Date: Jul 2005
Default

Quote:
Originally Posted by flstffxe View Post
Do a search, it happens and most go aftermarket as you are thinking.

Edit: a few threads down from yours
http://forums.nasioc.com/forums/show....php?t=1640139
I did a search and found the thread that you were talking about... It didn't seem to be the same phenominon as I'm getting just a little leak and I'm sure my head gaskets aren't blown... Also I read through a few posts and didn't find anything about what people were using for replacements.

rick-l .... That is exacly the kind of information I was looking for, I will check the hose tonight... I bet that is the problem leak looks exactly like the one pictured, I didn't get a good look last night just noticed fluid in the joint and assumed it was the tank splitting as that has been a common problem on my other cars.


Thanks,

Smythe
Smythe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS Northern NJ: 2006 CGM STi, only 8,600 miles stock(no mods) and mint cond. $25.5k BOOSTR Private Vehicle 'For Sale' Classifieds 5 02-23-2009 08:10 PM
Engine mounts dead at only 93 k miles? breakfasteatre Legacy Forum 5 08-12-2007 02:44 AM
a friend is "built" at only 16 DLC228 Off-Topic 27 10-12-2004 11:00 AM
Got rear-ended...with only 600 miles!!! CheeZ General Forum Archive 13 02-06-2001 09:32 AM


All times are GMT -4. The time now is 05:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.