Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-26-2002, 04:27 AM   #1
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Question flutter

hey guys
i have had the Forge bov in my car for a day now
but it flutters sometimes before it actually blows off.
it would sound like this , pst pst pst then a quick pshh.

i have done a lot of searching some people say its the turbo stalling or its turbo backspin.

other people say its the BOV's valve not opening all the way, they say taht the valve only opens only a little since not that much boost was made.

Hey Ofrder, what kinda spring was in it? some people say taht the forge comes with a red spring(really stiff) and that I need a blue or a green spring.

Did the forge behave like this on your car?

How bout everyone else, do your BOVs flutter?

i'm kinda worried about my turbo now
* Registered users of the site do not see these ads.
AK_2002_WRX is offline   Reply With Quote
Old 03-26-2002, 04:54 AM   #2
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

Hahahaha, Mike you're killing me. I thought you did all your research. Let me guess. It only happens at part throttle and not under WOT conditions.

Winslow
WRXnFX is offline   Reply With Quote
Old 03-26-2002, 05:10 AM   #3
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Default

well, i think i know what it is, i just want everyone elses input

i just want to know if it is the turbo makin the noise, or the BOV itself makin the noise. i know turbo backspin would make a noticeable flutter noise, but the one i hear sort sounds like a "giggle." it will make its noise then do a quick pshh. this is at part throttle at aroun 3500-4000 rpms.
AK_2002_WRX is offline   Reply With Quote
Old 03-26-2002, 05:15 AM   #4
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

I don't think it's the spring. Have you done any other intake mods? My BOV makes the same sound and I've heard it on other cars too. Does the Forge recirc? I think it is the turbo making noise. That is what I've read in past posts. It is a pretty common sound with cars with BOVs.

Winslow
WRXnFX is offline   Reply With Quote
Old 03-26-2002, 05:22 AM   #5
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Talking

well if Rob isn't having any problems with his car then i guess mine should be fine too. we'll have to hear what he has to say about it.

its just that noise it makes. it kind sounds like it comes from the BOV side of the engine and not the turbo.
AK_2002_WRX is offline   Reply With Quote
Old 03-26-2002, 05:32 AM   #6
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

Really? I hear the flutter on the turbo side. Where is everybody? Oh yeah, its 130 in the morning. I see Rob on line around 6-7am.

Winslow
WRXnFX is offline   Reply With Quote
Old 03-26-2002, 07:12 AM   #7
brokeawd
Scooby Newbie
 
Member#: 15796
Join Date: Feb 2002
Location: East A-Town
Vehicle:
2003 Cobra 10.40@135
09 Titan Crew Cab LE

Default

This flutter that you are hearing is air bouncing off the throttle body plate and turbine wheel exit side. As you would call it...air has no where to go or escape, this may be accompanied by a small jolt. Basically since its a aftermarket BOV the spring on the inside is heavier tension, unlike the stock one, so therefore it doesnt blow off like the stock one with small boost inputs i.e. get in throttle shortly then get out....probably sounds like a choking sound. You are backspinning the turbo a tad but nothing to be concerned with.

All in all you are gonna have to put up with this unless the bov has a soft/hard adjustment on it. If you set the spring to soft, boost pressure will blow off under WOT resulting in lost boost. So yes in a way stiffer is better.

DSM guys take the stock ones and crush them, which puts more tension on the spring, and cuts down on boost leaks. I still run a stock BOV on my car.....hope this helped some.
brokeawd is offline   Reply With Quote
Old 03-27-2002, 05:05 AM   #8
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Angry

i got a check engine light today. i'm not sure if its related to the BOV or not, but it went on right after the bov vented during a shift
AK_2002_WRX is offline   Reply With Quote
Old 03-27-2002, 05:39 AM   #9
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

I can't help but laugh. You put so much into the research of BOVs and look what happened. Sorry, but the light will probably go away after 50 miles. I can pull the code when I get back if it makes you feel better.

Winslow
WRXnFX is offline   Reply With Quote
Old 03-27-2002, 06:55 AM   #10
R-RATED
Scooby Newbie
 
Member#: 16875
Join Date: Mar 2002
Location: Anchorage
Vehicle:
2002 WRX
Infomous racing crew

Default ?

Only in a high gear an low rpm when you dont produce that much boost and lay off the gas but problems with my bov not a sing thing thought.
R-RATED is offline   Reply With Quote
Old 03-27-2002, 09:15 AM   #11
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

just reset the ecu...
SQUAD_907 is offline   Reply With Quote
Old 03-27-2002, 12:04 PM   #12
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Wink

yeh i reset the ECU again, 2nd time this week
first after Rob put it on, and yesterday.

i've never waited for a CE light to go off before, does it actually turn off on its own with out reseting it?
AK_2002_WRX is offline   Reply With Quote
Old 03-27-2002, 05:48 PM   #13
R-RATED
Scooby Newbie
 
Member#: 16875
Join Date: Mar 2002
Location: Anchorage
Vehicle:
2002 WRX
Infomous racing crew

Default ce light

Yeah it turns off by it's self dont worry.
R-RATED is offline   Reply With Quote
Old 03-27-2002, 06:40 PM   #14
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

Yup, usually after so many miles. The ECU runs continuous monitor tests and after so many good results it will turn off the light.

Winslow
WRXnFX is offline   Reply With Quote
Old 03-27-2002, 11:05 PM   #15
R-RATED
Scooby Newbie
 
Member#: 16875
Join Date: Mar 2002
Location: Anchorage
Vehicle:
2002 WRX
Infomous racing crew

Default

Or if your worried reset the ECU.
R-RATED is offline   Reply With Quote
Old 03-28-2002, 02:32 AM   #16
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Angry

i got another ******* check engine light again
maybe it is the bov i dunno what the hell it is, but 2 CE lights in a row really ****ing sucks.

i checked everything in the engine bay, nothing seems wrong, i think i need to invest in a scan tool. i bet its the damn BOV.
AK_2002_WRX is offline   Reply With Quote
Old 03-28-2002, 04:55 AM   #17
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

Damn OFRDER. Maybe he'll swap BOVs with you. Hmmm HKS huh? Sounds like a good deal. I'll be back Friday. I need to hook that software up to my car so I can pull the last code. I can do your too.

Winslow
WRXnFX is offline   Reply With Quote
Old 03-28-2002, 05:30 AM   #18
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

ofrder never got a cel with that bov...maybe it's something else? u never know til u bring up the code...
SQUAD_907 is offline   Reply With Quote
Old 03-28-2002, 05:45 AM   #19
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

Does the forge recirc? Or is it 100% blow off?

Winslow
WRXnFX is offline   Reply With Quote
Old 03-28-2002, 05:50 AM   #20
SQUAD_907
Totally Biased
Moderator
 
Member#: 10104
Join Date: Sep 2001
Chapter/Region: AKIC
Location: 907
Vehicle:
WOW! JUST WOW!
I make posts disappear

Default

it's 100%...it comes with a plug...
SQUAD_907 is offline   Reply With Quote
Old 03-28-2002, 10:36 AM   #21
Sokudo
Scooby Specialist
 
Member#: 11162
Join Date: Oct 2001
Chapter/Region: AKIC
Location: Anchorage,AK
Vehicle:
MY98 A4 Avant

Unhappy

Hmmm,never had cel issues when i had it in my car.Let's wait for Winslow so he can pull the codes and check what's the cause of the cel.
Sokudo is offline   Reply With Quote
Old 03-28-2002, 10:38 AM   #22
AK_2002_WRX
Scooby Specialist
 
Member#: 10591
Join Date: Sep 2001
Chapter/Region: AKIC
Location: anch, ak
Vehicle:
2004 Silverado SS
Victory Red

Have a Nice Day?

i had my ecu unplugged all night. hopefully it wont light up again.
yeah i think i need mine scanned too.
AK_2002_WRX is offline   Reply With Quote
Old 03-28-2002, 03:45 PM   #23
RallyX13
Scooby Specialist
 
Member#: 1543
Join Date: May 2000
Chapter/Region: AKIC
Location: Greensboro, NC USA
Vehicle:
2007 Jetta GLI
Yellow

Default

To fix Check Engine Light, do the following:

1. Get a roll of Electrical Tape
2. Open drivers side door and get in seat.
3. Pull off a few small strips of tape.
4. Put tape on plastic gauge housing cover in the area of the offensive "Check Engine" light. Do not be afraid to use as much tape as you like.
5. Mod your car to your hearts content, without the little red light to bug you.

Kris
RallyX13 is offline   Reply With Quote
Old 03-28-2002, 06:44 PM   #24
WRXnFX
Alaskan Mafia
Moderator
 
Member#: 10398
Join Date: Sep 2001
Chapter/Region: AKIC
Location: Corner of Easy and Lazy
Default

The light is yellow. Go figure. Color blind people. Good fix though.

Winslow
WRXnFX is offline   Reply With Quote
Old 03-29-2002, 12:37 AM   #25
RallyX13
Scooby Specialist
 
Member#: 1543
Join Date: May 2000
Chapter/Region: AKIC
Location: Greensboro, NC USA
Vehicle:
2007 Jetta GLI
Yellow

Default

Colors all the same....make no matter, make light go away!

Kris
RallyX13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
wastegate flutter or bov flutter-help!?!? odin1 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 5 02-08-2004 06:25 PM
I think I have turbo flutter now with my GFB BOV ezatnova Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 07-15-2002 12:15 PM
fluttering sound coming from intake after throttle lift? pbnj9786 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 18 03-21-2002 03:20 PM
Fluttering sound in the rear bumper? Daios Car Audio, Video & Security 1 10-02-2000 01:34 PM


All times are GMT -4. The time now is 11:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.