Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-29-2008, 06:33 PM   #1
97OBWagon
Scooby Newbie
 
Member#: 43899
Join Date: Sep 2003
Vehicle:
2005 Legacy OB Wagon
Atlantic Blue

Default P2009 CEL Tumble Generator Valve

I have a 2005 Outback Wagon 2.5L non-Turbo. A while back, I got a CEL. I read the code and it came back P2009 (Intake Manifold Runner Control (IMRC) Circuit Low (Bank 1)). I also notice that my fuel mileage and power have both diminished. Do you think it's a gummed up tumble generator valve (TGV)? Other people with TGV problems get CEL codes in addition to P2009, but I'm only getting a P2009 error.

I read a lot about the TGV and some posts say that I should clean it. Are there any directions on how to do this quickly or do I need to take the entire intake manifold off like in the TGV deletes procedure?

Dumb questions:
1) Which side is bank 1? Passenger or driver?
2) How do people get factory service manuals?

Any help would be appreciated! Thx!
Alan
* Registered users of the site do not see these ads.
97OBWagon is offline   Reply With Quote
Old 11-30-2008, 10:44 AM   #2
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

procedure for P2009 for your car:

STEP:
1 CHECK HARNESS BETWEEN ECM AND
TUMBLE GENERATOR VALVE ACTUATOR
CONNECTOR.
1) Turn the ignition switch to OFF.
2) Disconnect the connector from tumble generator
valve connector.
3) Measure the voltage between tumble generator
valve actuator and chassis ground.
Connector & terminal
(E51) No. 1 (+) Chassis ground (��):
(E51) No. 2 (+) Chassis ground (��):

CHECK
Is the measured value less
than 5 V?

YES
Replace the tumble
generator valve
actuator. <Ref. to
FU(H4SO U5)-31,
Tumble Generator
Valve Actuator.>

NO
Repair the battery
short circuit
between ECM and
tumble generator
valve actuator.
Tea cups is offline   Reply With Quote
Old 12-02-2008, 11:06 AM   #3
97OBWagon
Scooby Newbie
 
Member#: 43899
Join Date: Sep 2003
Vehicle:
2005 Legacy OB Wagon
Atlantic Blue

Default Thanks

Thanks, Tea Cup! I'll give it a try.
97OBWagon is offline   Reply With Quote
Old 12-22-2008, 03:30 PM   #4
lolsshea
Scooby Newbie
 
Member#: 198161
Join Date: Dec 2008
Default Fix??

Hey - I ran across this thread today looking for answers to the same exact question. Just bought an 05 Outback and it threw the P2009 code this morning.

What was the result?? Did you get it sorted?? I haven't driven it enough to see any diminished power or mileage, but that could change.
lolsshea is offline   Reply With Quote
Old 12-29-2008, 06:31 PM   #5
97OBWagon
Scooby Newbie
 
Member#: 43899
Join Date: Sep 2003
Vehicle:
2005 Legacy OB Wagon
Atlantic Blue

Default No problems?

I couldn't find the problem so I took it to the dealer today. I had cleared the P2009 CEL in August 2008 and no new codes have materialized since then. I still have decreased gas mileage (currently getting ~17mpg from non-turbo, 2.5L in city), low power, and intermittent rough idle. The dealer couldn't find anything wrong.
97OBWagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tumble generator valve CEL TyranosaurusWRX Newbies & FAQs 11 08-09-2010 08:46 PM
CEL Code: P1090 Tumble generator valve #1 (RH) malfunction (stuck open) 4sworks Newbies & FAQs 6 08-14-2009 01:23 PM
Help ... CEL 1086 re: Tumble Generator Valve Actuator lupohki Factory 2.5L Turbo Powertrain 11 05-20-2005 07:14 AM
Tumble Generation Valve Info Imprezer Factory 2.0L Turbo Powertrain 7 01-21-2002 03:24 AM
Check engine. Tumble generator valve EPD Factory 2.0L Turbo Powertrain 1 06-12-2001 11:47 AM


All times are GMT -4. The time now is 05:36 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.