Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-04-2008, 06:52 PM   #1
colost.wrx
Scooby Newbie
 
Member#: 196635
Join Date: Dec 2008
Location: Fort Collins Colorado
Vehicle:
2002 Impreza Wrx
WRB

Have a Nice Day? EGT sensor help

I just purchased my car under 3 months ago and recently the EGT sensor worked its way out from the uppipe. I noticed it when my wrx sounded like a diesel truck. I took it to the dealership and they informed me the sensor had "unscrewed" itself somehow. They want to charge me $190 to screw it back in for me because of the inconvinient location. I'm reluctant to pay so much for a "repair" that I feel I could do myself. However I am unfamiliar with the upipe and am not sure if it would be something I could accomplish or not. I am mechanically inclined but am in college dorms without a place to work on it. I could drive it 1.5 hr home where I have tools, but is it safe. What a dilema
* Registered users of the site do not see these ads.

Last edited by colost.wrx; 12-06-2008 at 04:21 PM.
colost.wrx is offline   Reply With Quote
Old 12-05-2008, 01:23 AM   #2
RealiTnh
Scooby Newbie
 
Member#: 191452
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Hudson NH
Vehicle:
2004 ej20 18g 303whp
@ 20psi Synaptic tuned

Default

You should be able to reach the bung from under the hood and you can try rethreading it in or just do what I did and plug it with an M12 x 1.25 pitch bolt. I had to use a large nut and a lock & regular washer to make up for to much length on the bolt. Also grab a 2.2k 1/2 watt resistor from Radio Shack to keep you ECU smiling... Easy fix!
RealiTnh is offline   Reply With Quote
Old 12-05-2008, 01:43 AM   #3
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

search around here for the fix

its easy......and cheap......ive cut the cable off close to the hex with a bolt cutter and cut the probe off at the taper and used jbweld on the threads of the remaining part of the probe and the 2.2k ohm resistor in the plug on the firewall

and been permanantly done in 30 minutes
Uncle Scotty is offline   Reply With Quote
Old 12-05-2008, 07:10 PM   #4
colost.wrx
Scooby Newbie
 
Member#: 196635
Join Date: Dec 2008
Location: Fort Collins Colorado
Vehicle:
2002 Impreza Wrx
WRB

Default

Thanks For the Imput! My car is currently at the dealership, If I go over there to see if I can rethread it myself, do you know what tools I'll need? Or what parts I might have to remove to get to it (if any).
colost.wrx is offline   Reply With Quote
Old 12-05-2008, 07:21 PM   #5
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Unhappy Sad smiley for the fail

I'm tired of people using the sad smiley lately unless they have a real i$$ue like, "why is my my engine knocking"?
mikeythejew is offline   Reply With Quote
Old 12-06-2008, 04:23 PM   #6
colost.wrx
Scooby Newbie
 
Member#: 196635
Join Date: Dec 2008
Location: Fort Collins Colorado
Vehicle:
2002 Impreza Wrx
WRB

Exclamation

Public Service Anouncement: i changed it to a neutral face so i don't upset anyone
colost.wrx is offline   Reply With Quote
Old 12-06-2008, 04:51 PM   #7
sackytar
Scooby Guru
 
Member#: 149262
Join Date: May 2007
Chapter/Region: MWSOC
Location: Grand Rapids MI
Vehicle:
03WR Rally/XTDD/98SJ
PrimerGrey

Default

forget about it and get an upipe while you in there.
sackytar is offline   Reply With Quote
Old 12-08-2008, 07:06 PM   #8
colost.wrx
Scooby Newbie
 
Member#: 196635
Join Date: Dec 2008
Location: Fort Collins Colorado
Vehicle:
2002 Impreza Wrx
WRB

Default

Thanks For all of the help, I successfully put the EGT senor back in and possibly will plug it later as it does have an HKS Aftermarket upipe. The sensor is viewable under the hood without removing any parts. I will post pictures later If I can.
colost.wrx is offline   Reply With Quote
Old 12-08-2008, 07:23 PM   #9
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

hks up is garbage

if it leaks....replace it
Uncle Scotty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help finding flare nut for EGT sensor STi2001 Factory 2.0L Turbo Powertrain 1 06-12-2002 10:28 PM
EGT sensor striped on stock uppipe! help wRxbeater11 Factory 2.0L Turbo Powertrain 4 01-27-2002 09:37 PM
HELP!! EGT sensor problem bobgrice Factory 2.0L Turbo Powertrain 9 01-11-2002 07:59 AM
Stock EGT Sensor HELP! D_REX Factory 2.0L Turbo Powertrain 7 12-15-2001 10:59 PM
Need help installing EGT sensor IMPBOY Bay Area Impreza Club Forum -- BAIC 4 02-27-2001 11:43 PM


All times are GMT -4. The time now is 07:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.