Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-08-2008, 08:49 PM   #1
wrx4meinnd
Scooby Newbie
 
Member#: 153745
Join Date: Jul 2007
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2006 wrx limited
silver

Default Electrical problem:(

i did search and came up with nothin. last night i was drivin home and aproachin a turn i turned my turn signal on and my headlights turned off. after the second blink they came back on. i then tried the turnsignal again and nothin happened. about 5 seconds later my headlights and dashboard turned off, at the same time the dome light turned on. this lasted about 2 seconds. and throughout my 2 blocks home it didnt happen again. anyone have any knowledge about this problem? by the way i have a 2006 wrx limited. thanks alot for any input
* Registered users of the site do not see these ads.
wrx4meinnd is offline   Reply With Quote
Old 12-08-2008, 09:00 PM   #2
wrxskier18
Scooby Specialist
 
Member#: 88005
Join Date: May 2005
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
2002 WRX PSM
GS500

Default

Any mods at all to the elctrical system, incuding sound system? This could be very dangerous. Try to take in under warranty if you can.
wrxskier18 is offline   Reply With Quote
Old 12-08-2008, 09:03 PM   #3
wrx4meinnd
Scooby Newbie
 
Member#: 153745
Join Date: Jul 2007
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2006 wrx limited
silver

Default

it is under warranty, i called them and let them know, they work with me quite well since im over 100 miles from the nearest dealer. the only mods to the car r k&n drop in and intake silencer remover. thats it
wrx4meinnd is offline   Reply With Quote
Old 12-08-2008, 10:06 PM   #4
xrebel21
Scooby Newbie
 
Member#: 153224
Join Date: Jul 2007
Chapter/Region: SWIC
Location: Tucson AZ
Vehicle:
07 WRX TR
Garnet Red Pearl

Default

poltergeist. call ghostbusters
xrebel21 is offline   Reply With Quote
Old 12-09-2008, 01:11 PM   #5
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

have alternator checked, search on it. i've heard(never experienced) that a failing alternator can cause odd things to happen.
yarrgh is online now   Reply With Quote
Old 12-11-2008, 04:00 PM   #6
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

combo. switch is bad.
crampfan is offline   Reply With Quote
Old 12-14-2008, 03:24 PM   #7
wrx4meinnd
Scooby Newbie
 
Member#: 153745
Join Date: Jul 2007
Chapter/Region: MWSOC
Location: North Dakota
Vehicle:
2006 wrx limited
silver

Default

do u have experience with the combo switch goin bad? i had the battery and alternator fully checked. the only problem found wat corrosion on the positve cable. had it cleaned and no problem so far...
wrx4meinnd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question for the Electrically Inclined or Electricians/Electrical Engineers nepawrx Off-Topic 25 01-08-2010 01:57 PM
Electric Cars to be Made in China Based on Detroit Electric Drive Technologies AVANTI R5 Non-Subaru News & Rumors 0 06-20-2009 08:24 AM
OT electrical gurus - school me on electricity -=C=- Off-Topic 21 07-18-2006 02:41 PM
Electrical Formulas, Basic Electrical information, FAQs, and threads of note GLwagon Electrical & Lighting 2 01-23-2003 07:33 PM
('93-'01) Anyone with electrical knowledge? dkpassat Impreza Forum 4 06-07-2001 08:10 PM


All times are GMT -4. The time now is 11:52 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.