Welcome to the North American Subaru Impreza Owners Club Tuesday September 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-24-2008, 04:56 PM   #1
smithrcing17
Scooby Newbie
 
Member#: 193195
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: Harrisburg
Vehicle:
2005 Ty Tuned 2.5RS
PSM

Default SOMEBODY HELP!!! 05rs sputtering!!!

yesturday i drove my car for about an hour and it ran absolutely perfect!! i came home and parked it outside and reved it once before shutting it off and it sounded really good, i let it idle and then turned it off, over night we had some really cold temps and freezing rain in the morning. i come out this afternoon to get in it and it starts really hard and i thought that was weird but perceeded on i drove it about a quarter mile and it starts sputtering like theres water in it so i drive it back home quick and i rev it up to hear it and i thought it was just cold at first but then it starts sounding horrible and sputtering like crazy and i go back and smell the exhaust and it seemed alittle hoter smelling but no a whole lot but then it throws the CEL and sputtered even more so i turned it off quick. i just bought this car within the last 2 months and i just changed my oil and im scared as **** that something is blown up or something bad happened but i dont see what oculd of happened over night?!?!?!?! any advice would be nice
* Registered users of the site do not see these ads.
smithrcing17 is offline   Reply With Quote
Old 12-24-2008, 10:15 PM   #2
seanvetter123
Scooby Specialist
 
Member#: 174476
Join Date: Mar 2008
Chapter/Region: NWIC
Location: B-ham, WA
Vehicle:
2002 Impreza RS
BRP

Default

well get the CEL checked and see that the problem is and then we can tell you what you need to do. schucks can do it for free, or find a friend with a code reader and google it.
could be a misfire (spark plugs, O2 sensor), because it was cold it could be water in the gas if your tank is on the empty side. and when ever i buy a car i always do a tune up even if the previous owner said he had done it. just makes me feel better and then if someting does go wrong i know what it cant be.
seanvetter123 is offline   Reply With Quote
Old 12-24-2008, 11:24 PM   #3
smithrcing17
Scooby Newbie
 
Member#: 193195
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: Harrisburg
Vehicle:
2005 Ty Tuned 2.5RS
PSM

Default

i bought it from a subaru dealership and they said it was completely serviced, and i have 3/4 of a tank of gas and theres no way water got in my gas
smithrcing17 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need help engine sputtering jesse_r Normally Aspirated Powertrain 3 06-15-2009 02:50 AM
need help reading my boost controller can somebody help stiking87 Newbies & FAQs 3 06-11-2006 12:12 PM
Help with sputtering jskho Factory 2.0L Turbo Powertrain 2 10-28-2005 03:40 PM
somebody help me! xphilxcorex Factory 2.0L Turbo Powertrain 3 12-22-2001 02:09 PM
Somebody Help! NJWRXer Factory 2.0L Turbo Powertrain 1 06-15-2001 08:14 AM


All times are GMT -4. The time now is 10:02 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.