Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-31-2008, 02:07 AM   #1
dciisir
Scooby Newbie
 
Member#: 197407
Join Date: Dec 2008
Default Need advice on aircond unit on 02 sti

I'm from Aus and got the bug eye sti. Haven't been able to find anything on the net about this but here's my problem.

My air conditioning unit is not always cold. Sometimes it will be cold and sometimes its warm. One time I was driving home from work, it took 20 mins before it became cold. I also got it re-gassed a month ago since it was completely warm. Another problem with it is that the cold air does not come out on all vents. One of the center vents blow colder air than the one next to it. Also the driver side vent blows warm air.

It's driving me nuts. I checked to make sure the condensor is running and there is gas (via the little plastic hole).

Another problem with my car is I hear rattling sounds (more plastic than metal) when I put my foot all the way when the rpm is very low. It's sorta like a buzzing sound and its pretty loud if I stick my head out of the window. From inside the car, it sounds like it's coming from behind the stereo / driver side abs unit. I didn't get this sound until I got my clutch replaced a month ago. I put in an exedy heavy duty one. I also got coilovers replaced at the same time. The sound was relatively mild at the start but one hot day, I drove it quite hard and the sound of this buzzing thing went up a few notches. I wonder if the mechanic is unloosening my stuff so I have to keep bring my car back

Btw, my car is right hand drive.

Any advice would be much appreciated.
* Registered users of the site do not see these ads.

Last edited by dciisir; 12-31-2008 at 02:14 AM.
dciisir is offline   Reply With Quote
Old 12-31-2008, 09:53 AM   #2
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

You are best served by visiting the MRT forums. Yes our cars are similar, but there are differences and local Aussie help is better than us. I'm guessing you need more freon in your system. That's what it sounds like to me....you might have a leak or hole in a line.
Unabomber is offline   Reply With Quote
Old 12-31-2008, 02:38 PM   #3
yarrgh
Scooby Specialist
 
Member#: 80465
Join Date: Jan 2005
Chapter/Region: RMIC
Location: Aurora, CO
Vehicle:
2001 2.5RS
Black Diamond Pearl

Default

UNloosening = tightening. Are there any leaves/debris near the evaporator?
yarrgh is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Advice - Removing Window Tint from my STI... BongMonster Tri-State Area Forum 9 11-28-2005 05:31 PM
Need advice for putting video on internet Graham General Community 2 03-10-2005 02:14 AM
Need Advice re: Warranty Work on Tranny in Socal kooyaa Southern California Impreza Club Forum -- SCIC 5 01-26-2005 03:00 PM
Need advice on a head unit. Marc Sawaya Car Audio, Video & Security 11 12-19-2001 05:44 PM
need advice/help @ Ithaca NY on 8/14/01 NYCshopper Tri-State Area Forum 4 08-14-2001 07:14 AM


All times are GMT -4. The time now is 10:41 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.