Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-02-2009, 03:14 PM   #1
WingsWestWrx
Scooby Newbie
 
Member#: 68111
Join Date: Aug 2004
Default Problems w/ my heater

whenever i come to a stop my heater in my 03 wrx stops working and blows out cool air... it only blows out heat when im driving...

this happens when my engine is fully warmed up too...

does anyone know what the problem could be?
* Registered users of the site do not see these ads.
WingsWestWrx is offline   Reply With Quote
Old 01-02-2009, 03:59 PM   #2
SchmisterTyler
Scooby Specialist
 
Member#: 185992
Join Date: Aug 2008
Chapter/Region: SCIC
Location: Fullerton
Vehicle:
2003 WRX Impreza
World Rally Blue

Default

this meens it is really cold outside, turn the recirculation of air mode on so it blows warm air back into your face that is already in the cabin of the car. This will cause your windows to fog up faster though.
SchmisterTyler is offline   Reply With Quote
Old 01-02-2009, 04:22 PM   #3
Will from Maine
Scooby Newbie
 
Member#: 75152
Join Date: Nov 2004
Chapter/Region: NESIC
Location: Bar Harbor, ME
Vehicle:
2002 WRX
SRP

Default

Check your coolant level, when you are parked your rpms are lower and if you are a bit low on coolant this might reduce your heat. Mine is currently doing the same thing. A thermostat malfunction can do the same, but that would effect the temp gauge reading too.
-will
Will from Maine is offline   Reply With Quote
Old 01-02-2009, 04:27 PM   #4
durania717
Scooby Specialist
 
Member#: 153468
Join Date: Jul 2007
Chapter/Region: South East
Location: Crossville, TN
Vehicle:
2005 STi WRB on Gold
95 OutSack

Default

Have you had your water pump replaced?
Coolant flushed?
Clogged heater core?
durania717 is offline   Reply With Quote
Old 01-02-2009, 06:27 PM   #5
trueno16v
Scooby Specialist
 
Member#: 175170
Join Date: Mar 2008
Chapter/Region: MWSOC
Location: Milwaukee, WI
Vehicle:
2005 WRX Wagon
owl + bungee cord= my a$$

Default

+1 for checking coolant level. Turn on car and let coolant get warm (not HOT!) then turn on heat to high. Open radiator cap and I bet your coolant is low. Please don't do this while engine is hot or right after you've raced that civic in a school zone.
trueno16v is offline   Reply With Quote
Old 01-04-2009, 12:20 AM   #6
WingsWestWrx
Scooby Newbie
 
Member#: 68111
Join Date: Aug 2004
Default

thanks for the help everybody!!! it was the coolant... you saved my ass from spending my x-mas money at the stealership
WingsWestWrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
So my boss stole my heater.... 1shibainu Off-Topic 26 02-28-2006 04:00 PM
Will bypassing my heater core cause my evaporator to ice up? caterpill Factory 2.0L Turbo Powertrain 2 07-26-2005 05:49 PM
gas smells on my heater.??? veightkiller Vancouver Impreza Club Forum -- VIC 13 01-14-2005 10:56 PM
I smell gas when I turn on my heater DetroitWRX Factory 2.0L Turbo Powertrain 37 02-13-2004 03:11 AM
Fix my heater please it's getting cold starbuckjunkee 'Old School' Subaru Forum 4 11-09-2003 04:46 PM


All times are GMT -4. The time now is 03:52 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.