Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-04-2009, 02:02 AM   #1
jarrod
Scooby Newbie
 
Member#: 153188
Join Date: Jul 2007
Default help

pulling my motor cause of rod knock cant get the block from tranny any ideas all bolts are off and clutch fork is taken apart just need advice
* Registered users of the site do not see these ads.
jarrod is offline   Reply With Quote
Old 01-04-2009, 10:12 AM   #2
GreenLantern
Scooby Specialist
 
Member#: 159372
Join Date: Sep 2007
Chapter/Region: MAIC
Location: PG county, MD
Vehicle:
2007 WRX (stage ++)
UGM

Default

Kaldar142 and i had this same problem when pulling his 05 wrx motor out as well....
to be honest, its just really really stuck on there hard (if its never been removed before) very tight stock seal i guess

the way Joe and I got his apart was rather stupid/dangerous

we were lifting his engine with a motor lift and the straps holding the motor broke (we were trying to pull up the engine and use the weight of the car as leverage to pry the two apart by just continuing to lift the engine even as the car started to lift by the tranny. these are the ideas you get with several beers and a dash of frustration ) and when the motor dropped back down into place (fell a good probably foot or so) the tranny and motor cracked apart. Nothing damaged surprisingly and lucky neither joe nor I's hands or anything got crushed/mangled by the falling motor. BE CAREFUL!!! OUR ENGINES MAY BE SMALL BUT THEY STILL ARE HEAVY kinda

lol so not saying that you should drop your motor, because i am assuming you still want to keep and use it (kaldar only needed the heads from his stocker...bought LeeC's motor) but just an idea of how hard it is. Im sure theres a trick to it. just remember, there are long rod/bolts that go between the tranny and the motor that you gotta slide the motor forward off of to.

Good luck homie

-GreenLantern
GreenLantern is offline   Reply With Quote
Old 01-04-2009, 11:11 AM   #3
Unabomber
Big Ron
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

http://forums.nasioc.com/forums/usercp.php? fill this out
When you post a thread, the title should be a synopsis of your problem so something vague like help

Search in the transmission forum....your help is in there.
Unabomber is offline   Reply With Quote
Old 01-04-2009, 11:32 AM   #4
madmax718
Scooby Specialist
 
Member#: 172501
Join Date: Feb 2008
Default

a good penetrant on the bell housing and engine seal seems to help too..
madmax718 is offline   Reply With Quote
Old 01-04-2009, 04:47 PM   #5
turd_ferguson
Scooby Newbie
 
Member#: 114609
Join Date: May 2006
Chapter/Region: MWSOC
Location: Logan, OH
Default

It took me about an hour the other day to break mine loose. As a last resort, I took a block of wood and placed it on various parts of the transmission as I beat it with a hammer. Eventually the engine and transmission started to separate far enough for me to get something in there to gently pry them apart (be careful, it's aluminum).
turd_ferguson is offline   Reply With Quote
Old 01-04-2009, 05:35 PM   #6
jarrod
Scooby Newbie
 
Member#: 153188
Join Date: Jul 2007
Default

thanks for all the advice i appreciate it
jarrod is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! bluesbrother Mid Atlantic Impreza Club -- MAIC 8 06-08-2010 12:10 AM
help!!! flashing cel and no one can help tommy 02wrx Factory 2.0L Turbo Powertrain 21 06-05-2010 07:26 PM
Help. o2 sensor subizzo02 Factory 2.0L Turbo Powertrain 6 06-04-2010 07:03 PM
anyone have a pioneer avic u310bt need some help cosanostra Car Audio, Video & Security 5 06-04-2010 12:20 PM
need help with a/c compressor replacement sen7inel Factory 2.5L Turbo Powertrain 0 06-04-2010 08:53 AM


All times are GMT -4. The time now is 08:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.