Welcome to the North American Subaru Impreza Owners Club Sunday August 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-05-2009, 01:35 PM   #1
jddelrosso
Scooby Newbie
 
Member#: 171832
Join Date: Feb 2008
Default CEL P0420 - Catalyst efficience low-bank 1

Hey guys,
I have a 2002 WRX. I have just replaced the Front and Rear O2 sensor because of this CEL code P0420. I am stumped. It stayed off for 1000 miles after replacing the front 02 sensor and it is back now. I have noticed a drop in Fuel Efficiency too. I was getting 29mpg now only 23mpg. I have talked to multiple Subaru dealers. They didn't give me a straight answer. One said front cat, one said rear cat. PLEASE help. Any insight would be greatly appreciated.
~thanks,
Aaron
* Registered users of the site do not see these ads.

Last edited by jddelrosso; 01-05-2009 at 02:10 PM.
jddelrosso is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-05-2009, 02:32 PM   #2
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Default

PO420 is a code that often requires an expensive fix. What you should do is inspect the cats for breaking apart & or being clogged. Not a fun task for sure. Does your car consume any oil?
mikeythejew is offline   Reply With Quote
Old 01-05-2009, 02:49 PM   #3
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Default

Link shows an example of a failing cat. http://www.2carpros.com/how_does_it_work/images/catalyst_material.jpg

Whats scary is that on some cars, if the cat(s) go out, it can ruin the engine. Some engine desings that eliminated the use of an EGR valve have the valve overlap set as that it creates reversion. When a cat goes out, it sucks the fine paricles into the engine, wearing out the cylinder walls. Nissan QR25DE engines in altimas, the 02' up SER and the toyota MR2 spyder are known for thisw problem.
mikeythejew is offline   Reply With Quote
Old 01-05-2009, 02:59 PM   #4
jddelrosso
Scooby Newbie
 
Member#: 171832
Join Date: Feb 2008
Default

The car doesn't consume any oil, which would eliminate the threat of oil leakage into exhauset valve guide seals or piston rings.
jddelrosso is offline   Reply With Quote
Old 01-05-2009, 03:35 PM   #5
mikeythejew
Scooby Specialist
 
Member#: 141672
Join Date: Feb 2007
Vehicle:
07' wrx
Mothballed until winter

Default

Quote:
Originally Posted by jddelrosso View Post
The car doesn't consume any oil, which would eliminate the threat of oil leakage into exhauset valve guide seals or piston rings.
Cat(s) could still be shot. I think there may be a low incidence of 2.0L WRX precat failures if you search. I absolutely would not drive this car until it is fixed.
mikeythejew is offline   Reply With Quote
Old 01-05-2009, 06:01 PM   #6
jddelrosso
Scooby Newbie
 
Member#: 171832
Join Date: Feb 2008
Default

Thanks for the help. Every little bit counts. I am going to do more and more research and try to fix this issue the cheapest way possible. Luckily, I do all the work myself and don't have to pay for labor.
Thanks again
jddelrosso is offline   Reply With Quote
Old 01-06-2009, 12:56 PM   #7
Davidwrx
Scooby Newbie
 
Member#: 141028
Join Date: Feb 2007
Location: Atlanta, GA
Vehicle:
2002 WRX Wagon
WRB

Default

If you end up having to replace the cats, you can usually get a stock downpipe (has 2nd and 3rd in it) used cheap here. Maybe $100. Shipping will be a bit high as they are usually heavy. Check model years, but I think any 02-05 will work. I think in 06 they changed lengths of some of the pieces.

There is plenty of guidance on how to change the downpipe.
Davidwrx is offline   Reply With Quote
Old 01-24-2009, 02:03 PM   #8
D.C.W.J.
Scooby Newbie
 
Member#: 153334
Join Date: Jul 2007
Chapter/Region: SWIC
Location: Flagstaff, AZ
Vehicle:
2006 STI
SGM

Default

I have a friend of mine who says her wrx is throwing this code now. The question i have is it normally just the cats in the downpipe that are going bad or would we need to replace her uppipe as well?
D.C.W.J. is offline   Reply With Quote
Old 01-24-2009, 02:15 PM   #9
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

The only cat montitored is the one between the Front AF sensor and the Rear Oxygen sensor, the ECM has no idea if the upipe cat or rear cat is efficient because it does not monitor them.
munkis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
BNIB exedy stage 1 clutch 15804 $335 picked up Wannascooby SCIC Private Classifieds 19 07-15-2010 04:18 PM
help!!! flashing cel and no one can help tommy 02wrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 21 06-05-2010 07:26 PM
valentine 1 - needs to b fixed ? AMOS GT Car Audio, Video & Security 3 06-04-2010 03:31 PM
HELP!! flashing cel tommy 02wrx Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 06-04-2010 01:38 PM
FS : Innovate LC-1 Wideband with XD-Gauge alcoolaid VIC Private Classifieds 0 06-04-2010 04:12 AM


All times are GMT -4. The time now is 04:25 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.