Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-07-2009, 07:38 PM   #1
speed_ga
Scooby Newbie
 
Member#: 188906
Join Date: Sep 2008
Chapter/Region: South East
Vehicle:
1999 Legacy SUS lmt.
Black Cherry

Default Lower Radiator hose busted...Now car overheats...?

Ok yesterday my friend said he smelt antifreeze....so I popped the hood to find that I had no anti-freeze in my expansion resevoir. So I put some in and later that day found a knife-like slash in my lower radiator hose. I replace the hose and refilled with anti-freeze.

Here's the problem....While idleing...the car will run great and at normal temp....even when I revved the car to 2500rpms after refilling to burp the engine.

Now when driving down the road....my expansion resevoir tank will fill up to the top....way past the full line. and my temp gauge will go to hot.

Anyways, does anyone have any ideas on what the problem is.


It's 1999 subaru legacy with the 2.5 EJ25
* Registered users of the site do not see these ads.
speed_ga is offline   Reply With Quote
Old 01-07-2009, 07:53 PM   #2
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

Assuming its not the thermostat or water pump id say first make sure there is not any air bubbles in the cooling system anywhere.
stretchedk7 is offline   Reply With Quote
Old 01-07-2009, 07:55 PM   #3
speed_ga
Scooby Newbie
 
Member#: 188906
Join Date: Sep 2008
Chapter/Region: South East
Vehicle:
1999 Legacy SUS lmt.
Black Cherry

Default

whats the best way to get rid of the air bubbles?
speed_ga is offline   Reply With Quote
Old 01-07-2009, 08:55 PM   #4
stretchedk7
Scooby Guru
 
Member#: 170602
Join Date: Jan 2008
Location: j-ville fl
Vehicle:
06 Wrx RWD Auto
76MM-AEM-2200's

Default

Sorry for the slow response. When the car is cold, remove the cap from the upper coolant tank abover turbo and make sure its full, then fire up the car and turn on the heater. Run the car and continue to fill this tank until the burping has stopped. If that doesn't help, you can take the cap off the radiator when the car is cool and run it again.

Last edited by stretchedk7; 01-07-2009 at 09:01 PM.
stretchedk7 is offline   Reply With Quote
Old 01-08-2009, 04:50 PM   #5
speed_ga
Scooby Newbie
 
Member#: 188906
Join Date: Sep 2008
Chapter/Region: South East
Vehicle:
1999 Legacy SUS lmt.
Black Cherry

Default

thanks so much!!

Besides the fact that I was sold a faulty thermostat that I had to replace... The burping really helped and now it's back to normal...or so I hope it is
speed_ga is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
mishimoto lower radiator hose sndc5 Engine/Power/Exhaust 3 08-25-2009 04:25 AM
Brand New Samco Sti Lower Radiator Hose!! Only Lower Hose New! Dugansti Engine/Power/Exhaust 0 12-12-2008 08:34 PM
WTB: WRX Water pump, Thermostat housing and lower radiator hose? CUNNINGHAM Private 'Wanted' Classifieds 1 04-13-2007 10:52 AM
NIB perrin LOWER radiator hose RED w/free scuffed up top one Sti-lin' Engine/Power/Exhaust 2 02-01-2007 12:20 PM
Best Lower Radiator Hose I can get. Dre2932 Normally Aspirated Powertrain 0 04-07-2004 11:34 AM


All times are GMT -4. The time now is 08:06 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.