Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-11-2009, 12:10 AM   #1
aigochamaloh
Scooby Newbie
 
Member#: 188167
Join Date: Aug 2008
Chapter/Region: SCIC
Vehicle:
2015 WRX Premium GBP
2009 Legacy 2.5i DGM

Default Stumbling, shaking idle?

So I have a 09 Legacy 2.5i. It has about 9000 miles on it. When I'm sitting at a light or something, just when the car is idling, it stumbles a bit. It's very slight, but enough that I notice it. The car accelerates just fine, it delivers its' power very smoothly, but just at idle, I get stumbling, almost like it's missing.

Another thing, when I'm approaching a stop and I go through my downshifting, then finally popping into neutral, the engine RPM's drop really low, then catches itself and idles normally. I'm told this is normal behavior, I just want to make sure.

I only ask the second part, because I was making a left turn once onto a freeway onramp, and I downshifted really slowly for some reason. But the RPM's dropped low, and the car stalled mid turn, while I was going about 20 mph. I only noticed because the steering went heavy. I just assumed that while the RPM's dropped low, my steering input, using power from the power steering, robbed too much from the engine at such a low idle. I hope that doesn't happen again, that was pretty dangerous.

Anything I should be worried about?
* Registered users of the site do not see these ads.
aigochamaloh is offline   Reply With Quote
Old 01-11-2009, 02:04 AM   #2
RaceFaceXC
NASIOC Supporter
 
Member#: 165749
Join Date: Dec 2007
Chapter/Region: South East
Location: stupid Florida
Vehicle:
2007 No YELLING
on the bus!

Default

my 07 does this on occasion, but its not as severe as yours. It has never stalled on me. can you reproduce a stall if you try? if you can, take it to the dealer and do it for them.
RaceFaceXC is offline   Reply With Quote
Old 01-11-2009, 09:07 PM   #3
Ducki3
Scooby Newbie
 
Member#: 199863
Join Date: Jan 2009
Default

I had the same problem with my 03 RS. I recently replaced the spark plugs and it stopped, However now I have a fuel smell in the cab coming from the vents. The motor is running great though. anyone know why this would happen? I don't feel like burning to death on my way to school tomorrow.
Ducki3 is offline   Reply With Quote
Old 01-11-2009, 09:08 PM   #4
P-Tein
Scooby Newbie
 
Member#: 197399
Join Date: Dec 2008
Chapter/Region: Tri-State
Location: Bronx, NY
Vehicle:
Blue 2006 WRX TR
1990 Mustang GT

Default

Quote:
Originally Posted by Ducki3 View Post
I had the same problem with my 03 RS. I recently replaced the spark plugs and it stopped, However now I have a fuel smell in the cab coming from the vents. The motor is running great though. anyone know why this would happen? I don't feel like burning to death on my way to school tomorrow.

Before reading your reply I was about to say check the spark plugs. You can replace them yourself with the proper wrench and spacer.
P-Tein is offline   Reply With Quote
Old 01-12-2009, 12:22 AM   #5
NARanger
Scooby Newbie
 
Member#: 199878
Join Date: Jan 2009
Default I think I have your answer!!!!

I have a new 2008 Subaru Impreza 2.5i. This has the same powertrain as your 09 Legacy. Assuming it is a manual. I was having the same problem and I talked to the Service Manager at Subaru of Jacksonville, where I worked at the time. I had to have a fix done on mine for the same reasons. He told me that their were alot of reports for this problem so Subaru issued a fix. You may have not heard about it because its not considered a safty recall. I was a Subaru Salesman so I had the inside scoop.
NARanger is offline   Reply With Quote
Old 01-12-2009, 01:05 AM   #6
aigochamaloh
Scooby Newbie
 
Member#: 188167
Join Date: Aug 2008
Chapter/Region: SCIC
Vehicle:
2015 WRX Premium GBP
2009 Legacy 2.5i DGM

Default

Do you have any service bulletin number or any info that would be helpful when going to my dealership? Thanks for the insider info!
aigochamaloh is offline   Reply With Quote
Old 01-12-2009, 02:50 AM   #7
kyle_g
Scooby Newbie
 
Member#: 182162
Join Date: Jun 2008
Location: Flagstaff, AZ
Vehicle:
2000 Legacy

Default

This is kind of interesting - my 2000 Legacy has the EXACT same problems you're describing. Car also runs and drives like a champ when I give it gas too.

The rough/inconsistent idle, the rpms falling down to near 100 when downshifting then coming back up, and the random stalling. I've had all of those. The stalling not so much anymore but it used to happen randomly when I'd just drive the car down the road and back. The idle and rpms falling/stumbling though, those wont go away. It seems to have gotten better after cleaning the throttle body twice now but it's still very annoying.

I've replaced the plugs twice, no difference.

Keep us updated.
kyle_g is offline   Reply With Quote
Old 01-12-2009, 06:31 AM   #8
VIsubi
Scooby Specialist
 
Member#: 187834
Join Date: Aug 2008
Vehicle:
06 2.5i impreza
Red

Default

Mine does this to stumbles a little at idle..this is normal your idle is some where at 500rpm or 800rpm and the load frequancy that all four tires make on the engine is enough to stall it if your not right on the clutch ingagement. I've never had my rpm's drop that quick when downshifting and I go thru all the gears. hmm owell get it fixed while you have warranty.
VIsubi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
stumbles off idle and small oil leak??? NETWRX Factory 2.0L Turbo Powertrain 0 10-02-2007 08:05 PM
Stumble at idle after mods 3XRex Factory 2.5L Turbo Powertrain 0 03-28-2007 12:36 AM
02 Shifter shakes @ idle?? noobwrx02 Factory 2.0L Turbo Powertrain 3 05-20-2004 11:43 AM
A/F not cycling, stumbly idle, cause found Aphex Normally Aspirated with bolt-on Forced Induction Powertrain 3 05-15-2002 09:50 AM
booty shaking idle with a/c on RaceCarRiot Normally Aspirated Powertrain 0 01-15-2002 12:58 PM


All times are GMT -4. The time now is 02:04 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.