Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
View Poll Results: Am I screwed or not?
Yes, sell the car while you can 0 0%
Yes, go buy a new clutch 0 0%
No, have the pedal adjusted again 0 0%
No, take it somewhere to have it looked at and fixed 3 100.00%
Voters: 3. You may not vote on this poll

Reply
 
Thread Tools Display Modes
Old 01-12-2009, 08:41 PM   #1
kokilc
Scooby Newbie
 
Member#: 94425
Join Date: Aug 2005
Chapter/Region: Tri-State
Location: Port Chester, NY
Vehicle:
05 Impreza 2.5 RS
Dark Blue

Default New Clutch - Bad Noises

Hey guys and gals,

So I have a 05 2.5 RS, manual, and a few months back the throwout bearing blew out so i would get that lovely shutter noise when taking off, or switching gears. After doing my homework online, and throughout other various consultations with known vendors, i decided to go out and buy the exedy clutch kit. Just the oem replacement, not a stage one. so the clutch came in, and i didnt really have time to have it installed. Finally on the week between xmas and new years, i was in florida, found a shop who would do the install for about 3-4 bills of my hard earned cash.

Monday - Car goes in for the install around noon.
Tuesday 9 am, car is ready for pickup
Tuesday 10 am, car is picked up and driving better than the day i bought it
Thursday, new years day, 9 am, i leave florida for ny.
Thursday, midnight, make it to NY and car is running like a champ with 400 miles to the tank on 93 gas (32mpg anyone?)

couple of days go by with driving to work and around town, and i heard a clicking noise. Went and checked the fluid level, and it was low, so i added some in. Clicking noise went away, all problems solved!

NOT!

now, 1800 miles into the new clutch (1000 miles just from Fla to NY) the car is making a terrible noise. Lets discuss.

When the pedal is out, and car is at startup, idle, it is a repetative noise, sounds like a belt that is wet and bad. If i slightly touch the pedal and push it in to the point before the catch point, Roughly 1/2 inch, the squealing goes away.

So today i took the car to a transmission shop. I told the guy my issue, and told him that when i press the clutch in, that the noise goes away, so he suggests that they do a pedal adjustment. The guy does the adjustment and brings the car out. The noise is still there, and now the pedal is almost sitting on the floor. I get and say to him that this isnt how i want it, and the pedal being on the floor isnt good, so put it back to how it was. They take it in, bring the pedal back out, and now its higher than it was before i gave it to him, but at idle NO NOISE!!! YAY! Guy says that he doesnt want anything since they undid their work, i give him a 10 dollar tip and drive away.

I get two blocks away, and the noise starts again, but now rather then at idle it happens WHILE IM DRIVING!!! (NEVER MADE THE NOISE IN THE PAST WHILE DRIVING) So i get to a stop light, i hear no noise, then i take off, and with the pedal completely out, there is alot and i mean alot of that squealing belt noise. So i figure lets test the theory, and just slightly put my foot on the pedal, noise goes away while driving. By the way this is happening in all gears up to 4th now, and 5th hasnt been tried because i havent made it on a highway until i figure out what this is.

So, suggestions, comments, something???
All help is appreciated. Negative banter about the giants loss, or poor clutch choices are not accepted.
* Registered users of the site do not see these ads.
kokilc is offline   Reply With Quote
Old 01-12-2009, 09:08 PM   #2
Counterfit
Scooby Guru
 
Member#: 124254
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Rhode Island
Vehicle:
2006 06 SGM Slowbaru
"The Scoobinator"

Default

I don't think it's the clutch choice so much as the install itself.





P.S.: Dear Eli,
Welcome to the offseason.
-Romo
Counterfit is offline   Reply With Quote
Old 01-12-2009, 09:57 PM   #3
DiscoGsus
Scooby Specialist
 
Member#: 47646
Join Date: Nov 2003
Chapter/Region: MAIC
Location: NoVa
Vehicle:
0211 RallyWagon
DGM Sedan

Default

That is exactly what mine was doing.... so I replaced the throwout bearing and the noise went away.

Take it back.
DiscoGsus is offline   Reply With Quote
Old 01-12-2009, 11:03 PM   #4
Dubld
Scooby Newbie
 
Member#: 177881
Join Date: Apr 2008
Chapter/Region: SWIC
Location: Lake Havasu City, AZ
Vehicle:
2002 OBS
custom green

Default

My clutch was doing the same thing, everybody figured it was the throwout bearing. I did'nt have the $$$ at the time to fix it. The noise made me so mad that I started abusing the clutch...the funny thing? That made the noise go away!...but I toasted the clutch & flywheel. I'm having the exedy stage I & ACT lightweight flywheel put in now. My throwout bearing wasn't really that bad though, the pilot bearing on the other hand -was toast. So I would say either throwout or pilot bearing in your case. I'd also put blame at the install...
I hope mine goes well!

p.s.
The Giants loss gave home field to the Cards...making me a happy camper.
Dubld is offline   Reply With Quote
Old 01-12-2009, 11:05 PM   #5
subydude
Scooby Specialist
 
Member#: 80649
Join Date: Jan 2005
Chapter/Region: South East
Location: Columbia, SC
Vehicle:
2000 2.5 Auto-X RSTi
What's A Head Gasket?

Default

I had the squealing noise when letting the clutch out. It was the throwout bearing contacting the pressure plate. Once I put a new throwout bearing and pressure plate in (along with new clutch and flywheel) everything was fixed.
subydude is offline   Reply With Quote
Old 01-12-2009, 11:53 PM   #6
kokilc
Scooby Newbie
 
Member#: 94425
Join Date: Aug 2005
Chapter/Region: Tri-State
Location: Port Chester, NY
Vehicle:
05 Impreza 2.5 RS
Dark Blue

Default

the thing that upsets me the most is that i just replaced this clutch and all of the components cause the throwout bearing was shot!!! Unfortunately since the install was done in FLA i cant take it back. The other thing that sucks is that it was my part, so the repair facility may or may not help my cause at all. we shall see...
kokilc is offline   Reply With Quote
Old 01-13-2009, 03:17 AM   #7
Tim Sanderson
Scooby Guru
 
Member#: 6486
Join Date: May 2001
Chapter/Region: MWSOC
Location: S.E. wisconsin
Vehicle:
00 Impreza 2.5 RS
Blue Ridge Pearl

Default

If I had to guess, And I do, I would agree that it's a bad throw out bearing.

I don't understand why you had the work done in florida. Oh well, done and over.

Contact some local members near you and get someone to do it right for you.
Tim Sanderson is offline   Reply With Quote
Old 01-13-2009, 03:33 AM   #8
turb04
Scooby Specialist
 
Member#: 61386
Join Date: May 2004
Chapter/Region: SCIC
Location: Tha O*C*
Vehicle:
04 PSM WRX R.I.P.
05 Snow White Camry

Default

Do you have a light wieght fly?
turb04 is offline   Reply With Quote
Old 01-13-2009, 03:18 PM   #9
Reble_45
Scooby Newbie
 
Member#: 199014
Join Date: Jan 2009
Default

I also would look into contacting the BBB (Better Business Bureau) if you still have the receipt and the phone and name of the place that did it. Helped me in the past with bad installs.
Reble_45 is offline   Reply With Quote
Old 01-14-2009, 10:28 AM   #10
Skidd
Scooby Specialist
 
Member#: 1853
Join Date: Jul 2000
Chapter/Region: TXIC
Location: SA-TX (Hozer expat)
Vehicle:
GC6 Supercharged
STM

Default

Just an FYI, mine does the same thing, except the sound is more like a bad rod bearing. Kinda like a knocking sound. It all started about 5 months after installing a new ACT Clutch,PP,Throwout Bearing, Pilot Bearing and 14lb Flywheel. All new components! But.. alas.. I suspect that it's related to the TB. D'Oh! And just like you, press the clutch just a little, and the sound stops?

However... this is what I thought was the true reason/fix for the sound I get
http://www.subaruwrxparts.com/produc...1b4b8f9c34ec61
Skidd is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
new clutch pedal noise? or am i just crazy? or both? roccer Transmission (AT/MT) & Driveline 0 10-20-2007 08:34 PM
New Clutch, Wierd Noise wrxphantom Transmission (AT/MT) & Driveline 6 06-27-2007 08:07 AM
New Clutch, Wierd Noise ??? wrxphantom Transmission (AT/MT) & Driveline 0 06-26-2007 09:23 PM
new clutch!!BAD wheelhop! HELP shark3y06 Transmission (AT/MT) & Driveline 10 09-02-2006 08:31 PM
Need new clutch badly any suggestions? BlueScooby New England Impreza Club Forum -- NESIC 7 02-23-2001 01:44 AM


All times are GMT -4. The time now is 12:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.