Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-11-2009, 09:13 AM   #1
davecoon13
Scooby Newbie
 
Member#: 122823
Join Date: Aug 2006
Chapter/Region: MAIC
Location: Alexandria, VA
Vehicle:
2003 Baja Sport
SilverStone Metallic

Default ARE Cap Removal/Reinstallation Question

I have had my ARE cap now for a few months and removed it twice. I never have been able to get it to seal water tight between the back window of the main cabin and the front of the ARE cap. When I purchased the cap, they installed it by stretching a 2" x 4" across the inside lip and using ratchet tiedowns hooked to the bed tiedown rings to ratchet it down. When I tried this, I broke my 2x4 (as they did with theirs on the first try). Is there a secret to get the cap to reseat properly to seal tightly against the roof of the main vehicle?
* Registered users of the site do not see these ads.
davecoon13 is offline   Reply With Quote
Old 01-28-2009, 05:18 PM   #2
weiVA
Scooby Newbie
 
Member#: 72942
Join Date: Oct 2004
Location: Arlington, VA
Vehicle:
2005 Baja T
Atl Blue Pearl

Default

Dunno, mine slips right on and off... pinching my fingers constantly in the process.

I bought mine used and don't have any foam if that makes a difference.
weiVA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Center cap removal question. ARBoost Tire & Wheel 5 12-26-2008 11:17 PM
EJ20K oilpan removal/reinstall kheff46 Pre-2002 Factory Turbo Powertrain 15 12-14-2006 07:41 PM
Spark plug remove + reinstall with FMIC, Tips? GMTarkin Factory 2.0L Turbo Powertrain 0 08-25-2005 05:35 PM
Remove/Reinstall Bumber Cover? HAL1 Interior & Exterior Modification 1 09-23-2004 08:17 AM
How to remove/reinstall the stock turbo in the 2004? JoeCool Factory 2.0L Turbo Powertrain 27 01-01-2004 01:10 AM


All times are GMT -4. The time now is 11:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.