Welcome to the North American Subaru Impreza Owners Club Saturday September 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-01-2009, 01:46 AM   #1
WhiteKnightSTi
Scooby Specialist
 
Member#: 169250
Join Date: Jan 2008
Chapter/Region: NESIC
Vehicle:
2001 Schweizer 300CB
(wirlybird)

Unhappy 05 STi Aux wiring help needed.

Ok, so I've got a set of Hella 500 driving lights that I'm trying to wire up, and I'm running into a problem getting a 12v signal from the high beams (I want the 500's to come on when the High beams are turned on).

From what I can find out it's due to the high beams running off a switched ground, so both wires going to the light are hot at all times so I can't use them as a signal. And it seems my only two options are to run another relay which I don't want to do, or tap into the signal coming from the stalk on the steering column which is what I want to do, but cant seem to find out what color wire the high beam signal is.

Can anyone with a 05 Sti wiring diagram help me out?

Thanks in advance.
* Registered users of the site do not see these ads.
WhiteKnightSTi is offline   Reply With Quote
Old 02-01-2009, 03:26 AM   #2
Horkus
Scooby Newbie
 
Member#: 112667
Join Date: Apr 2006
Chapter/Region: VIC
Location: Coquitlam
Vehicle:
2002 WRX wagon
WRB

Default

red on right
white black on left.
(-) controlled signals for high beams.
steering column one is red color.

Pls test before connection.
Do this at your own risk
Horkus is offline   Reply With Quote
Old 10-19-2009, 12:15 AM   #3
Turk84
Scooby Newbie
 
Member#: 90696
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage
Vehicle:
2005 WRX Wagon
Silver

Default

Anybody have more insight into doing this?

I'm trying to wire in some PIAA 520's on my wife's WRX and want her to be able to turn the AUX lights on and off with the high beams. I thought I could tap into the high beam itself but ran into the same problem the OP had.

Thanks,
~Turk
Turk84 is offline   Reply With Quote
Old 10-19-2009, 12:41 AM   #4
jutes85
Scooby Specialist
 
Member#: 127232
Join Date: Sep 2006
Chapter/Region: W. Canada
Location: Suck Lake, Alberta
Vehicle:
E92 M3
98' Foz

Default

Quote:
Originally Posted by Turk84 View Post
Anybody have more insight into doing this?

I'm trying to wire in some PIAA 520's on my wife's WRX and want her to be able to turn the AUX lights on and off with the high beams. I thought I could tap into the high beam itself but ran into the same problem the OP had.

Thanks,
~Turk

You really have to look at a wiring diagram for your year to see which is the hotwire for the high beams.
jutes85 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Aux wiring help needed Turk84 Alaskan Impreza Club Forum -- AKIC 9 10-19-2009 06:39 PM
Hella AUX. Wiring help (I have done a search) theicewall Electrical & Lighting 17 12-30-2004 09:41 PM
STI stereo wiring help needed WRC-STI Car Audio, Video & Security 2 11-29-2003 02:56 AM
Tach wiring help needed Rovah New England Impreza Club Forum -- NESIC 2 08-07-2002 01:35 PM
Wiring help needed Fred Zaplitny Car Audio, Video & Security 0 01-09-2002 09:22 AM


All times are GMT -4. The time now is 03:01 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.