Welcome to the North American Subaru Impreza Owners Club Friday March 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-05-2009, 08:44 PM   #1
frederik
Scooby Specialist
 
Member#: 64405
Join Date: Jun 2004
Chapter/Region: E. Canada
Location: St-Georges, QC, Canada
Vehicle:
2003 WRX Sedan
WRB - Cobb Stg 2

Default Cold - Wont start and pump not cycling

It is about -20c outside. I tried to start my car at the end of my work day and let off the key after about 1 second (kinda automatically released the key because I thought the car was started).

Then I noticed it was not started and tried again, but it would rev forever (at pretty good speed) without starting. I then noticed that my fuel pump was not starting when turning the key.

I do believe the ecu should cycle the pump at each and every OFF-ON transition of the key switch because I remember in the past switching the key more than once and I could always hear the pump.

Maybe there is water frozen in the pump?

I never changed the plugs and the car is 105k miles and it is probably more than due. I recently stalled when releasing the clutch too fast in a hill and the car was hard to restart and the engine would bug a lot while trying to rev.

I poured fuel anti freeze just in case it helps. Going back there in a few minutes to try again.

Let me know if you have any idea about the pump not cycling and the motor turning forever without starting (battery is good).
* Registered users of the site do not see these ads.
frederik is offline   Reply With Quote
Old 02-06-2009, 08:53 AM   #2
frederik
Scooby Specialist
 
Member#: 64405
Join Date: Jun 2004
Chapter/Region: E. Canada
Location: St-Georges, QC, Canada
Vehicle:
2003 WRX Sedan
WRB - Cobb Stg 2

Default

Pump not cycling this morning either. Did not try to start the car anyway cause its -25c this morning. Going to try again this afternoon when it's "hotter".

You think a frozen line or something could cause the pump to not be able to turn ?
frederik is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car Wont Start... Fuel Pump Not Priming... Any Ideas? dug-e-fresh Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 08-09-2011 04:35 PM
Fuel Pump not coming on... SikSilvrSuby Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 08-17-2010 07:27 PM
Clattering on cold start ... and then not? Scrotus Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 06-28-2009 02:28 PM
Flowrate, Line pressure and Pump duty cycle discussion... Richard L Water/Methanol Injection, Nitrous & Intercooler Cooling 102 08-11-2006 12:02 PM
fuel pump will not prime, car wont start had to get towed! GregBolby Normally Aspirated with bolt-on Forced Induction Powertrain 17 03-24-2004 12:07 PM


All times are GMT -4. The time now is 08:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.