Welcome to the North American Subaru Impreza Owners Club Wednesday May 27, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-22-2009, 11:08 AM   #226
pappypusher
Scooby Newbie
 
Member#: 211919
Join Date: May 2009
Default

Tea Cup. Sorry that my problem is a 2008 but same engine, same problem, just a carry over. Sorry to waste your time.
* Registered users of the site do not see these ads.
pappypusher is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-23-2009, 03:26 AM   #227
5ub@ru
Scooby Newbie
 
Member#: 191798
Join Date: Oct 2008
Location: So. Cali
Vehicle:
2008 Legacy sPec.B
quartz silver

Default

so is everyone on this site with 09 wrx having this problem?? is there a way of finding out 09 owners that dont have this problem or would it be to early to tell since its a new car?
5ub@ru is offline   Reply With Quote
Old 05-23-2009, 06:32 AM   #228
nhmtns
Scooby Guru
 
Member#: 94283
Join Date: Aug 2005
Chapter/Region: NESIC
Location: Mt. Washington Valley, NH
Vehicle:
'05 OBXT Stage 2
Min bil är svart

Default

I haven't had any issues so far. 8,800 miles and 07/08 build date.
nhmtns is offline   Reply With Quote
Old 05-23-2009, 07:34 AM   #229
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by 5ub@ru View Post
so is everyone on this site with 09 wrx having this problem?? is there a way of finding out 09 owners that dont have this problem or would it be to early to tell since its a new car?
All of your questions are answered in the first post. No, not every 09 WRX has had the problem so far, even those within the "problem" build date range (07/08-09/08). Everything, though, is really just a guess (including what the problem build date range is), which is based on the data we've tracked in the list. We don't know anything else other than what is in the list because Subaru isn't talking.
Tea cups is offline   Reply With Quote
Old 05-23-2009, 07:54 AM   #230
powells85
Scooby Newbie
 
Member#: 201053
Join Date: Jan 2009
Location: NJ
Vehicle:
12 X

Default

Mine @ 2,800 501xxx

Last edited by powells85; 05-26-2011 at 04:11 PM.
powells85 is offline   Reply With Quote
Old 05-23-2009, 08:02 AM   #231
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by powells85 View Post
Mine @ 2,847 5012xx
Yours what? Failed? You are going to have to be more specific if it is. Is it at the dealer getting the engine replaced? What is their diagnosis? What were the symptoms? Any mods?
Tea cups is offline   Reply With Quote
Old 05-23-2009, 10:54 AM   #232
ScoobySon
Scooby Newbie
 
Member#: 198950
Join Date: Jan 2009
Chapter/Region: MWSOC
Location: Ann Arbor, MI
Vehicle:
2006 Impreza WRX STI
Grey

Default

hey, I am not on your list
ScoobySon is offline   Reply With Quote
Old 05-23-2009, 11:18 AM   #233
powells85
Scooby Newbie
 
Member#: 201053
Join Date: Jan 2009
Location: NJ
Vehicle:
12 X

Default

Spun rod bearing, dealer replaced the long block inside a week.

Stock, sounded like the various youtube videos documenting spun rod bearing.
powells85 is offline   Reply With Quote
Old 05-23-2009, 11:39 AM   #234
TunaRider
Scooby Newbie
 
Member#: 200713
Join Date: Jan 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2009 WRX
Dark Gray Metallic

Default

Quote:
Originally Posted by powells85 View Post
Spun rod bearing, dealer replaced the long block inside a week.

Stock, sounded like the various youtube videos documenting spun rod bearing.
What's your build date?
TunaRider is offline   Reply With Quote
Old 05-23-2009, 11:40 AM   #235
TunaRider
Scooby Newbie
 
Member#: 200713
Join Date: Jan 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2009 WRX
Dark Gray Metallic

Default

Quote:
Originally Posted by ScoobySon View Post
hey, I am not on your list
Yeah, Tea Cups' telepathy machine broke just last week.

Post up what happened to your car, the build date, VIN, and mileage it broke.
TunaRider is offline   Reply With Quote
Old 05-26-2009, 07:56 PM   #236
Supercrip
Scooby Newbie
 
Member#: 211090
Join Date: May 2009
Chapter/Region: E. Canada
Location: Great White North
Vehicle:
2009 WRX 5dr Stg 2
Dark Grey Metallic

Default

I've got a 09 WRX 5 Door with a 8219XX VIN and Feb/09 build date that I picked up on May 5th and I'm wondering if I'm going to be immune to this engine failure issue...

Last edited by Supercrip; 05-27-2009 at 06:05 AM.
Supercrip is offline   Reply With Quote
Old 05-26-2009, 08:05 PM   #237
irish44j
Scooby Specialist
 
Member#: 191290
Join Date: Oct 2008
Chapter/Region: MAIC
Location: Burke, VA
Vehicle:
09 OPB SM WRXsedan
85 BMW E30 M2 Rallycrossr

Default

nobody knows if you'll be immune. But the evidence so far is that the only cars with the problem are those built in July-September 08, so you really shouldn't worry about it one bit, in my opinion.
irish44j is offline   Reply With Quote
Old 05-28-2009, 03:53 PM   #238
bagels
Scooby Newbie
 
Member#: 212563
Join Date: May 2009
Default

hey i just found this list mine just started knocking on sunday...my car is in the shop they are replacing the long block so i dont have the build date but heres the last 6 of the vin
800661

its an 09 wrx premium edition hatch with almost 4800 miles on it
bagels is offline   Reply With Quote
Old 05-28-2009, 03:57 PM   #239
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by bagels View Post
hey i just found this list mine just started knocking on sunday...my car is in the shop they are replacing the long block so i dont have the build date but heres the last 6 of the vin
800661

its an 09 wrx premium edition hatch with almost 4800 miles on it
let us know what the dealer says and if they replace it under warranty. Any mods?
Tea cups is offline   Reply With Quote
Old 05-28-2009, 03:58 PM   #240
Garandman
Scooby Specialist
 
Member#: 101117
Join Date: Nov 2005
Chapter/Region: NESIC
Location: Boston / Sullivan County NH
Vehicle:
2009 WRX, 06 OBW 3.0
Tiger 1050, WR250R, TW200

Default

The second engine in my car hit 10,000 miles yesterday: so far so good.
Garandman is offline   Reply With Quote
Old 05-28-2009, 10:15 PM   #241
bagels
Scooby Newbie
 
Member#: 212563
Join Date: May 2009
Default

yep they called subaru corporate and they are replacing it for free...subaru has to know something is going on i live in buffalo and west herr was the dealership they are actually calling in a specialist for me and he is supposed to be one of the best enginers in the states for subarus so he will be installing it for me...idk i am def kinda pissed you pay all this money for this car and the thing ****s out on you subarus reputaition is starting to go down hill they need to start focusing on them building them correctly and stop trying to compete with the evo

and no i had no mods done to my car always 93 octane gas and mobile one full synthetic
bagels is offline   Reply With Quote
Old 05-29-2009, 02:21 AM   #242
NismoSkylineGTR
Scooby Specialist
 
Member#: 94622
Join Date: Aug 2005
Default

Quote:
Originally Posted by bagels View Post
yep they called subaru corporate and they are replacing it for free...subaru has to know something is going on i live in buffalo and west herr was the dealership they are actually calling in a specialist for me and he is supposed to be one of the best enginers in the states for subarus so he will be installing it for me...idk i am def kinda pissed you pay all this money for this car and the thing ****s out on you subarus reputaition is starting to go down hill they need to start focusing on them building them correctly and stop trying to compete with the evo

and no i had no mods done to my car always 93 octane gas and mobile one full synthetic
its normal they are calling a subaru rep. The dealer tech will be the one who install your engine. The rep will just check if you your car failed under "who konws what happend" to granted the warrenty repair. They did the samething to my car.
NismoSkylineGTR is offline   Reply With Quote
Old 05-29-2009, 11:28 AM   #243
engee
Scooby Newbie
 
Member#: 121486
Join Date: Jul 2006
Chapter/Region: Tri-State
Default

so is it safe to look at the new 09 wrx hatches? i recently lost MY00 L and I was looking into the new WRX 5 dr. I know we can't be certain, but I really don't want to make a $25k problem and have a decommissioned car for a while. Sorry if this post is just to rant, but I was really looking forward to picking up the 09.
engee is offline   Reply With Quote
Old 05-29-2009, 01:55 PM   #244
stoker68
Scooby Newbie
 
Member#: 208185
Join Date: Apr 2009
Chapter/Region: NESIC
Location: Mass.
Vehicle:
2009 WRX 5-door
Dark Gray Metallic

Default

Quote:
Originally Posted by engee View Post
so is it safe to look at the new 09 wrx hatches? i recently lost MY00 L and I was looking into the new WRX 5 dr. I know we can't be certain, but I really don't want to make a $25k problem and have a decommissioned car for a while. Sorry if this post is just to rant, but I was really looking forward to picking up the 09.
Many people will disagree, but I would say go for it. I did, just got mine (knock on wood) a month ago even after fallowing this issue . But seriously, judging by the data, and what conspiracy theories we've heard from Subaru, it seem the issue in "fixed" in the newer models (judging by the data that means built after September).

They are such a great car, and I just hit the lucky 1000 miles today!
stoker68 is offline   Reply With Quote
Old 05-29-2009, 02:01 PM   #245
WRBear
Scooby Specialist
 
Member#: 207171
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Gun wavin' New Haven
Vehicle:
2009 WRX
WRB

Default

Quote:
Originally Posted by stoker68 View Post
Many people will disagree, but I would say go for it. I did, just got mine (knock on wood) a month ago even after fallowing this issue . But seriously, judging by the data, and what conspiracy theories we've heard from Subaru, it seem the issue in "fixed" in the newer models (judging by the data that means built after September).

They are such a great car, and I just hit the lucky 1000 miles today!
2500+ miles and going strong! January '09 build date
WRBear is offline   Reply With Quote
Old 05-29-2009, 02:30 PM   #246
greddy90
Scooby Newbie
 
Member#: 147065
Join Date: Apr 2007
Default

My opinion is that Subaru has fixed the issue and the new batches are good. You see most problems in July-Sept. 08, just get one with a newer build date.
greddy90 is offline   Reply With Quote
Old 05-29-2009, 08:50 PM   #247
SoCalMonarch
Scooby Specialist
 
Member#: 142752
Join Date: Mar 2007
Chapter/Region: SCIC
Location: Mission Viejo, CA
Vehicle:
2008 WRX STi
White

Default

Not sure how applicable the issue is to the 08 STI engine issues (the Engine code and typical problems are the same) but i have one VIN 825226 MFD 01/08. No engine issues yet, did the ECU reflash recall around 4500 mi (was staying away from the redline prior) and I'm about to start modding.

Going to be probably ending with a intake, turboback, alc injection, front mount and street tune. (Probably just over 400whp with the alc injection)

Is she gonna blow?
SoCalMonarch is offline   Reply With Quote
Old 05-30-2009, 09:17 AM   #248
craigmp50
Scooby Newbie
 
Member#: 33791
Join Date: Mar 2003
Chapter/Region: Tri-State
Location: Buffalo NY
Vehicle:
2009 WRX
Lightning Red

Default Go For It

Quote:
Originally Posted by engee View Post
so is it safe to look at the new 09 wrx hatches? i recently lost MY00 L and I was looking into the new WRX 5 dr. I know we can't be certain, but I really don't want to make a $25k problem and have a decommissioned car for a while. Sorry if this post is just to rant, but I was really looking forward to picking up the 09.
I waited till April to buy my 09' 5door WRX, (built in Feb 09), so far 600 miles, runs great. Another 600 miles or so & I put in the Rotella Synthetic, Purone filter & Fumoto drain valve. My 04 WRX was a great car, but, this one is better.
craigmp50 is offline   Reply With Quote
Old 06-10-2009, 01:54 PM   #249
volcomgnu
Scooby Newbie
 
Member#: 211969
Join Date: May 2009
Default

My engine finally succumbed to the Knock last night. At the dealership currently, waiting on a call back. Just recently put the SPT cat back on.

Type: Sedan
Miles: 8,100
VIN: 500XXX
Build: 07/08
volcomgnu is offline   Reply With Quote
Old 06-10-2009, 06:17 PM   #250
Penti
Scooby Newbie
 
Member#: 148273
Join Date: May 2007
Chapter/Region: BAIC
Location: California
Vehicle:
2009 WRX Prem' 5Dr
D.Gray

Default

Engine failure today, confirmed by dealer today, bearing failure on rod #1. Replacement engine being ordered under warranty:

2009 5-door WRX
2350 miles
Built 08/08
VIN: ...804698

1000 mile drive in under 4k RPM, 93 Octane fuel used, always carefully warmed up and cooled down.

Last edited by Penti; 06-10-2009 at 06:18 PM. Reason: Added model year
Penti is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Engine Failure Poll AshJWilliams Warranty Issues & SOA Problems 201 07-12-2014 07:54 PM
2009 with an 08/08 build date? CO_Turbo Newbies & FAQs 8 05-19-2009 07:39 AM
2008 Wrx Engine Failure deunan General Community 101 03-29-2008 09:47 AM
2008 Wrx Engine Failure deunan Service & Maintenance 1 03-23-2008 10:18 PM
2008 wrx engine failure deunan Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 1 03-23-2008 10:09 PM


All times are GMT -4. The time now is 04:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.