Welcome to the North American Subaru Impreza Owners Club Friday August 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-25-2009, 08:37 PM   #501
EVL1
Scooby Newbie
 
Member#: 212931
Join Date: Jun 2009
Chapter/Region: South East
Location: St. Aug, FL
Vehicle:
2009 WRX Hatch
Spark Silver

Default

Is this thread dead?
* Registered users of the site do not see these ads.
EVL1 is offline   Reply With Quote
Old 08-25-2009, 08:41 PM   #502
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by EVL1 View Post
Is this thread dead?
Honestly, I hope so... Means the issues are behind us... Only time will tell tho...
Celly is offline   Reply With Quote
Old 08-25-2009, 08:46 PM   #503
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Considering the problem builds are almost all over 1 year old now, this thread should be slowly dying. The newest problem was from a car built within the first few days of Sept 08, right?
peglegsteve is offline   Reply With Quote
Old 08-25-2009, 08:52 PM   #504
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by peglegsteve View Post
Considering the problem builds are almost all over 1 year old now, this thread should be slowly dying. The newest problem was from a car built within the first few days of Sept 08, right?
I'm sure these cars are still sitting on lots somewhere.. If not, they replaced a clunker -- and it's just a matter of time...
Celly is offline   Reply With Quote
Old 08-25-2009, 09:17 PM   #505
5280WRX
Scooby Newbie
 
Member#: 203412
Join Date: Feb 2009
Chapter/Region: RMIC
Vehicle:
2009 WRX Sedan
SS

Default

Quote:
Originally Posted by peglegsteve View Post
The newest problem was from a car built within the first few days of Sept 08, right?
I don't think we ever received a confirmation on the build date did we?
5280WRX is offline   Reply With Quote
Old 08-25-2009, 11:21 PM   #506
NismoSkylineGTR
Scooby Specialist
 
Member#: 94622
Join Date: Aug 2005
Default

i really wonder what happend to my car!!!

anyone care to do a carfax?
NismoSkylineGTR is offline   Reply With Quote
Old 08-25-2009, 11:26 PM   #507
NismoSkylineGTR
Scooby Specialist
 
Member#: 94622
Join Date: Aug 2005
Default

Quote:
Originally Posted by Crev View Post
I showed it all to her and all she had to say (almost crying)was don't ruin this for me and we will deal with the problem if it happens.
Dealer also said no break in period on these cars. I swear I read 1,000 mile break in.
This dealer also has a 30 day return policy on all new cars within 30 days & 500 miles no questions.
retrun it get the 2010
NismoSkylineGTR is offline   Reply With Quote
Old 08-26-2009, 12:35 AM   #508
patdpro
Scooby Newbie
 
Member#: 221621
Join Date: Aug 2009
Default add me to the list

VIN 503536 build date 08/08 milage 13181

I PM'ed Tea cups to add me to the list. Mine died on my Mom's bday on Sunday. Subaru towed it to the nearest dealership (Fairfiled Subaru) which is 30 miles from me. Luckily the rest of the caravan stopped with me and I had a ride home.

Monday I called the dealsership from work and they said they were like "At first I did not know what was wrong because there was no description until I started the car." They said they would call me by noon with an update. After 3 pm I called them back and they said that they did some tests and it looks like I will need a new engine but they are waiting for a response from the east coast. They will call me back on Tuesday by 9:30AM.

Tuesday they called and said that the engine has been ordered and should arrive by noon on Thursday. They said that the car should be ready by Friday. They will call me when the engine arrives. I got a rental car today from Enterprise (covered by Subaru). The only thing they had was a Ford Focus.

Last edited by patdpro; 08-27-2009 at 01:09 AM.
patdpro is offline   Reply With Quote
Old 08-26-2009, 05:02 AM   #509
Garandman
Scooby Specialist
 
Member#: 101117
Join Date: Nov 2005
Chapter/Region: NESIC
Location: Boston
Vehicle:
2009 WRX, 06 OBW 3.0
Tiger 1050, WR250R, TW200

Default

Quote:
Originally Posted by AshJWilliams View Post
Definitely stop the deal; there is no reason that you should be paying 25k for a defective product. Trust me you don't want the hassles that I'm dealing with. I have suffered engine failure, I driven for 2 months with intermittent CELs and been in to the dealership 4 different times to have the CEL problem resolved, service technicians (though some of these items may have been previously unnoticed manufacturer defects) have damaged my intercooler and improperly re-assembled my vehicle (missing bolts, etc but literally 9 different components were/are screwed up), my vehicle for some time appeared to be using engine coolant, there are a number of issues with the ECU tune in general, and now it is making a wide array of extremely ****ed up noises. And after having discussed with SOA over the past month what options may be available to me to cordially remedy this situation, as of today they basically told me to **** off.

You'd be insane to purchase that particular vehicle, and frankly if I were you I would re-assess the decision to purchase any new Subaru. Though if you are still interested I'll sell you mine... //
I'd like to see a picture of your car, because frankly, I'm skeptical you aren't a troll.

You've been swearing, moaning, complaining, and berating Subaru since 12/12/08 when you claim this first happened to you. Just about every single other owner was taken care of in a few weeks at the most: my motor was replaced and I was back on the road in five days, including a weekend. My car now has 13,000 miles on it. SOA has even contacted people who posted in this thread to make sure they were happy. So how can you still be having the mother of all problems nine months later?

You have more than 20 posts in this thread. Clearly this car has ruined your life and you will never be happy again. Why not get rid of it before you swallow a muzzle?
Garandman is offline   Reply With Quote
Old 08-26-2009, 07:15 AM   #510
5280WRX
Scooby Newbie
 
Member#: 203412
Join Date: Feb 2009
Chapter/Region: RMIC
Vehicle:
2009 WRX Sedan
SS

Default

Quote:
Originally Posted by patdpro View Post
VIN 505303 build date 08/08
patdpro - Sorry to hear about your car but are you sure about your VIN and build date? Based on two failures with 504xxx VINs and September builds your car should either be a September build or something like a 503xxx or 504xxx VIN. Just want to make sure Tea Cups gets the correct info for our collective effort.

I'm a 5055xx with a 9-13-08 build date. So far so good at 8200 miles and waiting to see if I'm a member of the club or not.

Last edited by 5280WRX; 08-26-2009 at 07:50 AM. Reason: corrected VIN
5280WRX is offline   Reply With Quote
Old 08-26-2009, 10:16 AM   #511
ephilli2
Scooby Newbie
 
Member#: 221622
Join Date: Aug 2009
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2009 WRX Premium
Black

Unhappy Knock, knock, knock...

Looks like this thread isn't dead yet. My '09 WRX, built 08/08, started knocking yesterday at 5,303 miles. I had it towed to the dealer and I'm waiting to hear back with the diagnosis. If it's the all-too-familiar problem, I'll provide my info to be added to the dreaded engine failure list.
ephilli2 is offline   Reply With Quote
Old 08-26-2009, 07:43 PM   #512
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by Garandman View Post
I'd like to see a picture of your car, because frankly, I'm skeptical you aren't a troll.

You've been swearing, moaning, complaining, and berating Subaru since 12/12/08 when you claim this first happened to you. Just about every single other owner was taken care of in a few weeks at the most: my motor was replaced and I was back on the road in five days, including a weekend. My car now has 13,000 miles on it. SOA has even contacted people who posted in this thread to make sure they were happy. So how can you still be having the mother of all problems nine months later?

You have more than 20 posts in this thread. Clearly this car has ruined your life and you will never be happy again. Why not get rid of it before you swallow a muzzle?








It is what it is man. Like you, they replaced my initial engine in a week. No big deal (well the technician forgot to add adequate engine coolant but whatever). But then the CEL's came, which took 2 months and 4 service visits to resolve. During this time I had 8-9 other manufacturer defects and service related issues arise (damaged intercooler, missing bolts, technician forgot to add engine coolant again which caused me to think I was losing/using coolant, etc). I've been in for service for these issues as well and to this day I'm still driving with parts not properly installed under the hood and a few abnormal noises, one of which I'm fairly confident is a boost leak (and the knowledge that the guy who has completely disassembled my engine twice is the kind of guy who doesn't put all the parts back in; hmm I wonder how many other things are still ****ed up). And recently, when attempting to work with SOA to resolve these issues, they basically decided to do nothing for me. So despite your inability to believe it everything that I've said is 100% accurate. I guess maybe I go a little overboard here with the ranting but this is my first experience dropping $26k on something and having it turn out to be a total POS...and again, yeah it pisses me off. I've thought about trading it, but why should I have to take a loss on a lemon?

Your comment in regard to my post count in this thread and implied suicide attempt is moronic. If anything, its the car that should be worried. LMAO! I of course wouldn't, but the thought has crossed my mind (imagines putting 9 rounds of 385gr 2000 fps slugs from a Benelli M4 through the engine block)...
AshJWilliams is offline   Reply With Quote
Old 08-26-2009, 07:44 PM   #513
heavyD
Scooby Specialist
 
Member#: 194216
Join Date: Nov 2008
Chapter/Region: W. Canada
Location: Calgary, Alberta, Canada
Vehicle:
2013 STI Sport-tech

Default

Quote:
Originally Posted by Garandman View Post
I'd like to see a picture of your car, because frankly, I'm skeptical you aren't a troll.

You lose.
heavyD is offline   Reply With Quote
Old 08-26-2009, 07:57 PM   #514
Obsessive
Scooby Specialist
 
Member#: 77302
Join Date: Dec 2004
Chapter/Region: MWSOC
Location: Billy Mays
Vehicle:
damn well better
bail me out of this ****

Default

Quote:
Originally Posted by Garandman View Post
I'd like to see a picture of your car, because frankly, I'm skeptical you aren't a troll.

You've been swearing, moaning, complaining, and berating Subaru since 12/12/08 when you claim this first happened to you. Just about every single other owner was taken care of in a few weeks at the most: my motor was replaced and I was back on the road in five days, including a weekend. My car now has 13,000 miles on it. SOA has even contacted people who posted in this thread to make sure they were happy. So how can you still be having the mother of all problems nine months later?

You have more than 20 posts in this thread. Clearly this car has ruined your life and you will never be happy again. Why not get rid of it before you swallow a muzzle?
I fail to see where all of your butt-hurt is being generated from. He's (understandably) pissed off because he got the run-around, a crappy technician, and lame response from SoA. You didn't.
Obsessive is offline   Reply With Quote
Old 08-26-2009, 08:10 PM   #515
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

I sort of see where he's coming from; I've been ranting like a ****ing lunatic on here for a while now. But its just been one thing after another with this car. Most recently it really surprised me when SOA made the decision to do nothing for me; I was just trying to work with them to put me in another Subaru and still, nada. So now I'm driving around and this thing is making all kinds of ****ed up noises, SOA won't do anything for me, I don't feel like I can take it back to the dealer (although this was wrong of me; I received a very nice call from them today actually), and I have this lawyer telling me I have a solid case but if we can't reach a settlement it could require 1-2 years of my life to resolve. And its like WTF, when I got out of college I was just trying to buy a fun car that works...and this is where I am now. WTF!?!

AshJWilliams is offline   Reply With Quote
Old 08-26-2009, 09:47 PM   #516
Garandman
Scooby Specialist
 
Member#: 101117
Join Date: Nov 2005
Chapter/Region: NESIC
Location: Boston
Vehicle:
2009 WRX, 06 OBW 3.0
Tiger 1050, WR250R, TW200

Default

Quote:
Originally Posted by Obsessive View Post
I fail to see where all of your butt-hurt is being generated from. He's (understandably) pissed off because he got the run-around, a crappy technician, and lame response from SoA. You didn't.
Read through some of the posts?

But hey, I asked, he answered. As Bill Clinton would say "I feel your pain" and I'm at least as sincere!
Garandman is offline   Reply With Quote
Old 08-27-2009, 01:00 AM   #517
patdpro
Scooby Newbie
 
Member#: 221621
Join Date: Aug 2009
Default

Quote:
Originally Posted by 5280WRX View Post
patdpro - Sorry to hear about your car but are you sure about your VIN and build date? Based on two failures with 504xxx VINs and September builds your car should either be a September build or something like a 503xxx or 504xxx VIN. Just want to make sure Tea Cups gets the correct info for our collective effort.

I'm a 5055xx with a 9-13-08 build date. So far so good at 8200 miles and waiting to see if I'm a member of the club or not.

sorry. my VIN ends in 503536. Subaru called today and said they are going to replace the turbo as well. They said it was not broken but it had some wear and tear and that it still should be ready by Friday.
patdpro is offline   Reply With Quote
Old 08-27-2009, 01:03 AM   #518
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

Sorry to hear your troubles, but at least you're getting a new long block and turbo. Did the dealer admit to knowing about the problems?
peglegsteve is offline   Reply With Quote
Old 08-27-2009, 02:28 PM   #519
thatkhmer
Scooby Specialist
 
Member#: 217500
Join Date: Jul 2009
Chapter/Region: SCIC
Location: Long Beach
Vehicle:
2009 SWP Wrx
2010 WW Evo X

Default

My salesman actually admitted to knowing about the problem,
however once i had asked the sales manager about it he just denied denied denied
And the salesman also stirred me away from buying the ones that he knew might have the problem, i.e. build dates 07/08 and 08/08
thatkhmer is offline   Reply With Quote
Old 08-27-2009, 02:34 PM   #520
peglegsteve
Scooby Specialist
 
Member#: 209987
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Essex, MD
Vehicle:
2009 Stage eleventy
billion WRB WRX

Default

That's nice, honesty goes a long way in my book. My salesman didn't admit to knowing about it, and the service manager said he only saw one other 09 with a spun bearing, so I think he was being honest.

What build date did you end up with?
peglegsteve is offline   Reply With Quote
Old 08-28-2009, 12:29 PM   #521
ephilli2
Scooby Newbie
 
Member#: 221622
Join Date: Aug 2009
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2009 WRX Premium
Black

Default Another one bites the dust.

Looks like I can officially be added to the list. I heard from the dealer yesterday -- the engine spun a bearing. They're putting in a new long block.

2009 WRX sedan
Date of failure: 8/25/09
VIN: 502124
Build date: 08/08
Miles: 5,303

I asked the service manager if a new turbo would be included and he said no. Should I demand one? I honestly don't know too many technical details about this stuff. Could the turbo have been damaged by the bearing problem? If so, would it show obvious signs, or would there be hidden damage/stress that may only show up down the road (pun intended)?
ephilli2 is offline   Reply With Quote
Old 08-28-2009, 12:34 PM   #522
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by ephilli2 View Post
I asked the service manager if a new turbo would be included and he said no. Should I demand one? I honestly don't know too many technical details about this stuff. Could the turbo have been damaged by the bearing problem? If so, would it show obvious signs, or would there be hidden damage/stress that may only show up down the road (pun intended)?
Unless there is noticeable shaft play, or visual damage to the blades they will not replace it.. I would still ask the dealer to please check it to be on the safe side -- If it's questionable, they should have no problem replacing it since they get paid by SOA for the repair time...

Regardless -- Start talking with the SOA corporate offices about the issue... Most people on here have received the Extended warranty which will cover you in case those hidden damages do indeed show up.... down the road..
Celly is offline   Reply With Quote
Old 08-28-2009, 12:39 PM   #523
ephilli2
Scooby Newbie
 
Member#: 221622
Join Date: Aug 2009
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2009 WRX Premium
Black

Default

Quote:
Originally Posted by Celly View Post
Unless there is noticeable shaft play, or visual damage to the blades they will not replace it.. I would still ask the dealer to please check it to be on the safe side -- If it's questionable, they should have no problem replacing it since they get paid by SOA for the repair time...

Regardless -- Start talking with the SOA corporate offices about the issue... Most people on here have received the Extended warranty which will cover you in case those hidden damages do indeed show up.... down the road..
Thanks Celly. Does anyone have a good contact number for SOA?
ephilli2 is offline   Reply With Quote
Old 08-28-2009, 12:48 PM   #524
Celly
Scooby Specialist
 
Member#: 48724
Join Date: Nov 2003
Chapter/Region: South East
Location: Dead Whorelando, FL
Default

Quote:
Originally Posted by ephilli2 View Post
Thanks Celly. Does anyone have a good contact number for SOA?
Customer Service: 1-800-SUBARU3 (1-800-782-2783)

And if you're lucky -- You'll get Jennifer... Like I said before... She sounds really cute... (Someone needs to find Pictures from the company picnic so we can confirm our assumptions!! )

Also -- I would recommend not asking for handouts.. But just explain your concern with the reliability of your new car.. I'm not sure if the warranty is guaranteed, or on a per case basis...
Celly is offline   Reply With Quote
Old 08-28-2009, 01:23 PM   #525
elwray
Scooby Specialist
 
Member#: 194826
Join Date: Nov 2008
Chapter/Region: Tri-State
Location: Central NJ
Vehicle:
'09 WRX 5dr PP DGM
'07 VTX1300c, '03 VFR800

Default

lol @ Celly, that's not creepy at all

I dealt with Ralph when I had the engine go last month. He was great, actually called back with updates as he got new info from the dealership!

I went the direction of "concern over resale value due to Carfax report showing replaced engine" to make my case for the extended warranty.

Since the turbo shares the same oil that the engine uses, and metal that gets into the oil goes through the turbo.
Had the service dept check for "excessive shaft play" (that sounds weird now that I think about it ) in the turbo, which there was so they replaced it.
elwray is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Engine Failure Poll AshJWilliams Warranty Issues & SOA Problems 201 07-12-2014 07:54 PM
2009 with an 08/08 build date? CO_Turbo Newbies & FAQs 8 05-19-2009 07:39 AM
2008 Wrx Engine Failure deunan General Community 101 03-29-2008 09:47 AM
2008 Wrx Engine Failure deunan Service & Maintenance 1 03-23-2008 10:18 PM
2008 wrx engine failure deunan Factory 2.5L Turbo Powertrain 1 03-23-2008 10:09 PM


All times are GMT -4. The time now is 01:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.