Welcome to the North American Subaru Impreza Owners Club Saturday October 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-27-2009, 11:14 AM   #101
rex.rated
Scooby Newbie
 
Member#: 206428
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2009 WRX Premium 4dr
Lightning Red

Default

supposidely this issue has been resolved for pro dates 10/08-present? is this correct?

just picked up an '09 4dr wrx premium, prodate 10/08, vin ending in 507718. let's see what happens.
* Registered users of the site do not see these ads.
rex.rated is offline   Reply With Quote
Old 03-27-2009, 01:30 PM   #102
jmcgarrell
Scooby Newbie
 
Member#: 189946
Join Date: Sep 2008
Chapter/Region: NESIC
Location: Boston, MA
Vehicle:
2009 4 Door WRX
WRB!

Default

Quote:
Originally Posted by rex.rated View Post
supposidely this issue has been resolved for pro dates 10/08-present? is this correct?

just picked up an '09 4dr wrx premium, prodate 10/08, vin ending in 507718. let's see what happens.
nothing official, all rumors/assumptions.
jmcgarrell is offline   Reply With Quote
Old 03-27-2009, 09:43 PM   #103
davidylyl
Scooby Newbie
 
Member#: 199388
Join Date: Jan 2009
Default

Quote:
Originally Posted by Tea cups View Post
Any mods?
Zero mods. Was holding off - wanted to talk to Subie about downpipe and CAI.

davidylyl is offline   Reply With Quote
Old 03-27-2009, 10:36 PM   #104
andyinwi
Scooby Newbie
 
Member#: 178300
Join Date: Apr 2008
Chapter/Region: MWSOC
Location: Evansville, WI
Vehicle:
2009 WRX 5 Door
Black

Default Another 09 WRX Down. Add me to the list.

AndyinWI

802919
1861 Miles

Textbook knock. Videos and pics in hand for reference.

Thanks,
AndyinWI
andyinwi is offline   Reply With Quote
Old 03-28-2009, 07:54 AM   #105
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added another failure (andyinwi).
Tea cups is offline   Reply With Quote
Old 03-28-2009, 10:17 AM   #106
rex.rated
Scooby Newbie
 
Member#: 206428
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2009 WRX Premium 4dr
Lightning Red

Default

Quote:
Originally Posted by jmcgarrell View Post
nothing official, all rumors/assumptions.
keeping my fingers crossed

i'll keep you guys updated. i only have a little over 100 miles on it right now.
rex.rated is offline   Reply With Quote
Old 04-01-2009, 05:44 PM   #107
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added an "unconfirmed" failure (travisma).
Tea cups is offline   Reply With Quote
Old 04-02-2009, 09:26 PM   #108
nismozx
Scooby Newbie
 
Member#: 94183
Join Date: Aug 2005
Chapter/Region: NESIC
Location: NNY
Vehicle:
2009 WRX
Grey

Default

09/08
504xxx
3100mi
nismozx is offline   Reply With Quote
Old 04-02-2009, 10:58 PM   #109
irish44j
Scooby Specialist
 
Member#: 191290
Join Date: Oct 2008
Chapter/Region: MAIC
Location: Burke, VA
Vehicle:
09 OPB SM WRXsedan
85 BMW E30 M2 Rallycrossr

Default

I am the "anonymous" on the chart and it was at 9300 miles, not 9500 miles. you can put my username up now if you want.
irish44j is offline   Reply With Quote
Old 04-02-2009, 11:13 PM   #110
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added another failure (nismozx) and changed name "anonymous" to irish44j (fixed miles from 9500 to 9300).
Tea cups is offline   Reply With Quote
Old 04-03-2009, 10:07 AM   #111
AnnapolisSubaruSales
NASIOC Vendor
 
Member#: 125091
Join Date: Sep 2006
Chapter/Region: MAIC
Location: Annapolis, MD
Default Did not mean to ruffle so many furs

I guess the wrong thing to do was try to findout what my service knew. I gave you what they gave me. Never said that it was the problem, just gave some advice that they gave. Never knew it would ruffle so many furs. I do understand and agree with you all, you do not want to buy a new car and have these major issues. It would just p!ss me off too. I wish all of you the most success in getting this issue resolved so that the WRX can be the most dependable performance vehicle it has always been in the past. Just reading the post it seems like somewhere a bad batch when though and landed on the streets in the consumers hands.

Good luck to you all and if I should every heard anything special that Subaru has decided to do I will post it.
AnnapolisSubaruSales is offline   Reply With Quote
Old 04-03-2009, 10:27 AM   #112
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

I think you posted in the wrong thread.
Tea cups is offline   Reply With Quote
Old 04-04-2009, 10:11 PM   #113
leviathan3k
Scooby Newbie
 
Member#: 206529
Join Date: Mar 2009
Default

I've only recently found this thread, but the failure happened back in december.

08/08 WRX Premium
803XXX
3629 mi.

(the new engine, however, has had over 6000 mostly trouble-free miles)
leviathan3k is offline   Reply With Quote
Old 04-04-2009, 10:34 PM   #114
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

list updated - added another failure (leviathan3k).

41 total failures and an additional 10 "unconfirmed" failures for a total of 51.
Tea cups is offline   Reply With Quote
Old 04-05-2009, 01:18 AM   #115
doggieboy09
Scooby Newbie
 
Member#: 207629
Join Date: Apr 2009
Chapter/Region: MAIC
Location: Norcal
Vehicle:
2009 had WRX stage 2
now own BRZ

Default

Hi, I had just bought an 09 wagon just now. No problems yet of course. only 77 miles right now and I haven't revved over 4000. I won't do any aggressive driving until after 3000 miles and first oil change. Hopefully I won't have any problems.
doggieboy09 is offline   Reply With Quote
Old 04-05-2009, 02:16 AM   #116
CorrPerformance
Scooby Newbie
 
Member#: 153056
Join Date: Jul 2007
Location: NOLA
Default

subscribed to see the outcome of this.
CorrPerformance is offline   Reply With Quote
Old 04-05-2009, 02:51 AM   #117
tom bourque
Scooby Newbie
 
Member#: 207613
Join Date: Apr 2009
Default

ok...this is the thread i have been looking for! I bought a 09 wrx in October of last year and this chistmas i had too get the turbo replaced because oil was not getting to the turbo. Instead the oil was sprayed all over the engine compartment, causing the burn out of the turbo. Before this happened i had that juddering sound under the hood. Just this past week that same sound happened again, the next time i went too turn the car on it was dead. Subaru had the car brought in too the nearest dealership to give it a look over. Now i am in my second week of waiting for a new turbo and a new engine! This is all covered by warranty, but come on this is not what i expected of a Japanese product let a loan a subaru! I have done my home work for the last eight years on these cars and finally decided too get one... I guess you could say that i am a proud owner of a 35,000 dollar NIGHTMARE!
tom bourque is offline   Reply With Quote
Old 04-05-2009, 02:59 AM   #118
tom bourque
Scooby Newbie
 
Member#: 207613
Join Date: Apr 2009
Default

Oh yeah i am from Canada...if you want to find out more info on my peice of crap let me know. People have been requesting vin number and such. I am new too this and want to know if giving this info is ok or not. I will do my best to research.
tom bourque is offline   Reply With Quote
Old 04-05-2009, 08:01 AM   #119
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by tom bourque View Post
ok...this is the thread i have been looking for! I bought a 09 wrx in October of last year and this chistmas i had too get the turbo replaced because oil was not getting to the turbo. Instead the oil was sprayed all over the engine compartment, causing the burn out of the turbo. Before this happened i had that juddering sound under the hood. Just this past week that same sound happened again, the next time i went too turn the car on it was dead. Subaru had the car brought in too the nearest dealership to give it a look over. Now i am in my second week of waiting for a new turbo and a new engine! This is all covered by warranty, but come on this is not what i expected of a Japanese product let a loan a subaru! I have done my home work for the last eight years on these cars and finally decided too get one... I guess you could say that i am a proud owner of a 35,000 dollar NIGHTMARE!
Your failure is not representative of the 09 WRXs on this list. Those failures simply have a loud knocking noise from the engine and then a catastrophic failure.
Tea cups is offline   Reply With Quote
Old 04-05-2009, 11:18 AM   #120
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by tom bourque View Post
ok...this is the thread i have been looking for! I bought a 09 wrx in October of last year and this chistmas i had too get the turbo replaced because oil was not getting to the turbo. Instead the oil was sprayed all over the engine compartment, causing the burn out of the turbo. Before this happened i had that juddering sound under the hood. Just this past week that same sound happened again, the next time i went too turn the car on it was dead. Subaru had the car brought in too the nearest dealership to give it a look over. Now i am in my second week of waiting for a new turbo and a new engine! This is all covered by warranty, but come on this is not what i expected of a Japanese product let a loan a subaru! I have done my home work for the last eight years on these cars and finally decided too get one... I guess you could say that i am a proud owner of a 35,000 dollar NIGHTMARE!
I wouldn't be so sure of that Tea cups. Besides we have deemed this thread the 09 WRX engine failure thread; this guy needed a replacement engine at some point so I take it his previous engine failed.

Tom it seems like others have had the same concerns as you about the VIN. Just provide your VIN in the following format (based upon my VIN): instead of 500277 do 500XXX or 5002XX.
AshJWilliams is offline   Reply With Quote
Old 04-05-2009, 11:33 AM   #121
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Quote:
Originally Posted by AshJWilliams View Post
I wouldn't be so sure of that Tea cups. Besides we have deemed this thread the 09 WRX engine failure thread; this guy needed a replacement engine at some point so I take it his previous engine failed.
The list should be (and has been) limited to the specific rod knocking symptom and subsequent failure. We don't want to lump in failures due to other causes and it sounds like his failure was due to an oil leak at one of the turbo supply lines which caused oil starvation in the motor.
Tea cups is offline   Reply With Quote
Old 04-05-2009, 02:08 PM   #122
BIGSKYWRX
Scooby Guru
 
Member#: 7958
Join Date: Jul 2001
Location: Plains of Eastern Montana
Vehicle:
09 GH B+

Default

tom did you hear this noise?:

http://www.youtube.com/watch?v=SvxaR7HSmWc

I agree if it isn't a spun bearing then it probably shouldn't be included
BIGSKYWRX is offline   Reply With Quote
Old 04-05-2009, 04:26 PM   #123
AshJWilliams
Scooby Newbie
 
Member#: 189781
Join Date: Sep 2008
Location: OH
Vehicle:
2010 Tacoma
Black

Default

Quote:
Originally Posted by Tea cups View Post
The list should be (and has been) limited to the specific rod knocking symptom and subsequent failure. We don't want to lump in failures due to other causes and it sounds like his failure was due to an oil leak at one of the turbo supply lines which caused oil starvation in the motor.
I disagree...this is just another 09 WRX exhibiting engine failure and it should be documented. Besides the guy indicated multiple times in his post that a sound is what indicated to him that he had a problem...Change Engine Sound? Even if there was an oil leak what do you think ultimately happened? Poor lubrication conditions resulting in...spun rod bearing...? Sounds like the same problem to me.

Tom check out BIGSKY's post to see if that sound is familiar. Also maybe you could elaborate a little more on the information contained on your service reports. I guess I'd be more interested in the recent total engine/turbo failure (although I take it your vehicle is currently in the shop so maybe this will have to wait).
AshJWilliams is offline   Reply With Quote
Old 04-06-2009, 12:58 PM   #124
snoxracer183
Scooby Newbie
 
Member#: 206640
Join Date: Mar 2009
Chapter/Region: MWSOC
Location: Wausau, WI
Vehicle:
2011 WRX
WRB

Default

2009 WRX 5-Door Premium

VIN: 804425
Mileage: 1150
Build: 8/2008

Knocking noise just like the videos
snoxracer183 is offline   Reply With Quote
Old 04-06-2009, 01:15 PM   #125
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

list updated - added another failure (snoxracer183).

42 total failures and an additional 10 "unconfirmed" failures for a total of 52.
Tea cups is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Engine Failure Poll AshJWilliams Warranty Issues & SOA Problems 201 07-12-2014 07:54 PM
2009 with an 08/08 build date? CO_Turbo Newbies & FAQs 8 05-19-2009 07:39 AM
2008 Wrx Engine Failure deunan General Community 101 03-29-2008 09:47 AM
2008 Wrx Engine Failure deunan Service & Maintenance 1 03-23-2008 10:18 PM
2008 wrx engine failure deunan Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 1 03-23-2008 10:09 PM


All times are GMT -4. The time now is 08:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.