Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-25-2009, 10:51 PM   #176
Digitalfiend
Scooby Specialist
 
Member#: 54823
Join Date: Feb 2004
Chapter/Region: E. Canada
Location: Whitby, Ontario
Vehicle:
2008 STI
DGM

Default

I doubt it is related but my wife's car was on the original ROM and not the new one that Subaru released to fix the hanging RPMs after clutching in. Ironically enough I was going to take it in to have it flashed but now I'll be taking it in for a new engine. I have the utmost confidence that SCI will take care of this. Seriously - with this many failures and with us having bought 3 top-end Subarus in 4 years, I'd hope they'd take care of us.

I just feel really bad for my wife. This is her first unshared higher-end car. She never truly felt like my '05 STi was shared and her Civic was just a daily driver. This was supposed to be her fun car and she was having a blast with it. Unfortunately, now she'll have uncertainty everytime she gives it gas - even though I'm sure the new engine will be fine.
* Registered users of the site do not see these ads.
Digitalfiend is offline   Reply With Quote
Old 04-26-2009, 04:50 PM   #177
SpdDemon69
Scooby Newbie
 
Member#: 203400
Join Date: Feb 2009
Location: MD
Vehicle:
2007 Nissan 350z
Blue

Default

Well i dont know if u can add me to the list, and this is weird and unusual, but when i was test driving one a loud knocking noise started after i pulled to 4.5k rpms from a right turn. the salesman acted to be oblivious to what was going on, but i could sense that he was aware of the engine meltdowns.i walked back to the dealership hopped in my Z and drove off. They keep calling me back to come in but i donno if i can jump into a wrx now...especially if theyre gonna change it again in a year.

anyways the build date was late 2008 and it had 153 miles when i started the drive, and 158 when it happened.
SpdDemon69 is offline   Reply With Quote
Old 04-26-2009, 11:42 PM   #178
irish44j
Scooby Specialist
 
Member#: 191290
Join Date: Oct 2008
Chapter/Region: MAIC
Location: Burke, VA
Vehicle:
09 OPB SM WRXsedan
85 BMW E30 M2 Rallycrossr

Default

^^ what dealer? you should go back and say you want to look at the car again, and grab the VIN or build date if you can.

More likely though, if you go back they'll tell you "oh, we sold it" or some other reason that you can't see it again...
irish44j is offline   Reply With Quote
Old 04-27-2009, 12:11 AM   #179
docboy
Scooby Newbie
 
Member#: 208121
Join Date: Apr 2009
Location: Seattle, WA
Default

Quote:
Originally Posted by SpdDemon69 View Post
Well i dont know if u can add me to the list, and this is weird and unusual, but when i was test driving one a loud knocking noise started after i pulled to 4.5k rpms from a right turn. the salesman acted to be oblivious to what was going on, but i could sense that he was aware of the engine meltdowns.i walked back to the dealership hopped in my Z and drove off. They keep calling me back to come in but i donno if i can jump into a wrx now...especially if theyre gonna change it again in a year.

anyways the build date was late 2008 and it had 153 miles when i started the drive, and 158 when it happened.
What is "late 2008?"
docboy is offline   Reply With Quote
Old 04-27-2009, 07:39 AM   #180
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Only if you can verify, for sure, that the car had the engine replaced, would it be added to the list.
Tea cups is offline   Reply With Quote
Old 04-27-2009, 08:07 AM   #181
HelperMonkey
Scooby Newbie
 
Member#: 126407
Join Date: Sep 2006
Location: Lacey, WA
Vehicle:
2009 WRX Prem Hatch
WR Blue

Default

Quote:
Originally Posted by SpdDemon69 View Post
You guys wont believe this, but i was at subaru yesturday, asked to start up a silver wrx wagon. it had 532 miles and it made a loud clicking noise. i asked him how it had 500 miles and was still new he told me that the manager drove it for a week. he told me the noise couldn't possibly be the engine because subaru makes the most reliable cars out there blah blah blah. i called bs on that and revved it and he yells "if u think it was broken why would u do that" i said "if u think its fine then why cant i"

when i got home i pulled up the vid on youtube and its 100% the same.

all i can say is wtf.....
Quote:
Originally Posted by SpdDemon69 View Post
Well i dont know if u can add me to the list, and this is weird and unusual, but when i was test driving one a loud knocking noise started after i pulled to 4.5k rpms from a right turn. the salesman acted to be oblivious to what was going on, but i could sense that he was aware of the engine meltdowns.i walked back to the dealership hopped in my Z and drove off. They keep calling me back to come in but i donno if i can jump into a wrx now...especially if theyre gonna change it again in a year.

anyways the build date was late 2008 and it had 153 miles when i started the drive, and 158 when it happened.

So this happened to you twice? I call BS.
HelperMonkey is offline   Reply With Quote
Old 04-27-2009, 09:44 AM   #182
BIGSKYWRX
Scooby Guru
 
Member#: 7958
Join Date: Jul 2001
Location: Plains of Eastern Montana
Vehicle:
09 GH B+

Default

hmmmmm first one dated 2/22, the latest 4/26- either he's the unluckiest SOB around or I'd have to agree w/ this ^ assessment
BIGSKYWRX is offline   Reply With Quote
Old 04-27-2009, 10:43 AM   #183
Digitalfiend
Scooby Specialist
 
Member#: 54823
Join Date: Feb 2004
Chapter/Region: E. Canada
Location: Whitby, Ontario
Vehicle:
2008 STI
DGM

Default

UPDATE:

I took the car to the dealership this morning with my wife. I've got a pretty good relationship with the dealership and the service manager in general but the impression I got was that Subaru Canada knows about this issue. There was no argument or need to convince anyone. They are pulling the engine from the car today and the SM expects the new long block to arrive tomorrow sometime. He is optimistic that they will have the car back to us by Wednesday/Thursday. That seems a bit ambitious to me but since it is just dropping in an engine, it might not take as long.

I have a specific tech that I always request for my car and he'll be doing the engine pull and replacement, so that makes me feel better too. I've requested that they check the turbo as well.

I'll be talking to the SM later today to get a feel for what he thinks but unless anything unforeseen comes up, it looks like the car is getting a new long block. So far, I'm happy and couldn't really ask for much better service than that.
Digitalfiend is offline   Reply With Quote
Old 04-27-2009, 11:26 AM   #184
tekfoc
Scooby Specialist
 
Member#: 21392
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: NEW YORK CITY
Vehicle:
2014 CLA 45 AMG MB
WHITE /07 STI IS SOLD

Default

Quote:
Originally Posted by Digitalfiend View Post
UPDATE:

I took the car to the dealership this morning with my wife. I've got a pretty good relationship with the dealership and the service manager in general but the impression I got was that Subaru Canada knows about this issue. There was no argument or need to convince anyone. They are pulling the engine from the car today and the SM expects the new long block to arrive tomorrow sometime. He is optimistic that they will have the car back to us by Wednesday/Thursday. That seems a bit ambitious to me but since it is just dropping in an engine, it might not take as long.

I have a specific tech that I always request for my car and he'll be doing the engine pull and replacement, so that makes me feel better too. I've requested that they check the turbo as well.

I'll be talking to the SM later today to get a feel for what he thinks but unless anything unforeseen comes up, it looks like the car is getting a new long block. So far, I'm happy and couldn't really ask for much better service than that.
It's fantastic that there allowing your favorite tech to do the work, this in it self is 100% assuring that the work is meticulously done correct .
tekfoc is offline   Reply With Quote
Old 04-27-2009, 11:30 AM   #185
GravityDaemon
Scooby Newbie
 
Member#: 209152
Join Date: Apr 2009
Chapter/Region: NESIC
Location: Boston
Vehicle:
2009 WRX 5-dr
Silver

Default

Quote:
Originally Posted by rex.rated View Post
tea cups, you might want to add this to the list also? - unconfirmed?
Sorry about that - it's definitely the problem we're all talking about. You can confirm it.
GravityDaemon is offline   Reply With Quote
Old 04-27-2009, 07:34 PM   #186
gcs5656
Scooby Newbie
 
Member#: 111923
Join Date: Apr 2006
Chapter/Region: RMIC
Location: Colorado
Vehicle:
2012 WRX
Silver

Default Another 09 WRX engine problem

Vin 500060

Build date 7/08

Mileage 4540
gcs5656 is offline   Reply With Quote
Old 04-28-2009, 04:40 PM   #187
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added 2 failures (gcs5656 and Python96).
Tea cups is offline   Reply With Quote
Old 04-28-2009, 10:22 PM   #188
NismoSkylineGTR
Scooby Specialist
 
Member#: 94622
Join Date: Aug 2005
Default

My engine just got a knocking sound today i was like WTF~~ excuse my language

the car is at the dealer now.........I know why my car has lost power and dealer does't want to do anything.

i guess its been knocking for a long time so the sensor just cut off my timing
NismoSkylineGTR is offline   Reply With Quote
Old 04-29-2009, 08:04 AM   #189
HelperMonkey
Scooby Newbie
 
Member#: 126407
Join Date: Sep 2006
Location: Lacey, WA
Vehicle:
2009 WRX Prem Hatch
WR Blue

Default

Quote:
Originally Posted by NismoSkylineGTR View Post
My engine just got a knocking sound today i was like WTF~~ excuse my language

the car is at the dealer now.........I know why my car has lost power and dealer does't want to do anything.

i guess its been knocking for a long time so the sensor just cut off my timing
NismoSkylineGTR, I am sorry to hear about your wrx. Please post your VIN#, build date, and miles at failure or PM Tea cups with the information.
HelperMonkey is offline   Reply With Quote
Old 04-29-2009, 08:07 AM   #190
HelperMonkey
Scooby Newbie
 
Member#: 126407
Join Date: Sep 2006
Location: Lacey, WA
Vehicle:
2009 WRX Prem Hatch
WR Blue

Default

Quote:
Originally Posted by MackeyMack View Post
I just had my car towed to the dealer last night. The engine was making a loud knocking noise. I will have the dealer check it out and confirm later, but it sounded just like the youtube video. The only solace I have is that it is a lease. I will drive it for 3 more years, turn it in, and cross Subaru off the list of choices for my next car.
VIN: 800469
Build Date: 07/08
Mileage: 4975
Tea cups, please add MackeyMack to the list.
HelperMonkey is offline   Reply With Quote
Old 04-29-2009, 03:15 PM   #191
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added dates when failures were first reported on Nasioc.

Removed the following people from the list due to having engine and/or ECU related mods at the time of failure (based on their posts):
ScoobySon (502XXX, 08/08 build date, 7500 miles)
jsham109 ("unconfirmed" 5000 miles)
Peppe316 (800XXX, 07/08 build date, 12xx miles)
jaysuss (804XXX, 1400 miles)

Waiting on MackeyMack and NismoSkylineGTR to confirm engine replacement before adding to list.
Tea cups is offline   Reply With Quote
Old 04-30-2009, 12:54 AM   #192
NismoSkylineGTR
Scooby Specialist
 
Member#: 94622
Join Date: Aug 2005
Default

Quote:
Originally Posted by HelperMonkey View Post
NismoSkylineGTR, I am sorry to hear about your wrx. Please post your VIN#, build date, and miles at failure or PM Tea cups with the information.
i think build date was 08/08 i can't confirm this but form my memory this seems right

Vin is 8051XX ___I guess i'll leave out the last 2 digits (EDIT)

dealer hasn't confim anything back yet but the knocking is aroudn 3k rpm which is what everyone reported

the car have 5210 miles

when the car was around 500 miles i noticed a small tick tick sound but it went away i broght the car to the dealer they said everthing is in operating rang. Since i know hte car is getting slower and slower no low end power at all. Yesterday finally the Knock Knock came~~

and i heard when the engine knocks you dont really hear it but the knock sensor will hold back your timing and you willl loose power so the rest of ya'll out there if your car feels slower and lost low end tq have your dealer check it out

Last edited by NismoSkylineGTR; 04-30-2009 at 03:05 AM.
NismoSkylineGTR is offline   Reply With Quote
Old 04-30-2009, 08:33 AM   #193
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

The knocking noise related to this issue is not due to detonation. The only symptoms that have been reported related to this failure is the knocking noise that appears suddenly and gets progressively worse before catastrophic failure. No other symptoms are apparent at any time before this occurs.

Let us know if your engine gets replaced and what the diagnosis is.
Tea cups is offline   Reply With Quote
Old 04-30-2009, 10:48 AM   #194
GravityDaemon
Scooby Newbie
 
Member#: 209152
Join Date: Apr 2009
Chapter/Region: NESIC
Location: Boston
Vehicle:
2009 WRX 5-dr
Silver

Default

Quote:
Originally Posted by NismoSkylineGTR View Post
and i heard when the engine knocks you dont really hear it but the knock sensor will hold back your timing and you willl loose power so the rest of ya'll out there if your car feels slower and lost low end tq have your dealer check it out
Oh you'll hear it, it's a loud clang coming from under the hood. It's unmistakeable.
GravityDaemon is offline   Reply With Quote
Old 04-30-2009, 12:08 PM   #195
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

updated - added another failure (MackeyMack).

Also added a build date counter.
Tea cups is offline   Reply With Quote
Old 04-30-2009, 02:50 PM   #196
NismoSkylineGTR
Scooby Specialist
 
Member#: 94622
Join Date: Aug 2005
Default

Quote:
Originally Posted by GravityDaemon View Post
Oh you'll hear it, it's a loud clang coming from under the hood. It's unmistakeable.
i am talking about the symptoms
cuz i heard a tick tick sound when the engine was still in 3 digits but it went away and i began to notice the car loosing power in low end

i am not going to accept an engine swap at this time
the car has given me other problems as well and subaru have everthing documented
I like the car so i'm going to ask for a replacement car wish me luck~~

and looks like my car is the only 805 on the list
NismoSkylineGTR is offline   Reply With Quote
Old 04-30-2009, 10:51 PM   #197
Digitalfiend
Scooby Specialist
 
Member#: 54823
Join Date: Feb 2004
Chapter/Region: E. Canada
Location: Whitby, Ontario
Vehicle:
2008 STI
DGM

Default

Got my wife's car back yesterday but one of the coolant hoses was loose and I couldn't find it so I took it back and picked it up today. Runs great and feels smoother than the old engine, though it's probably just in my mind. Hopefully this one lasts.

Great service from Subaru Canada though. Dealership had the engine out the same day I brought my wife's car in and it took them two days to receive and install the new engine. If it wasn't for that hose, we'd have had the car back in 3 days total.

Edit:

By the way, thanks again for maintaining this list Tea Cups. If it wasn't for this list, this experience would probably have been a lot more stressful. At least I was aware of the issue and prepared. Subaru seems to know about the issue too. There wasn't one question about the engine. The dealership had to send it back untouched.
Digitalfiend is offline   Reply With Quote
Old 05-02-2009, 10:23 AM   #198
rex.rated
Scooby Newbie
 
Member#: 206428
Join Date: Mar 2009
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2009 WRX Premium 4dr
Lightning Red

Default

tea cups - i like the new layout for the list. keep up the good work.
rex.rated is offline   Reply With Quote
Old 05-02-2009, 10:44 AM   #199
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

no problem.

Hey guys, if you've had an engine failure you should really fill out the NHTSA complaint form here:
http://www-odi.nhtsa.dot.gov/ivoq/index.cfm

The government has the power to force a manufacturer to perform a recall. At the very least, its possible they might open up a defect investigation and we might get some at least some answers.

So far, there's one 1 failure reported the 09 WRX.
Tea cups is offline   Reply With Quote
Old 05-05-2009, 05:23 PM   #200
TunaRider
Scooby Newbie
 
Member#: 200713
Join Date: Jan 2009
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2009 WRX
Dark Gray Metallic

Default

Mine just got confirmed today. Metal shavings from the bearings were found in the oil.

Vin: G8020xx
Mileage: 3978
Build Date: 07/08
TunaRider is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2009 WRX Engine Failure Poll AshJWilliams Warranty Issues & SOA Problems 200 04-09-2013 02:44 PM
2009 with an 08/08 build date? CO_Turbo Newbies & FAQs 8 05-19-2009 07:39 AM
2008 Wrx Engine Failure deunan General Community 101 03-29-2008 09:47 AM
2008 Wrx Engine Failure deunan Service & Maintenance 1 03-23-2008 10:18 PM
2008 wrx engine failure deunan Factory 2.5L Turbo Powertrain 1 03-23-2008 10:09 PM


All times are GMT -4. The time now is 07:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.