Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-11-2009, 05:30 AM   #1
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default pioneer avh-p4000 install in 06sti

ill be installing this and for the life of me NO ONE can tell me if ill need anything extra for the install.so if someone knows if theres extra parts needed (factory subwoofer,antenna hookup ect) please advise me.
* Registered users of the site do not see these ads.
nation1979 is offline   Reply With Quote
Old 02-11-2009, 06:12 AM   #2
Jetta1120
Scooby Newbie
 
Member#: 65676
Join Date: Jul 2004
Chapter/Region: NESIC
Location: Aiken, SC
Vehicle:
2003 Subaru WRX
White

Default

Quote:
Originally Posted by nation1979 View Post
ill be installing this and for the life of me NO ONE can tell me if ill need anything extra for the install.so if someone knows if theres extra parts needed (factory subwoofer,antenna hookup ect) please advise me.
No you will not need anything extra to install this other than the harness.
Juust take out the factory unit and the Pioneer will bolt right up.
Jetta1120 is offline   Reply With Quote
Old 02-11-2009, 07:22 AM   #3
Uncanny
Scooby Specialist
 
Member#: 133012
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: Syracuse, NY
Vehicle:
2011 WRX
Obsidian Black Pearl

Default

If you have the factory sub harness, you may have a couple of wires to splice into, i forgot where the cutoff is for years.

You will need an adapter harness, PN Metra 70-8901
You may also want a 12v relay to bypass the screen if you so choose, otherwise you will need to hook up the parking brake wire. (Avic411.com for details)
Uncanny is offline   Reply With Quote
Old 02-11-2009, 07:42 AM   #4
06AZREX
Scooby Specialist
 
Member#: 132244
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Everett
Vehicle:
2006 OBP WRX
2006 BMW 325i

Default

on the p4000 all you need is a 3pole switch for the video
06AZREX is offline   Reply With Quote
Old 02-11-2009, 07:46 AM   #5
Uncanny
Scooby Specialist
 
Member#: 133012
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: Syracuse, NY
Vehicle:
2011 WRX
Obsidian Black Pearl

Default

or a relay for those that dont want to have to flick a switch
Uncanny is offline   Reply With Quote
Old 02-14-2009, 03:57 PM   #6
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

relay/switch-were would i find these other than ebay?
im guessing i would find the harness at the same place
nation1979 is offline   Reply With Quote
Old 02-15-2009, 12:39 PM   #7
Dungmaggot
Scooby Newbie
 
Member#: 203055
Join Date: Feb 2009
Default

Just installed this same unit in my 05 and it fits perfectly, looks great and sounds awesome. Its a complex little bugger to use but it has so damn many feature that was to be expected. Im getting the hang of it tho. I didn't need anything extra except a wiring harness and you dont even NEED one of those if you're handy with wiring. I'm not so I shelled out the 20 bucks and bought the harnes and wired it right up. Start to finish was 45 minutes. Easiest install ever.
Dungmaggot is offline   Reply With Quote
Old 02-15-2009, 03:54 PM   #8
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

do you have a pic of the install
nation1979 is offline   Reply With Quote
Old 02-18-2009, 06:22 PM   #9
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

im planning on installing tonite.anyone have more info on the relay or switch for the ebrake.im not finding the info i need
nation1979 is offline   Reply With Quote
Old 02-18-2009, 06:37 PM   #10
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

i also read you can turb off the parkin brake sensor in the sub menu of the unit but you need a code?is this true
nation1979 is offline   Reply With Quote
Old 02-18-2009, 07:44 PM   #11
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

ok i got the stock HU out.does anyone know what the little plug with 2 wires is for?i think it for the factory sub.how would i wire that in?
nation1979 is offline   Reply With Quote
Old 02-19-2009, 09:33 PM   #12
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

ok tried to install today and ran into problems.
1)the resistor fuse inthe red wire was bad
2)the antenna wire is to small for the hole in the HU.the stock HU has a smaller diameter hole,the pioneer may need a adapter,anyone know which one
3)still no idea on how to wire up a relay switch for the dvd portion.
help please
nation1979 is offline   Reply With Quote
Old 02-19-2009, 09:45 PM   #13
jakoi
Scooby Newbie
 
Member#: 121415
Join Date: Jul 2006
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
1997 Impreza Outback
Red

Default

the fuse is bad? replace it.
the antenna might use the newer subaru antenna, which means you'll need to get an antenna adapter from OE to Aftermarket style antenna plug.
The relay might be a bit hard for you to do. I would suggest you hook up the parking brake wire to a switch, and then hook it up to the ground wire (black) on the radio harness.

Good thing you chose Pioneer... doesn't have that stupid brake sequence like other ones I've installed.
jakoi is offline   Reply With Quote
Old 02-20-2009, 02:41 AM   #14
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

the fuse is actually a resistor,i dont get it

the switch.now if you could show me a basic diagram of how to to he parking brake for the dvd
nation1979 is offline   Reply With Quote
Old 02-21-2009, 03:45 AM   #15
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

i have a question about the wiring of the deck.onthe harness for the HU theres 2 blk wires that come together and have a clip sorta speak.i just cut that off and wired it up to the black wire on the adapter harness.was this correct?or should i have done something different
nation1979 is offline   Reply With Quote
Old 02-21-2009, 10:14 PM   #16
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

anyone?
crutchfield is no help.pioneer is no help and best buy stereo installers are complete D-bags

and i cant find the adapter for the antenna.or whats the proper way to wire the ground for this HU
nation1979 is offline   Reply With Quote
Old 02-21-2009, 10:17 PM   #17
claycron
Scooby Specialist
 
Member#: 181941
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Fairmont WV
Vehicle:
2004 Forester XT
AW

Default

Quote:
Originally Posted by nation1979 View Post
i have a question about the wiring of the deck.onthe harness for the HU theres 2 blk wires that come together and have a clip sorta speak.i just cut that off and wired it up to the black wire on the adapter harness.was this correct?or should i have done something different
Thats how I wired mine and it worked fine
claycron is offline   Reply With Quote
Old 02-21-2009, 10:20 PM   #18
ozzy370
Scooby Specialist
 
Member#: 162469
Join Date: Oct 2007
Chapter/Region: RMIC
Location: Suba Performance, Denver, CO
Vehicle:
2003 WRX wagon
special sauce

Default

Quote:
Originally Posted by nation1979 View Post
anyone?
crutchfield is no help.pioneer is no help and best buy stereo installers are complete D-bags

and i cant find the adapter for the antenna.or whats the proper way to wire the ground for this HU
Sounds like you have no clue what you are doing... best buy will probably be your best bet for you to pay them to do it.
not to be a dick but within 5 minutes of acually looking for your "problems" I found most if not all answers


http://forums.nasioc.com/forums/showthread.php?t=749402
http://forums.nasioc.com/forums/show....php?t=1532755

Last edited by ozzy370; 02-21-2009 at 10:27 PM.
ozzy370 is offline   Reply With Quote
Old 02-22-2009, 01:19 AM   #19
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

have you actually seen the harness pioneer uses?if you had you would know why its such a pain.i have installed more stereos than i care to admit and i have NEVER seen 2 black wires come out of one harness,connect and end with a clip.and since this is a dvd unit i wasnt sure if pioneer had some special reason for this.the pioneer directions say to attach to a chasis ground.should i do that or wire it into the ground on the P&P harness?because if i cut off the provided end it voids the warranty.i know, i called and asked
the antenna is to small.the subaru antenna doesnt make the right contact inside the HU.now i can look inside and see plain as day that the very end is just the wrong diameter.i figured a simple slip on adapter that was a little bigger would be all i needed,i just cant find it.i called metra and had no luck.went to radio shack,no luck.and i did go to best buy and they employees are complete tools.so if someone knows what i need to connect the antenna please let me know.
and for the dvd/brake issue.all i need is a simple wiring diagram

Last edited by nation1979; 02-22-2009 at 01:31 AM.
nation1979 is offline   Reply With Quote
Old 02-22-2009, 01:31 AM   #20
claycron
Scooby Specialist
 
Member#: 181941
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Fairmont WV
Vehicle:
2004 Forester XT
AW

Default

Cut off the plastic clip , splice the 2 coming from the CD player to the one in the vehicles stock wiring harness. Also make sure you do the video bypass so you can watch it while your cruising
claycron is offline   Reply With Quote
Old 02-22-2009, 01:34 AM   #21
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

Quote:
Originally Posted by claycron View Post
Cut off the plastic clip , splice the 2 coming from the CD player to the one in the vehicles stock wiring harness. Also make sure you do the video bypass so you can watch it while your cruising
im not sure how to do the bypass.i have read alot on this forum and others(ford,honda tech ect)but i have yet to see a simple wiring diagram.it cant be that hard to do,im just not sure were to start.and yes im pretty damn good at wiring.i have a ton of TT harness's for friends,its just a matter of having the right parts
nation1979 is offline   Reply With Quote
Old 02-22-2009, 01:48 AM   #22
claycron
Scooby Specialist
 
Member#: 181941
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Fairmont WV
Vehicle:
2004 Forester XT
AW

Default

You need a 4 prong relay from a parts store usually found in the automotive lighting section. You ground 2 prongs to your already grounded wiring harness run one prong to your remote wire from your cd player and the other from the cd players e-brake wire. The tabs are numbered and there is a thread about it that explains the exact numbers and what to do with each one. Just search for it
claycron is offline   Reply With Quote
Old 02-22-2009, 01:54 AM   #23
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

yah im a jackass.once i put my hands on the relay it made sense.
one thing though,you say to ground the relay using the harnees ground?would it matter if i used a chasis ground.its pretty tight behind there with the other work related items and i wouldnt want to conflict the ground and short something out

and as for the antenna i guess i can just get a random adapter and hope it makes it longer and the end is bigger
nation1979 is offline   Reply With Quote
Old 02-22-2009, 09:20 AM   #24
claycron
Scooby Specialist
 
Member#: 181941
Join Date: Jun 2008
Chapter/Region: MAIC
Location: Fairmont WV
Vehicle:
2004 Forester XT
AW

Default

A chassis ground will be fine
claycron is offline   Reply With Quote
Old 02-25-2009, 03:30 AM   #25
nation1979
*** Banned ***
 
Member#: 192914
Join Date: Oct 2008
Chapter/Region: BAIC
Location: california
Vehicle:
06 sti
importimageracing is #1

Default

ok relay is wired,deck is set to go in.one last issue.i still cant figure out the antenna issue.the factory antenna end is the correct style but the very tip is to small.i was thinking about getting a extension with the hope that the end would be bigger,its not.what am i missing?
nation1979 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: (AZ) Pioneer AVH P4000 DVD in MINT Condition! BlackSun Interior/Dressup/Audio & Security 11 01-29-2011 08:42 PM
FS: (AZ) Pioneer AVH P4000 DVD in MINT Condition! BlackSun SWIC Private Classifieds 0 10-23-2009 01:02 AM
Pioneer AVH-P4000 DVD, great shape, $250 shipped Rock_Strongo Interior/Dressup/Audio & Security 5 03-01-2009 12:11 AM
FS:AZ-Pioneer AVH-P4000 and other stuff 06AZREX Interior/Dressup/Audio & Security 7 12-31-2008 08:24 AM
Pioneer AVH-P4000 Receiver Questions to you Audio Gurus Works Car Audio, Video & Security 4 09-28-2008 11:15 PM


All times are GMT -4. The time now is 02:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.