Welcome to the North American Subaru Impreza Owners Club Tuesday October 6, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Thread Tools Display Modes
Old 04-07-2002, 06:04 PM   #1
Santo Domingo 2.5 RS
Scooby Specialist
Member#: 5354
Join Date: Apr 2001
Location: Santo Domingo. R.D
Silverthorn Metallic

Default Problem when filling up gas!!

I dont know whats the problem, but my car whenever i try to fill it up with gas, i can`t do it fast because the trigger on the fuel pump always comes up and stops pumping, so you cant fill it up fast, and i have to fill it up really slowly.
* Registered users of the site do not see these ads.
Santo Domingo 2.5 RS is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-07-2002, 07:44 PM   #2
Scooby Guru
Member#: 847
Join Date: Feb 2000
Chapter/Region: South East
Location: Greensboro, Georgia
'06 Titan Crew Cab
'08 Forester LL Bean


I have had this happen too. Whenever you fill up your tank try only putting the nozzle part half way in, instead of having it flush against the door opening. I think that the sensor that is on the pumps nozzle gets false readings for some reason when you have it all the way in, perhaps its getting splashed? Anyways try what I said, that should solve the problem.
Tkacik is offline   Reply With Quote
Old 04-07-2002, 08:05 PM   #3
Scooby Specialist
Member#: 7119
Join Date: Jun 2001
Chapter/Region: MAIC
Location: chesapeake va usa
2000 impreza rs
blue ridge pearl


ya i have had the same problem
LA is offline   Reply With Quote
Old 04-07-2002, 08:35 PM   #4
Scooby Specialist
Member#: 6178
Join Date: Apr 2001
Chapter/Region: MAIC
Location: Singletracks
98 GM67 + 03 SG6
2 whls > 4 whls


This happened to me at a random Texaco station. I was getting really ticked. So I just pulled the nozzle out 1/4 to 1/2 inch or so, and tried it again, and it worked fine. Try that and see what happens.

This doesn't happen to me often, so I'm guessing it is just that pump. It didn't happen today when I filled up, and I wasn't pressing the nozzle all the way in. Just an idea.

AJ711 is offline   Reply With Quote
Old 04-07-2002, 10:00 PM   #5
Scooby Newbie
Member#: 15174
Join Date: Feb 2002
Location: I am silent_rob!
02 Impreza 2.5 RS


Yeah like everyone else said do that. That happen to me a few times. Its like it goes to deep sometimes. It works for me to raise it up a bit.
amorenite95 is offline   Reply With Quote
Old 04-07-2002, 11:19 PM   #6
Aprilia Jon
Scooby Newbie
Member#: 13394
Join Date: Dec 2001
Location: Austin TX Y'all
2001 GC8 Coupe


Originally posted by amorenite95
That happen to me a few times. Its like it goes to deep sometimes.
Yeah, I get that problem all the time
Aprilia Jon is offline   Reply With Quote
Old 04-08-2002, 10:44 AM   #7
Scooby Newbie
Member#: 5691
Join Date: Apr 2001
Chapter/Region: BAIC
Location: Redwood City, CA
2001 2.5 RS


I had this problem with my car from day one. I had it back to the dealer something like 4 times. I was without my car cumulatively for 6 weeks. Before they finally fixed it, they had replaced the entire gas tank, the fuel filler tube, a bunch of smog equipment. It turns out that it had a defective "check valve" which was replaced with another defective "check valve".

Take it to a dealer and tell them to try it. The positive side is that for the dealer to test it they have to fill your car up...

Anyway, the dealership I dealt with, Carlsen in Redwood City CA was very helpful and understanding. Now every time I show up the service writer says "Oh, no, please tell me the gas tank still works."
Suba_Roo is offline   Reply With Quote
Old 04-08-2002, 11:50 AM   #8
NASIOC Supporter
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
The 93 W/EJ20K
Series 10 FRS


its a common subaru proublem

2 of my subaurs have done it

if you have soft enought suspension rock the car as you fuel it

the air outlet line is blocked or too small
Jaxx is offline   Reply With Quote
Old 04-09-2002, 01:12 PM   #9
Subie FI
Scooby Newbie
Member#: 17253
Join Date: Apr 2002
Chapter/Region: MWSOC
Location: The Mitten State
2014 BMW 328i Wagon
Alpine White


Suba_Roo nailed it. I also had this problem the first time I filled up the tank of my '02 OBS. First, I thought it was the gas pump. When it happened again I called my dealer (Ann Arbor Subaru). They said it could be a plug in the pressure bleed line or a faulty valve in the tank. First, they checked the lines and found no problem so they ordered me a new gas tank. Replacing the tank and check valve did the trick. Warranty replacement.
Subie FI is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem when hooking up battery globalrex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 03-05-2008 08:14 PM
Car Idling Problem When i fill up Gas wrxphantom Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 14 02-03-2007 07:48 PM
Engine mount problem when jacking up engine Eaglesfan2422 Service & Maintenance 3 09-03-2006 06:11 PM
having problems filling up gas tank Benjamin Tang Legacy Forum 12 01-01-2003 11:06 PM
White 00-01 RS, Black painted 6spoke stock rims, Filling up gas on Teaneck Rd Tensen Tri-State Area Forum 0 10-03-2001 12:41 AM

All times are GMT -4. The time now is 04:21 AM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.