Welcome to the North American Subaru Impreza Owners Club Monday September 1, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-10-2014, 05:24 PM   #1
InFINite989
Scooby Newbie
 
Member#: 381106
Join Date: Feb 2014
Location: Houston
Vehicle:
2014 SWP WRX Hatch

Default PSA - Chevron Premium Gas in Houston

Haven't seen anything posted in this section about this yet, so I thought I'd make a thread.

Seems Houston area Chevron gas stations had an issue with mid and high grade gasoline being inferior quality and suspended sale of said grades for some time.

Also saw a Subaru owner claiming it ruined his engine in this article

Quote:
The signs were still on some gas stations on Wednesday told telling the stations cannot sell premium or mid-grade fuel, and while Chevron has not said what's wrong with the gas, one driver tells us it ruined his cars engine.

This is not Jamal Caliste's Subaru, his car is in the shop with a ruined engine.

"He said there was something in the gas that totaled my engine," said Caliste.

The Houston driver says he put Chevron premium gas in his car that was just 6 months old, and the dealership has seen another with the same problem recently. Last week, Chevron stopped selling premium and mid-grade gasoline at all its Houston locations and now Caliste wants an explanation.
Another news report is here

Just wanted to put this out there and also see if anyone else has noticed any mechanical issues.
* Registered users of the site do not see these ads.
InFINite989 is offline   Reply With Quote
Old 07-11-2014, 08:20 AM   #2
TJ
Scooby Guru
 
Member#: 41735
Join Date: Aug 2003
Chapter/Region: TXIC
Location: Look MFer
Vehicle:
I'm on your lawn
do something about it

Default

Probably a turbo trying to run 87 octane.

:smh:
TJ is offline   Reply With Quote
Old 07-11-2014, 07:28 PM   #3
Hot_Neon
Scooby Newbie
 
Member#: 47011
Join Date: Nov 2003
Chapter/Region: TXIC
Location: Houston
Vehicle:
12 STI sedan
Satin White Pearl

Default

I stopped at a Texaco last sunday and their pumps had the mid-grade and premium as "out of order" too.
Hot_Neon is offline   Reply With Quote
Old 07-11-2014, 10:18 PM   #4
shiftpgdn
Scooby Newbie
 
Member#: 193302
Join Date: Nov 2008
Chapter/Region: TXIC
Location: Houston, TX
Vehicle:
2013 WRX
SWP

Default

I fuel up with Chevron exclusively and recently had severe stumbling/misfires but no CEL somehow.
shiftpgdn is offline   Reply With Quote
Old 07-12-2014, 12:07 AM   #5
bluesonicboomae86
Scooby Newbie
 
Member#: 284297
Join Date: May 2011
Chapter/Region: TXIC
Location: Houston' TX
Vehicle:
2011 Impreza STi
WR Blue

Default

Is stripes also part of chevron? I've noticed I've had a weird problem as well.
bluesonicboomae86 is offline   Reply With Quote
Old 07-12-2014, 01:00 AM   #6
lowranger
Scooby Specialist
 
Member#: 124370
Join Date: Aug 2006
Chapter/Region: TXIC
Location: coppell TX. College Station
Vehicle:
03 wrx stg 2.34159
Pro tuned by Cobb Tooning

Default

QT ftw
lowranger is offline   Reply With Quote
Old 07-12-2014, 04:20 AM   #7
TheWhip
Visiting NASIOC Timeout
 
Member#: 384465
Join Date: Mar 2014
Chapter/Region: TXIC
Vehicle:
2013 WRX Hatch
ISM

Default

Watch out and be careful where you get gas. I wonder if any octane boosts would be helpful to the situation for the time being.
TheWhip is offline   Reply With Quote
Old 07-14-2014, 01:14 AM   #8
SGC2CIC
Scooby Specialist
 
Member#: 286908
Join Date: Jun 2011
Chapter/Region: TXIC
Location: Dallas Texas
Vehicle:
2014 EVO X GSR
2000 2.5RS

Default

Ever heard of shell...
SGC2CIC is offline   Reply With Quote
Old 07-14-2014, 04:19 PM   #9
samagon
Scooby Guru
 
Member#: 26859
Join Date: Oct 2002
Chapter/Region: TXIC
Location: undisputed COMBAT! champion
Vehicle:
of TXIC
I also like (oYo)!!!!

Default

all gasoline goes into the pipelines the same, companies put in their additives after it comes out of the pipeline, so all gasoline is the same, just different additives, in the case of Chevron, it's techron, Texaco uses techron as well.

additionally, 93 and 87 are blended at the pump for 91, so it's probably the specific additives they use in the 93 gas.

stay away from both Chevron and Texaco for a while.

I do my best to go with Valero, because Texas company, or Shell if I don't have a Valero around me.

Last edited by samagon; 07-14-2014 at 04:26 PM.
samagon is offline   Reply With Quote
Old 07-14-2014, 11:05 PM   #10
nxttruck2002
Scooby Specialist
 
Member#: 90879
Join Date: Jul 2005
Chapter/Region: TXIC
Location: Houston, Texas
Default

I am a victim of this.

I filled a full tank of Chevron 93 on 6/27 and on 6/28 my car wouldn't start twice while at work and when it did it felt like it was on a couple cylinders with very rough/shaky idle. Eventually she started perfectly and brought it to the dealer who could not replicate the issue. It has ran perfect since. What would you guys recommend for a cleaner or additive I can add to the tank that's not BS?


2014 ZL1 3,000 miles
nxttruck2002 is offline   Reply With Quote
Old 07-15-2014, 02:20 AM   #11
Trae32566
Scooby Newbie
 
Member#: 353990
Join Date: Apr 2013
Chapter/Region: TXIC
Location: Arlington, Texas
Vehicle:
2013 Impreza WRX 4dr
Black

Default

Quote:
Originally Posted by samagon View Post
all gasoline goes into the pipelines the same, companies put in their additives after it comes out of the pipeline, so all gasoline is the same, just different additives, in the case of Chevron, it's techron, Texaco uses techron as well.

additionally, 93 and 87 are blended at the pump for 91, so it's probably the specific additives they use in the 93 gas.

stay away from both Chevron and Texaco for a while.

I do my best to go with Valero, because Texas company, or Shell if I don't have a Valero around me.
This. I also want to add that there is a published list of top tier gas providers which can be found at http://www.toptiergas.com
Trae32566 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 07:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.