Welcome to the North American Subaru Impreza Owners Club Friday November 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Texas Impreza Club
Texas Impreza Club Forum sponsored by Gillman Subaru Houston
and Gillman Subaru San Antonio
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Texas Impreza Club Forum -- TXIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-01-2012, 10:25 AM   #476
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Sending PM
* Registered users of the site do not see these ads.
wrx_02 is offline   Reply With Quote
Old 02-01-2012, 10:35 AM   #477
Spider Pig
Scooby Guru
 
Member#: 82323
Join Date: Mar 2005
Chapter/Region: TXIC
Location: Aesir Tactical & Armory
Vehicle:
I'm a lead farmer,
mother****er!

Default

So I've run into an interesting problem with the SV. After changing my oil, the bike is absolutely impossible to shift into neutral while sitting at a dead stop. Also, the clutch is ridiculously sensitive now. If I let it out just a hair, it tries to jump on me and will stall every now and then. And even with the clutch engaged, the bike still tries to cheap forward as if I was letting it out, so I have to sit at a stoplight with the brake engaged so the bike doesn't attempt to take off on me.

I've adjusted the clutch, but was wondering if maybe I overfilled the crank with oil. Before the oil change, this was not an issue and I was able to slip the bike into neutral anytime I was stopped.
Spider Pig is offline   Reply With Quote
Old 02-01-2012, 10:45 AM   #478
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Did you change the type of oil you were using? Was it the correct oil?

Also if you adjusted the clutch cable and it made no difference I would suggest checking the oil level. Are you sure the drained out what you put in?

I only ask cause on my old bike there were 2 drain spots. If you didn't use them both you would over fill. Just like if you didn't empty the oil filter and then added the recommend amount of oil.

As for the neutral, that is usually the sign of a chain that is to tight, but in your case sounds like it might be something else.
wrx_02 is offline   Reply With Quote
Old 02-01-2012, 10:46 AM   #479
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Oh you didn't happen to do anything to change how your cables are run? It is very important to run the cables through the bike one specific way for everything to work properly.
wrx_02 is offline   Reply With Quote
Old 02-01-2012, 01:02 PM   #480
Spider Pig
Scooby Guru
 
Member#: 82323
Join Date: Mar 2005
Chapter/Region: TXIC
Location: Aesir Tactical & Armory
Vehicle:
I'm a lead farmer,
mother****er!

Default

See, that's what is so confusing to me. I didn't adjust any cables and haven't changed anything regarding the chain. I'm using the same 5W40 Amsoil high performance motorcycle oil I've used in the past. I accidentally added a little more than normal, but the amount was negligible and my oil levels are still in between the full and low lines.

It's just strange to me that this would start now, whereas I haven't done anything to the bike differently for over a year. I'm just going to chalk it up to the bike having nearly 38,000 miles and being ridden at least four days a week.
Spider Pig is offline   Reply With Quote
Old 02-01-2012, 01:12 PM   #481
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Without seeing the bike and testing it on my own it would be hard to say.

Has the tension on the pull changed at all? Softer or tighter?

You could always take the clutch cover off. Shouldn't cost you more than a gasket to have a look at it.

Motorcycle clutches are very very easy to change. TQ specs on the spring bolts is what is important.
wrx_02 is offline   Reply With Quote
Old 02-01-2012, 01:19 PM   #482
Spider Pig
Scooby Guru
 
Member#: 82323
Join Date: Mar 2005
Chapter/Region: TXIC
Location: Aesir Tactical & Armory
Vehicle:
I'm a lead farmer,
mother****er!

Default

Yeah, I've done it before. I figured since work canceled my shift tomorrow, I'll just jump into it further then. It's probably something minor, since the neutral thing and the clutch having to be in all the way thing are all that is going on. Tension is the same, so at least my clutch isn't taking **** on me. Because at speed, it still shifts into all gears smooth as butter. It's just at a stop where it's like trying to lift a tank with my big toe.

So my guess is, despite my adjustment, the clutch is still off and I have slightly too much oil in the crank case. Ugh. Sometimes I hate my choices in vehicles.
Spider Pig is offline   Reply With Quote
Old 02-01-2012, 01:48 PM   #483
Groceryboy
Scooby Specialist
 
Member#: 231322
Join Date: Nov 2009
Location: Houston TX
Vehicle:
'11 Sportster
Bobber, 71 Chevelle

Default

My Sportster...



Groceryboy is offline   Reply With Quote
Old 02-01-2012, 01:58 PM   #484
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Not a Sportster fan but that is nice.



Let me know what you find Spider.
wrx_02 is offline   Reply With Quote
Old 02-01-2012, 04:16 PM   #485
Spider Pig
Scooby Guru
 
Member#: 82323
Join Date: Mar 2005
Chapter/Region: TXIC
Location: Aesir Tactical & Armory
Vehicle:
I'm a lead farmer,
mother****er!

Default

Will do. I checked out SVRider.com and found that apparently its a quite high phenomenon among higher mileage K3 SV650s. Apparently the clutch wears a certain way to a point where it no longer wants to shift into neutral at stop while the bike is running.

I guess Suzuki fixed it in 2006 models on.

But I'm still going to get into it tomorrow and see if I can't fix it. Because there are times at long lights where my hand really starts to cramp up on my shorty handles after about five minutes of constant full grip.
Spider Pig is offline   Reply With Quote
Old 02-01-2012, 04:34 PM   #486
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

If you have to get a new clutch check out Barrnett. They are usually cheaper and better.
KBC's suck btw. Good Luck!
wrx_02 is offline   Reply With Quote
Old 02-01-2012, 09:03 PM   #487
Spider Pig
Scooby Guru
 
Member#: 82323
Join Date: Mar 2005
Chapter/Region: TXIC
Location: Aesir Tactical & Armory
Vehicle:
I'm a lead farmer,
mother****er!

Default

I'll check them out. Thanks.
Spider Pig is offline   Reply With Quote
Old 02-01-2012, 09:47 PM   #488
Spider Pig
Scooby Guru
 
Member#: 82323
Join Date: Mar 2005
Chapter/Region: TXIC
Location: Aesir Tactical & Armory
Vehicle:
I'm a lead farmer,
mother****er!

Default

And I fixed it. I figured I'd start pulling things off while dinner was finishing cooking, and as I pulled back the rubber cover over the clutch locknut on the handlebar, I noticed it was screwed way closer than it used to be.

Apparently when I had the dealership install my new tire, they decided to adjust my clutch for me and royally dicked it up. So after twenty minutes of adjusting, no more pulling while the clutch is engaged and I can easily shift in and out of neutral while stopped.

Thank god that was an easy fix, but now I feel pretty damn dumb.
Spider Pig is offline   Reply With Quote
Old 02-02-2012, 10:30 AM   #489
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Hahaha So you did have something else done to it!

I always hate trying to figure something out like that and you leave out the tire change cause it has nothing to do with your Air Conditioner. Always some underlying issue that was unknown.

Not sure where in Texas you are but I bet we have a TSBA chapter by you. I think all chapters have a tire changer. It's worth the 24$ a year member fee to be able to change your own tires, plus the discounts we get. Just a thought......
wrx_02 is offline   Reply With Quote
Old 02-02-2012, 12:07 PM   #490
samagon
Scooby Guru
 
Member#: 26859
Join Date: Oct 2002
Chapter/Region: TXIC
Location: undisputed COMBAT! champion
Vehicle:
of TXIC
I also like (oYo)!!!!

Default

I need to get out in the garage and adjust valves, change oil, and make sure all chains (cam and drive) are still adjusted correctly before it starts getting too hot!
samagon is offline   Reply With Quote
Old 02-02-2012, 12:36 PM   #491
Spider Pig
Scooby Guru
 
Member#: 82323
Join Date: Mar 2005
Chapter/Region: TXIC
Location: Aesir Tactical & Armory
Vehicle:
I'm a lead farmer,
mother****er!

Default

Quote:
Originally Posted by wrx_02 View Post
Hahaha So you did have something else done to it!

I always hate trying to figure something out like that and you leave out the tire change cause it has nothing to do with your Air Conditioner. Always some underlying issue that was unknown.

Not sure where in Texas you are but I bet we have a TSBA chapter by you. I think all chapters have a tire changer. It's worth the 24$ a year member fee to be able to change your own tires, plus the discounts we get. Just a thought......
Yeah I talked to Frank about TSBA when I got the bike. After some of the maintenance costs I've incurred, I'm thinking I should have taken him up on his offer to join.
Spider Pig is offline   Reply With Quote
Old 02-02-2012, 04:00 PM   #492
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Quote:
Originally Posted by Spider Pig View Post
Yeah I talked to Frank about TSBA when I got the bike. After some of the maintenance costs I've incurred, I'm thinking I should have taken him up on his offer to join.

Feel free to come to a meeting. No pressure to join, you can come to several meetings and decide if it is for you or not. I think we get 15% @ Cycle Gear and 10% at Motoliberty. Not to mention all the contacts, track day discounts, and tire changer. We also have a emergency list if you break down anywhere in Texas you can contact another chapter and they can get someone with a trailer to come and get you. Pretty cool! Oh the Tire changer is in North Fort Worth at my house.
wrx_02 is offline   Reply With Quote
Old 02-02-2012, 04:02 PM   #493
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

Oh and we are all about safety, you can't go on club rides without wearing your gear, also the Yearly Dues go towards club parties, dinner giveaways, and things like the tire changer. We all vote on it.
wrx_02 is offline   Reply With Quote
Old 02-02-2012, 04:57 PM   #494
inkdeep
Scooby Newbie
 
Member#: 306744
Join Date: Jan 2012
Chapter/Region: TXIC
Location: Dallas TX
Vehicle:
2011 WRX STI 5 Door
Obsidian Black Pearl

Default Zr-7



Needs lots of work on the jets and carbs - I let it sit too many years without flushing the tank/lines.
inkdeep is offline   Reply With Quote
Old 02-03-2012, 12:31 PM   #495
bcorn
Scooby Newbie
 
Member#: 77482
Join Date: Dec 2004
Chapter/Region: TXIC
Location: San Marcos TX
Vehicle:
2005 Impreza STI
Pikes Peak #968

Default

Here are some of my 2 wheeled rides.



















bcorn is offline   Reply With Quote
Old 02-03-2012, 12:34 PM   #496
bcorn
Scooby Newbie
 
Member#: 77482
Join Date: Dec 2004
Chapter/Region: TXIC
Location: San Marcos TX
Vehicle:
2005 Impreza STI
Pikes Peak #968

Default

A couple more.






This is why I mostly race cars now.


And a time laps of my XR 600 R build.

I don't own all of these. Some are mine some are sponsored rides.
bcorn is offline   Reply With Quote
Old 02-09-2012, 11:13 AM   #497
wrx_02
Scooby Specialist
 
Member#: 188471
Join Date: Sep 2008
Chapter/Region: TXIC
Location: Fort Worth, Texas
Default

I got 2 sets of sport tires should anyone need some.
They have some track days on them, but plenty of center tread. Will be good for general commuting to and from work.

Come by and you can have them I'm in North Fort Worth. Feel free to PM me.
wrx_02 is offline   Reply With Quote
Old 02-10-2012, 12:19 PM   #498
ExchangeGuy
Scooby Guru
 
Member#: 4383
Join Date: Feb 2001
Chapter/Region: TXIC
Location: Dickinson
Vehicle:
2012 Camaro RS
Blsck/gray

Default

One word comes to mind....DAYUM!!!
ExchangeGuy is offline   Reply With Quote
Old 02-10-2012, 04:08 PM   #499
Sharpjeff6
Scooby Newbie
 
Member#: 301579
Join Date: Nov 2011
Location: Dallas, TX
Vehicle:
2003 Wrx
PSM

Default

I got a 2008 ninja zx 14
2003 Harley vrod geared for racing
2005 Honda btw
And a sexy 2003 wrx
Sharpjeff6 is online now   Reply With Quote
Old 02-10-2012, 04:25 PM   #500
Kicnit
Scooby Newbie
 
Member#: 307599
Join Date: Jan 2012
Chapter/Region: NESIC
Location: Seacoast NH
Vehicle:
2008 WRX 5door
SSM

Default

2007 kawasaki Vulcan custom 900
2008 wrx 5door

Cheers,
Kyle
Kicnit is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02/03 Oil leak Who's got one? enTarget South East Region Forum 4 03-20-2005 11:38 PM
GC8 Coupe wings - who's got one in BRP?? swappedGF Mid West Subaru Owners Club Forum -- MWSOC 8 01-06-2005 03:44 PM
i want a impreza...who's got one?! Subecowboy General Forum Archive 17 03-06-2001 09:21 PM
Rallispec Light bar.Who's got one? RallyeX General Forum Archive 10 06-06-2000 10:59 AM


All times are GMT -4. The time now is 09:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.