Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-24-2009, 10:21 AM   #1
shipjumper
Scooby Specialist
 
Member#: 6307
Join Date: May 2001
Chapter/Region: NESIC
Location: defrosted FINALLY, VT
Vehicle:
what I has no car...
am carless

Default strange unrepeatable issue...

I am randomly having a COUGH or a chug from the BAJA lately.


light crusing, then a COUGH, kinda feels like a fuel cut... kinda jarring...

its like the injectors dont fire for a split second... I cannot MAKE it do it, and its totally random.

anyone else have this happen?
* Registered users of the site do not see these ads.
shipjumper is offline   Reply With Quote
Old 02-24-2009, 01:13 PM   #2
deadlydave
Scooby Specialist
 
Member#: 131119
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: Waterford, NY
Vehicle:
1996 Impreza LWRXSTI
91 BMW 318is

Default

when was the last time you ran a bottle of fuel system treatment through?
deadlydave is offline   Reply With Quote
Old 02-24-2009, 01:19 PM   #3
shipjumper
Scooby Specialist
 
Member#: 6307
Join Date: May 2001
Chapter/Region: NESIC
Location: defrosted FINALLY, VT
Vehicle:
what I has no car...
am carless

Default

the week before never....

any special kind, or just the usual iso-propolyne stuff?
shipjumper is offline   Reply With Quote
Old 02-24-2009, 01:49 PM   #4
Buck Rogers
Scooby Newbie
 
Member#: 139234
Join Date: Jan 2007
Chapter/Region: NESIC
Location: Vassalboro, ME
Vehicle:
05NA Lifted Baja MT
Brilliant Silver

Default

Check your plugs if you haven't changed them recently.
Buck Rogers is offline   Reply With Quote
Old 02-24-2009, 03:07 PM   #5
deadlydave
Scooby Specialist
 
Member#: 131119
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: Waterford, NY
Vehicle:
1996 Impreza LWRXSTI
91 BMW 318is

Default

Quote:
Originally Posted by shipjumper View Post
the week before never....

any special kind, or just the usual iso-propolyne stuff?
I use STP fuel system cleaner at least once a summer, but any fuel system cleaner/injector cleaner will work. During the winter the ISO HEET stuff works fine.

Quote:
Originally Posted by Buck Rogers View Post
Check your plugs if you haven't changed them recently.
Most definitely. May also want to look for a cracked/damaged wire.
deadlydave is offline   Reply With Quote
Old 02-24-2009, 03:39 PM   #6
shipjumper
Scooby Specialist
 
Member#: 6307
Join Date: May 2001
Chapter/Region: NESIC
Location: defrosted FINALLY, VT
Vehicle:
what I has no car...
am carless

Default

Hmmm, Always Thought That Stuff Was Snake Oil-ish...
shipjumper is offline   Reply With Quote
Old 02-24-2009, 11:34 PM   #7
moonzie
Scooby Specialist
 
Member#: 128537
Join Date: Oct 2006
Chapter/Region: MWSOC
Location: Bloomington, Indiana
Vehicle:
2004 Baja Turbo
Red/Silver

Default

Possibly an O2 sensor.
moonzie is offline   Reply With Quote
Old 02-25-2009, 08:25 AM   #8
deadlydave
Scooby Specialist
 
Member#: 131119
Join Date: Nov 2006
Chapter/Region: Tri-State
Location: Waterford, NY
Vehicle:
1996 Impreza LWRXSTI
91 BMW 318is

Default

Quote:
Originally Posted by shipjumper View Post
Hmmm, Always Thought That Stuff Was Snake Oil-ish...
It's just a small bottle of really caustic, flammable liquid. I imagine running more ethanol has the same proported cleaning effects. The baja is just too new to know. My 2nd gen legacy responded positively to the treatments, just idling better and not hesitating as much.
deadlydave is offline   Reply With Quote
Old 02-25-2009, 08:45 AM   #9
BajaGuy68
Scooby Newbie
 
Member#: 127720
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: Western, NY
Vehicle:
2011 Forester
Dk Metallic Grey

Default

I have used STP gas treatment in both my Baja's with excellent results- no issues reguarding the fuel system. Once a year I also run a bottle of Lucas through her.
BajaGuy68 is offline   Reply With Quote
Old 02-26-2009, 09:20 AM   #10
moonzie
Scooby Specialist
 
Member#: 128537
Join Date: Oct 2006
Chapter/Region: MWSOC
Location: Bloomington, Indiana
Vehicle:
2004 Baja Turbo
Red/Silver

Default

Ahh something just struck me - the cough you're talking about - is it just a one-time *cough* or is it more like a stuttering hesitation of some sort? And are you on a 5-sp or 4eat?
moonzie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
strange unrepeatable (by me that is) issue... shipjumper Service & Maintenance 5 04-17-2013 03:24 PM
Strange idling issue pictureboy Factory 2.0L Turbo Powertrain 2 01-03-2007 03:02 PM
Strange Clutch Issue SlickWRX Transmission (AT/MT) & Driveline 2 06-10-2005 11:19 PM
Strange power issue turbo6speed Normally Aspirated Powertrain 2 12-03-2004 01:18 AM
Strange power issue turbo6speed Legacy Forum 16 12-02-2004 09:11 AM


All times are GMT -4. The time now is 11:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.