Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-12-2009, 05:57 AM   #1
W0R2X
Scooby Newbie
 
Member#: 88706
Join Date: Jun 2005
Vehicle:
2002 WRX
Black

Default need some help with my vf39 hybrid please

hey guys sorry if this is a repost, ive been searching forever and havent found the right answer yet.
anyway, here is my situation.
i just installed a vf39 on my 02 wrx hybrid, and i had a real hard time with the intercooler because it wouldnt line up right. im using the stock wrx intercooler for now until i get a larger tmic.
my question is, is the problem im having due to the y-pipe? i've read lots of threads about mounting sti intercoolers on wrx's and having the fitment issue where the brackets dont line up. but my intercooler to throttle body connection is where i seem to be having the problem. is this due to the ypipe not being long enough?
im confused because i've read that the samco hose should work on wrx's, but would need to be modified to work on stis, why would they need to be extended for the sti?
it is also to my understanding that the vf39 does situate slightly differently than the td04 but its hard to tell.
if someone could help me out it would be much appreciated.

thanks.
* Registered users of the site do not see these ads.
W0R2X is offline   Reply With Quote
Old 03-12-2009, 09:33 PM   #2
EsubaruJ
Scooby Specialist
 
Member#: 200008
Join Date: Jan 2009
Chapter/Region: RMIC
Location: Salt Lake City
Vehicle:
85 AE86
01XJcrawler02WRXsold

Default

There were fitment issues with mine as well. Solution was to get a longer 90 elbow and cut it to fit I also bought a longer IC-TB coupler but ended up having to cut it a bit because it was too long. This looks like a good write you have further questions.
http://forums.nasioc.com/forums/showthread.php?t=952204
EsubaruJ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Im a little confused and need some help with my brembo swap..please help? Turbo_Twinky Brakes, Steering & Suspension 16 08-18-2009 11:21 AM
need some help with my map please xxlostxx UTEC 9 06-21-2008 04:00 PM
Need some help with my SZ49 with boost falling off at redline.. j87w Factory 2.5L Turbo Powertrain 11 07-24-2007 08:58 PM
please guys,i need some help with my turbo timer Vidiotgamer Electrical & Lighting 0 03-13-2003 01:16 AM


All times are GMT -4. The time now is 06:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.