Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-14-2009, 03:31 AM   #1
mufflerman69
Scooby Newbie
 
Member#: 166835
Join Date: Dec 2007
Chapter/Region: NWIC
Location: scotia CA.
Vehicle:
2004 WRX STI
white

Subaru Stars Built motor and all the goodies but lack of power...

let me just start by saying that i have built 5 wrx motors and they all tuned just fine. the case here is a 06 wrx with forged internals bored 20 over , a dom3, and PE 800cc inj. now after breakin we took it to the tuner and they tried there hardest to get it to break 300 but it just wouldn't we ran a leakdown test,comp test, and boostleak test. they all past, so i then pulled the timing covers off and checked the marks and they too were good... if you can think of anything feel free to let me know i would like to make at least 350... thanks
* Registered users of the site do not see these ads.
mufflerman69 is offline   Reply With Quote
Old 03-14-2009, 08:50 AM   #2
centeno711
Scooby Newbie
 
Member#: 184638
Join Date: Jul 2008
Location: central valley California
Vehicle:
2002 wrx wagon wrb
97 cummins 1ton 4x4

Default

how much boost?
fuel and air ...spark....tune
there aro only so many factors to check. im sure if you stay with it youll get it. but if it were me i would have the tuner help you as hes the one looking at the numbers that matter

ie injector duty and what not you could be dropping boost due to insufficient fueling
it could be a million things
youve checked most of the easy ones now just find the one component thats missing
i would start at the easiest points first fuel and air
maf...do sensors and what not also as they could be working but not well enough

the good part is you know somethings wrong.....thats usually half the problem in itself
centeno711 is offline   Reply With Quote
Old 03-14-2009, 07:16 PM   #3
mufflerman69
Scooby Newbie
 
Member#: 166835
Join Date: Dec 2007
Chapter/Region: NWIC
Location: scotia CA.
Vehicle:
2004 WRX STI
white

Default

well he has me tuned for 18.8 psi... and the timing is uknown to me yet the tuner aid the timing wasnt the issue... he said the car started to fuel up on top and fall on its face.
mufflerman69 is offline   Reply With Quote
Old 03-14-2009, 09:58 PM   #4
DemiSlayer
Scooby Specialist
 
Member#: 120339
Join Date: Jul 2006
Chapter/Region: RMIC
Location: Utah
Vehicle:
02 WRX
Alliance Motor Sports

Default

This sounds like a tuning issue though could be turbo related. 300 on a domIII should be easy.

I would take it to another tuner or have one of us look at the timing map etc.
DemiSlayer is offline   Reply With Quote
Old 03-14-2009, 10:55 PM   #5
dexterous
Scooby Guru
 
Member#: 23553
Join Date: Aug 2002
Chapter/Region: MAIC
Location: Slippery Rock, PA
Vehicle:
2005 STI - Insanity!
2014 WRX - Daily

Default

Could you please post your fuel octane, ambient temperature, altitude and the type of dyno that was used. Thanks.
dexterous is offline   Reply With Quote
Old 03-15-2009, 11:43 AM   #6
Fongers
Scooby Specialist
 
Member#: 118239
Join Date: Jun 2006
Chapter/Region: SCIC
Location: Beijing and Venice Beach
Vehicle:
2002 Built Wagon
Wife- 2004 Outback SE

Default

did you do cams? OEM wrx heads can't flow up top well enough to take advantage of 20g+ sized turbos after 6k...
Fongers is offline   Reply With Quote
Old 03-15-2009, 04:38 PM   #7
trbowrx
Scooby Specialist
 
Member#: 50770
Join Date: Dec 2003
Chapter/Region: MAIC
Location: VA
Vehicle:
08 STi
04 536whp STi Sold!

Default

Quote:
Originally Posted by Fongers View Post
did you do cams? OEM wrx heads can't flow up top well enough to take advantage of 20g+ sized turbos after 6k...
02-05 wrx heads maybe, but not on 06+ heads. sounds like a tuning issue to me.
trbowrx is offline   Reply With Quote
Old 03-15-2009, 05:22 PM   #8
bucket7788
Scooby Specialist
 
Member#: 124263
Join Date: Aug 2006
Chapter/Region: MAIC
Location: Now with DB Super 16g and WI!
Vehicle:
2004 WRX Wagon
RomRaider + UTEC Tuned

Default

Is it hitting target AFR's at higher RPM?
bucket7788 is offline   Reply With Quote
Old 03-18-2009, 04:03 AM   #9
mufflerman69
Scooby Newbie
 
Member#: 166835
Join Date: Dec 2007
Chapter/Region: NWIC
Location: scotia CA.
Vehicle:
2004 WRX STI
white

Default

well i know the tuner isnt the issue, for one thing he has tuned every car that i have set up and the target hp has always worked out. let me just say that GST does all my tuning.
mufflerman69 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
just dropped in new motor and all the coolant in the oil pan JT's06sti Built Motor Discussion 39 03-01-2009 03:37 PM
Missing at idle all the time, EGT code, and lack of power occasionally STI-NKR Texas Impreza Club Forum -- TXIC 7 05-04-2008 09:19 PM
FEELER: AZ sr55 and all the goodies.. FATgc8 Engine/Power/Exhaust 8 07-08-2007 06:02 PM


All times are GMT -4. The time now is 07:58 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.