Welcome to the North American Subaru Impreza Owners Club Friday October 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-23-2009, 05:16 AM   #1
C-grunt
Scooby Specialist
 
Member#: 152713
Join Date: Jun 2007
Chapter/Region: SWIC
Location: North Peoria
Vehicle:
2010 G37 Sedan
Gray

Default HELP!!! Car making bad sound...vid

Hey guys tonight my car started making some weird sounds.

Its kind of a grinding sound that sounds like its from te turbo area when Im in boost. At idle or just cruising around it doesnt make any sounds out of normal. But once the turbo starts boosting it makes the sound. I took off the heat shield, and couldnt hear any exhaust leaks. No smoke and the oil is still at full. Also I cant really duplicate it when the car is stopped. It only happens when the car is driving.

I made a crappy video with my cell phone. You can hear the sound when I boost it and it goes away right when I let off of the throttle at the end.

* Registered users of the site do not see these ads.
C-grunt is offline   Reply With Quote
Old 03-23-2009, 07:42 AM   #2
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

do you have a boost guage? what does it do?

has your clutch slipped recently?

It's either your turbo is bad or the car is dumping all the boost.
bobturismo is offline   Reply With Quote
Old 03-23-2009, 10:28 AM   #3
chosen_cartel
Scooby Newbie
 
Member#: 151620
Join Date: Jun 2007
Chapter/Region: SWIC
Location: GLENDALE, AZ
Vehicle:
2003 WRX
WRB

Default

I am not a mechanic but it seems like the same sound my car was making awhile back and it turned out to be the turbo. When it happened to my car, it was the same parameters, it would only make the noise while the car was under boost.
chosen_cartel is offline   Reply With Quote
Old 03-23-2009, 11:02 AM   #4
kpluiten
Scooby Guru
 
Member#: 120273
Join Date: Jul 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
06 WRBWRXWGN
Now with 100% more Spec-C

Default

Probably a failing turbo. This can happen everyonce and a while. Sometimes oil starvation to the turbo is the cause. The 2.5L WRX's have a small filter screen on the supply line to the turbo that can become plugged with sludge and stuff causing insufficient oil to be supplied to the turbo. I have historically only read about this on larger more oil hungry turbo's though.

I guess my point is you should remove this screen just in case it's the cause when you put a new turbo in. Subaru removed it on later models.
kpluiten is online now   Reply With Quote
Old 03-23-2009, 12:58 PM   #5
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

what turbo are you running? if its just a stock td04 i have one at jays house. im at school so i cant listen to the video. ill check it out when i get home
SubeSTIle is offline   Reply With Quote
Old 03-23-2009, 01:16 PM   #6
C-grunt
Scooby Specialist
 
Member#: 152713
Join Date: Jun 2007
Chapter/Region: SWIC
Location: North Peoria
Vehicle:
2010 G37 Sedan
Gray

Default

Yeah its the stock td04. It still is boosting and desnt seem to be losing much if any power. But I havent been boosting it since it started.
C-grunt is offline   Reply With Quote
Old 03-23-2009, 03:32 PM   #7
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

idk what mods you have but is it still under warrenty?
SubeSTIle is offline   Reply With Quote
Old 03-23-2009, 03:54 PM   #8
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

I cant hear it very well in that vid chase. If it is only on boost it could be the start of a failing turbo or a boost leak at a certain pressure. Take a screwdriver and stick it agianst the exhaust housing of the turbo and to your ear. If your turbo is on its way out you will most likely hear something abnormal, but not a guarantee. I would do a boost leak test first so if it is something simple you dont waste any money on parts. Another area that can make some stupid ass noises under boost is the uppipe to exhaust manifold gasket. That is more of a screaming noise where a boost leak will sound like a turbo diesel ford and a failing turbo will sound like a metal on metal scraping.
v8eaterWRX is offline   Reply With Quote
Old 03-23-2009, 04:13 PM   #9
C-grunt
Scooby Specialist
 
Member#: 152713
Join Date: Jun 2007
Chapter/Region: SWIC
Location: North Peoria
Vehicle:
2010 G37 Sedan
Gray

Default

Well I took it over to Christians house and it appears to be several exhaust leaks. The gasket from the turbo to the DP is leaking. Also the DP to catback is open a little. My exhaust sits very very low and I did catch it on a automatic gate guide at Teach's apt complex. Im going to take it to the exhaust shop that did my last exhaust and see if they can cut down the hangers.

Hope this is the problem.
C-grunt is offline   Reply With Quote
Old 03-24-2009, 01:41 AM   #10
gormonk
Scooby Specialist
 
Member#: 98960
Join Date: Oct 2005
Chapter/Region: SWIC
Location: phoenix, AZ
Vehicle:
1978 brat (fo realz)
red

Default

sounds like exhaust leaks (plural) to me
gormonk is offline   Reply With Quote
Old 03-24-2009, 07:58 PM   #11
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

yeah it was coming from tuBRO to dp and then dp to catback... it was pretty bad.
racingfish is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
car making funny sound 20gwrx Service & Maintenance 6 04-16-2008 12:35 AM
Need help, Car jerks bad when starting to build boost. Manoxide069 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 20 02-20-2008 04:19 AM
Fellow STi owners, does your car make this sound? volkl23 Transmission (AT/MT) & Driveline 0 07-20-2004 07:19 PM
Help car making noise! Problem after uppipe install jbogli Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 06-20-2003 10:25 AM
Help car making bad sound. White Knight Legacy Forum 5 07-12-2002 01:54 PM


All times are GMT -4. The time now is 07:14 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.