Welcome to the North American Subaru Impreza Owners Club Friday December 26, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-23-2009, 10:23 PM   #1
Mittelstadt
Scooby Newbie
 
Member#: 184301
Join Date: Jul 2008
Default Let's talk O2 sensors and exhaust

I'm installing Borla Replica's and a 2005 STI catback on my 2006 2.5i. I was happy to see the pics from a users recent install on his 07, but he has a stromung setup that seemed to make it too easy! I've already made new flanges and have to bend and weld some pipe to make the catback work.

I have a car lift so the install should be crazy easy, but I lifted it up to check it out today (and I threw the muffler on since I had it up anyway) and I was seeing that there appear to be 2 O2 sensors. I was under the impression that there was only one. One is orange and the other was white (I think).

So I have weld in bung's to put the sensors in, however my question is where do I need to put them. I believe that I need to put one in the header and the other behind the cat? I can just drill in at the base of the header right before the connection to the cat if that's where it needs to go.

I can go throw it on the lift again and take pictures if need be, and I would have had I had the camera with me. TIA!
* Registered users of the site do not see these ads.
Mittelstadt is offline   Reply With Quote
Old 03-23-2009, 10:54 PM   #2
07ImprezaMB
Scooby Specialist
 
Member#: 153861
Join Date: Jul 2007
Chapter/Region: MAIC
Location: Frostburg Maryland
Vehicle:
2008 WRX hatch
WR Blue

Default

Hey to answer your question since i JUST did this lol(and it was really easy with the stromung!!!!) But there are two 02 sensors. Pay attention which one goes after the cat because when you put them on your new exhaust the same one has to be after the cat. Now the one before the cat is on the header on your stock exhaust setup. However on the it DOES NOT need to be. My borla header had no o2 sensor plug ins. You just need to make sure the one is after the cat and the other is before it. Soooooo to simplify it, One 02 sensor right before the cat, one right after. DOES NOT have to be on the header.
07ImprezaMB is offline   Reply With Quote
Old 03-24-2009, 10:35 AM   #3
07ImprezaMB
Scooby Specialist
 
Member#: 153861
Join Date: Jul 2007
Chapter/Region: MAIC
Location: Frostburg Maryland
Vehicle:
2008 WRX hatch
WR Blue

Default

I guess my answer was so correct no one else wanted to chime in lol.
07ImprezaMB is offline   Reply With Quote
Old 03-24-2009, 12:42 PM   #4
Mittelstadt
Scooby Newbie
 
Member#: 184301
Join Date: Jul 2008
Default

Yeah, you should have ended your post with "/thread" lol

Thanks 07ImprezaMB, that makes perfect sense, I was just confused because I was only expecting to find 1 o2 sensor. It won't be too difficult. I'll take pictures after I get all this stuff fabbed up this weekend.
Mittelstadt is offline   Reply With Quote
Old 03-24-2009, 10:38 PM   #5
07ImprezaMB
Scooby Specialist
 
Member#: 153861
Join Date: Jul 2007
Chapter/Region: MAIC
Location: Frostburg Maryland
Vehicle:
2008 WRX hatch
WR Blue

Default

Hey good luck with the exhaust. Post them pics!!!!! im going to try and get a video of mine on here real soon. Gotta get the camera back from my friend first though.
07ImprezaMB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
can i zip tie second o2 sensor and put wideband o2 in that spot? sidwin AccessPort 2 02-11-2008 07:18 PM
Cats,O2 sensors, and exhaust - 2 simple questions Back Road Runner General Community 2 09-15-2006 09:12 PM
Front O2 sensor and/or EGT sensor (02 WRX) crazyhorse Private 'Wanted' Classifieds 1 11-03-2003 09:35 PM
O2 sensors and pass inspection with a full turbo back exhaust jfalcon001 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 09-09-2002 10:04 PM
O2 sensor and speed sensor Seca2man New England Impreza Club Forum -- NESIC 3 04-06-2001 05:16 PM


All times are GMT -4. The time now is 12:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.