Welcome to the North American Subaru Impreza Owners Club Thursday December 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > General Community

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-27-2009, 01:16 PM   #1
CANNIBALOFDOOM
Scooby Newbie
 
Member#: 198898
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: NEPA
Vehicle:
2012 wrx
Silver

Default getting my 09 back soon

Yes, i happen to be one of the lucky people that had the rod bearings crap out on him. Was wondering with anyone else who got it back or anyone who had a WHOLE engine replaced what might be some things to look out for to make sure they did it correct? I'm going to look it over when i get it back to see if anything seems out of place but does anyone know of anything that is more often then not overlooked or forgot when replacing an engine. I have never had a engine replaced so can only guess to check the basic connections and over all function. I trust the dealer shop guys i just know sometimes things get overlooked or things get broken when fixing it. Also, i miss my car and kinda sad i gotta "baby" it for another 1,000 miles.
* Registered users of the site do not see these ads.
CANNIBALOFDOOM is offline   Reply With Quote
Old 03-27-2009, 02:16 PM   #2
CANNIBALOFDOOM
Scooby Newbie
 
Member#: 198898
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: NEPA
Vehicle:
2012 wrx
Silver

Default

Just found out i'm getting it back at 7 tonight. Less then a week to get it back. Not sure if that is a good or bad thing.
CANNIBALOFDOOM is offline   Reply With Quote
Old 03-27-2009, 09:01 PM   #3
04funwagon
Scooby Newbie
 
Member#: 163332
Join Date: Nov 2007
Chapter/Region: Tri-State
Location: Reading, PA
Vehicle:
2004 WRX Wagon
PSM

Default

if they did a full motor swap then the timing is ok, I did this by myself in my garage with my 97 LGT in less than a week. good luck
04funwagon is offline   Reply With Quote
Old 03-27-2009, 10:10 PM   #4
CANNIBALOFDOOM
Scooby Newbie
 
Member#: 198898
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: NEPA
Vehicle:
2012 wrx
Silver

Default

Yeahs got it back.. can;t say i;m 100% happy.
minus the car feeling different to me(maybe its me mabye some things are off) the dirt/rocks all over my back seat have me really pissed, escp since i have never had anyone ride in the backseat
CANNIBALOFDOOM is offline   Reply With Quote
Old 03-27-2009, 10:36 PM   #5
mikeybo
Scooby Newbie
 
Member#: 41702
Join Date: Aug 2003
Chapter/Region: W. Canada
Location: Yellowknife, NT, Canada
Vehicle:
2005 05STi, 92Justy
White

Default

Quote:
Originally Posted by CANNIBALOFDOOM View Post
the dirt/rocks all over my back seat have me really pissed, escp since i have never had anyone ride in the backseat
Almost sounds like someone put a tire or some dirty boots in the back seat?
mikeybo is offline   Reply With Quote
Old 03-27-2009, 10:53 PM   #6
nhmtns
Scooby Guru
 
Member#: 94283
Join Date: Aug 2005
Chapter/Region: NESIC
Location: Mt. Washington Valley, NH
Vehicle:
'05 OBXT Stage 2
Min bil är svart

Default

Quote:
Originally Posted by CANNIBALOFDOOM View Post
the dirt/rocks all over my back seat have me really pissed, escp since i have never had anyone ride in the backseat
Did you ask them how this happened? That's a bunch of crap.
nhmtns is offline   Reply With Quote
Old 03-28-2009, 10:39 AM   #7
CANNIBALOFDOOM
Scooby Newbie
 
Member#: 198898
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: NEPA
Vehicle:
2012 wrx
Silver

Default

Quote:
Originally Posted by nhmtns View Post
Did you ask them how this happened? That's a bunch of crap.
I had to pick my car after service closed and when i went to talk to someone they told me i had to call on monday and speak to a certain person i was like ok that is pretty lame.
Also, i got to drive it more and the clutch seems to catch really high now.
CANNIBALOFDOOM is offline   Reply With Quote
Old 03-28-2009, 12:21 PM   #8
fog hat
Scooby Newbie
 
Member#: 196426
Join Date: Dec 2008
Location: So-Cal
Vehicle:
2009 WRX 5 door
White-ish

Default

I had an exhaust leak that I didnt notice until I "got on it" for the first time. Dealership fixed it, but it was another day wasted.

Are you going to break your new motor in according to SOA? Because it worked so good for you the first time!

My car felt weird to me at first too. After about 45days I started to fall in love with it again, but I know what you mean it just feels DIRTY to me now.
fog hat is offline   Reply With Quote
Old 03-28-2009, 02:32 PM   #9
wy09wrx
Scooby Newbie
 
Member#: 206343
Join Date: Mar 2009
Default

get mine back tuesday am,tech working on mine used to work with me so hoping for the best!
wy09wrx is offline   Reply With Quote
Old 03-28-2009, 08:38 PM   #10
CANNIBALOFDOOM
Scooby Newbie
 
Member#: 198898
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: NEPA
Vehicle:
2012 wrx
Silver

Default

I def gotta take it back for the clutch, **** is ****ing driving me insane. After driving about 200 milesish it def seems to be breaking in nicely and sounds like my old car again.
Another thing i noticed though is the handling. Its weird that these things that have nothing to do with what was replaced seem to be amiss. It seems to oversteer like crazy and just doesn;t cut into the corner as it used to. Gonna look under it and see if anything is a miss.
Also as other people SOA sent me a thing to get the extended warranty, Def made me hate this situation even more.
CANNIBALOFDOOM is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how do i get my cd back from my friend White 2.5rs Off-Topic 14 04-17-2005 05:15 PM
Getting my AEM EMS soon rhd Engine Management & Tuning 17 03-26-2005 04:32 PM
I get my car back...I get my car back! mexicanpizza Bay Area Impreza Club Forum -- BAIC 13 10-10-2002 02:23 AM
Getting my '02 WRX Soon... eclipsefire General Forum Archive 8 03-29-2001 01:51 AM
I'm gonna get my car back...I'm gonna get my car back... MPREZYA Southern California Impreza Club Forum -- SCIC 17 03-23-2001 11:40 AM


All times are GMT -4. The time now is 07:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.