Welcome to the North American Subaru Impreza Owners Club Monday March 30, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-14-2002, 06:53 PM   #1
Splat_One
Scooby Newbie
 
Member#: 5857
Join Date: Apr 2001
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2004 STI
WRB

Default Throwing CEL's left and right. Help!!!

let me start off by stating i have a 98 impreza RS.
i have been throwing check engine lights often now. i cant figure out what is going on. essentially my engine is stock. scoobysports exhaust, k&n filter and a pro ecm. It started when i got my cage installed. the guy i got it from forgot to screw in my ground to my proecm. so technically i was running no computer since that bypasses it. and i hit 4-4.5 grand on my tach and my engine cut out. light came on and it was still driveable but not past 4-5 grand. i took it back and got the ground attached and the light went off and it was ok. about three to 4 weeks later i cant stop them from comming. its my 8th one now. could i have damaged something when he didnt plug in comp.
so today after my RPMS started bouncing after starting the car(couldnt stay in one spot. revved to 4 grand stayed there and then it droped and went back up and did that for a while until it completely died) i decided to pull the proecm out and just run off the stock ecu. well i drove it and it cut out at 4 grand again. so i am lost. i have no idea what the hell is going on. i need help
also i hear this high pitched wine in the back of my car. i think its my fuel pump. should it be loud. you can hear it outside the car. is it cutting out? the reason why i think its my fuel pump is when i turn on my blinker i can hear the noise drain with the blinker. loud quite loud quite.


I have no idea how this just happened but my post got put under someone elses name. my screename is Rallyspec. Please email me at.
AlteredEK@aol.com
* Registered users of the site do not see these ads.
Splat_One is online now   Reply With Quote
Old 04-14-2002, 06:58 PM   #2
Rallyspec
Scooby Specialist
 
Member#: 5967
Join Date: Apr 2001
Location: Olympia, Washington
Default

This is my screename. hmm. i-club is on crack. if anyone is going to email dont email splat-one. email me .
thanks
Aaron
Rallyspec is offline   Reply With Quote
Old 04-14-2002, 10:21 PM   #3
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

hmm...find out what code you're throwring...then we'll have a better idea how to help ya...did you clear the code once you tookt eh chip out??

jeremy
HndaTch627 is offline   Reply With Quote
Old 04-15-2002, 09:51 AM   #4
STiTuner
Scooby Specialist
 
Member#: 5778
Join Date: Apr 2001
Chapter/Region: South East
Vehicle:
09 135i
Jet Black

Default

New term for throwing ECU codes...

I "SPLATE_ONE"

and with a ProECM and an Exhaust there are lots of codes you could be pulling.. first would probably be an 02 code.

have a dealer pull it. just don't let him look at the splicing you did for your Chip

Brad
STiTuner is offline   Reply With Quote
Old 04-15-2002, 04:02 PM   #5
Splat_One
Scooby Newbie
 
Member#: 5857
Join Date: Apr 2001
Chapter/Region: NWIC
Location: Seattle
Vehicle:
2004 STI
WRB

Default

Ok.. yea so spell my name right.... :monkey:

And I still think its with the fuel
Splat_One is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LEFT and RIGHT 06 07 fenders and front bumper new oem ki11switch Exterior/Styling 11 01-25-2010 02:57 PM
2002 WRX WRB Side Mirrors left and right in excellent condition inside and out :) Royal Motors Exterior/Styling 99 11-25-2009 10:12 PM
04-05 front bumper,left and right fender and headlights deadlystealthwrx Private 'Wanted' Classifieds 11 04-27-2006 04:43 PM
My car seems to be pulling left and right and I don't know why? breathinez Brakes, Steering & Suspension 6 12-31-2005 09:50 AM
Left and Right Bride Seat Rail hYYpeRX Private 'For Sale' Classifieds 1 11-12-2003 12:43 PM


All times are GMT -4. The time now is 12:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.