Welcome to the North American Subaru Impreza Owners Club Tuesday October 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-31-2009, 10:44 PM   #1
weston666
Scooby Newbie
 
Member#: 198759
Join Date: Dec 2008
Default Baja "shaking" at an idle

My 03 Baja seems to be idling quite rough when i'm sitting at a stop light in Drive gear. It will not however shake when it is in neutral or park gear. It only does this after the engine has warmed up and the choke has gone away. Has anyone had these similar problems?
Thanks for all the input people.
Weston

----It does not shake while im driving it either, only when im idling in Drive
* Registered users of the site do not see these ads.
weston666 is offline   Reply With Quote
Old 04-01-2009, 12:03 AM   #2
Buck Rogers
Scooby Newbie
 
Member#: 139234
Join Date: Jan 2007
Chapter/Region: NESIC
Location: Vassalboro, ME
Vehicle:
05NA Lifted Baja MT
Brilliant Silver

Default

Could be plugs. Ive seen bad plugs give some strange symptoms
Buck Rogers is offline   Reply With Quote
Old 04-01-2009, 10:45 AM   #3
moonzie
Scooby Specialist
 
Member#: 128537
Join Date: Oct 2006
Chapter/Region: MWSOC
Location: Bloomington, Indiana
Vehicle:
2004 Baja Turbo
Red/Silver

Default

I'd say pull out your MAF sensor and see if it's dirty. That's one thing that might cause it and would be simple to clean. It'll be somewhere in your intake plenum past the air filter - not sure exactly where it's located on N/As.
moonzie is offline   Reply With Quote
Old 04-01-2009, 04:27 PM   #4
weston666
Scooby Newbie
 
Member#: 198759
Join Date: Dec 2008
Default

I'm putting new spark plugs in and gonna clean the MAF sensor tonight, ill let you know how it goes
weston666 is offline   Reply With Quote
Old 04-01-2009, 08:54 PM   #5
weston666
Scooby Newbie
 
Member#: 198759
Join Date: Dec 2008
Default

NO luck with the plugs and cleaning the maf. Maybe my engine mounts are toast? The car has 120k miles
weston666 is offline   Reply With Quote
Old 04-01-2009, 09:28 PM   #6
WYSubaru
Scooby Newbie
 
Member#: 154884
Join Date: Jul 2007
Vehicle:
2005 Baja turbo
silver

Default

Our turbo was doing the same thing and I replaced the plugs first but it ended up being a bad injector.
WYSubaru is offline   Reply With Quote
Old 04-10-2009, 04:48 PM   #7
Alpha Wolf
Scooby Newbie
 
Member#: 140505
Join Date: Feb 2007
Chapter/Region: BAIC
Location: Salinas, CA
Vehicle:
2005 Baja Turbo
Pearl Blue

Cool

This normally due to the car dropping a cylinder and at idle it is more noticeable.

It is either spark or fuel.

Check plugs
Check plug wires
Check injectors
Alpha Wolf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Baja Competitors at NAIAS fdg008 Baja Forum 8 01-14-2005 11:27 AM
Somewhat of an idling problem when I get out of gear SloWrX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 02-18-2004 12:46 AM
Saw the first BAJA Sport at a local dealer.... Kostamojen Baja Forum 13 06-26-2003 09:42 AM
Where is/ or is there an idle adjustment screw for 02' Wrx? PaulRex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 5 02-14-2003 06:19 PM
'03 Legacy GT, Forester, Baja, etc. at the NY auto show rsholland News & Rumors 9 04-09-2002 04:06 PM


All times are GMT -4. The time now is 12:01 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.