Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-09-2012, 12:12 AM   #1
99imprezd
Scooby Specialist
 
Member#: 198964
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: south NJ
Vehicle:
2004 WRX wgn, built!
WRB

Default blocking off AVCS 257 LB in an '04 WRX

So gna be running an EJ257 Longblock fully built in my '04 WRX.. Whats the best way to deal with the AVCS I wont be running? Some people are saying simply block it off. Some people are saying block it off, use wrx cams, block off and run wrx cam gears on the sti cams.. whats the correct way to do this? Anyone running a similar setup care to chime in..
* Registered users of the site do not see these ads.
99imprezd is offline   Reply With Quote
Old 10-09-2012, 12:39 AM   #2
99imprezd
Scooby Specialist
 
Member#: 198964
Join Date: Jan 2009
Chapter/Region: Tri-State
Location: south NJ
Vehicle:
2004 WRX wgn, built!
WRB

Default

Ive read a bunch on here and people threading the avcs holes and locktiting are still getting leaks.. even leaks after welding? Im thinking jb weld..lol. as far as the cam gears go, if I run the AVCS gears without it hooked up will the timing be off? these other threads are all over the place..
99imprezd is offline   Reply With Quote
Old 10-09-2012, 08:24 AM   #3
04ScoobyWtf
Scooby Specialist
 
Member#: 287974
Join Date: Jul 2011
Default

Just get a cap and a clamp....
04ScoobyWtf is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:11 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.