Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-06-2009, 01:11 AM   #1
Sawyerscooby
Scooby Newbie
 
Member#: 149122
Join Date: May 2007
Chapter/Region: SWIC
Location: Mesa AZ
Vehicle:
2006 WRX Stage II
Black w/ scratches

Default weird noise...

so in the mornings when its cool out and I warming up my car i can here this high pitch whine from the engine, at first I thought it was a belt, then I noticed when I turn the wheel it gets louder... I am assuming it has something to do with the power steering but I am not a genius when it comes to this stuff so if any one has an idea let me know? As advised by Brock I did check the power steering fluid, its full btw...just concerned I want to make sure I keep this baby running properly... thanks.
* Registered users of the site do not see these ads.
Sawyerscooby is offline   Reply With Quote
Old 04-06-2009, 03:37 AM   #2
kpluiten
Scooby Guru
 
Member#: 120273
Join Date: Jul 2006
Chapter/Region: SWIC
Location: AZ
Vehicle:
06 WRBWRXWGN
Now with 100% more Spec-C

Default

Quote:
Originally Posted by Sawyerscooby View Post
As advised by Brock I did check the power steering fluid, its full btw...
Problem identified.
kpluiten is offline   Reply With Quote
Old 04-06-2009, 04:34 AM   #3
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

check the ps belt.
racingfish is offline   Reply With Quote
Old 04-06-2009, 04:35 AM   #4
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

Quote:
Originally Posted by kpluiten View Post
Problem identified.
v8eaterWRX is offline   Reply With Quote
Old 04-07-2009, 12:38 AM   #5
NAZSTI
Scooby Specialist
 
Member#: 164516
Join Date: Nov 2007
Chapter/Region: SWIC
Location: Northern AZ STI hence username
Vehicle:
2004 STI
PSM

Default

check yer head.
NAZSTI is offline   Reply With Quote
Old 04-07-2009, 10:26 AM   #6
AWDshenanigans
Scooby Specialist
 
Member#: 197856
Join Date: Dec 2008
Chapter/Region: SWIC
Location: 'merikuh
Vehicle:
2010 FJ Cruiser
Sandstorm

Default

think with your dipstick jimmy!
AWDshenanigans is offline   Reply With Quote
Old 04-07-2009, 11:24 AM   #7
SpankySuby
Scooby Newbie
 
Member#: 122305
Join Date: Aug 2006
Chapter/Region: SWIC
Location: Gilbert, Az
Vehicle:
2002 wrx half breed
Aspen White

Default

How many miles you got on it?
SpankySuby is offline   Reply With Quote
Old 04-07-2009, 01:31 PM   #8
intercoolerontop
Scooby Specialist
 
Member#: 72148
Join Date: Oct 2004
Chapter/Region: SWIC
Location: PHX, AZ
Vehicle:
2010 Ford Raptor
RAWR

Default

Quote:
Originally Posted by Sawyerscooby View Post
As advised by Brock I did check the power steering fluid, its full btw
+1 to problem identified
intercoolerontop is offline   Reply With Quote
Old 04-07-2009, 02:46 PM   #9
ChandlerWRX06
Scooby Specialist
 
Member#: 184206
Join Date: Jul 2008
Chapter/Region: SWIC
Location: Fliessem, Germany
Vehicle:
2013 X1 sDrive 28i
gray

Default

be sure to check the exhaust bearings. . .


seriously though, its probably the PS belt. might be a little loose.
ChandlerWRX06 is offline   Reply With Quote
Old 04-07-2009, 03:03 PM   #10
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

lol I said ps fluid and ps belt dbags.....

mine made the noise when the pump died from using ps fluid rather than atf
v8eaterWRX is offline   Reply With Quote
Old 04-07-2009, 03:36 PM   #11
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

Good one. how much did that cost ya to fix?
racingfish is offline   Reply With Quote
Old 04-07-2009, 03:50 PM   #12
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

Quote:
Originally Posted by racingfish View Post
Good one. how much did that cost ya to fix?
Like $200 including all new belts. Thats what I get for not reading the damn cap
v8eaterWRX is offline   Reply With Quote
Old 04-07-2009, 06:34 PM   #13
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

u got lucky sir..... sometimes if it gets really contaminated (hoses swell, steering rack goes bad) it can be $$$
racingfish is offline   Reply With Quote
Old 04-07-2009, 06:46 PM   #14
bObby
Scooby Guru
 
Member#: 66959
Join Date: Jul 2004
Chapter/Region: SCIC
Location: straight out of Compton
Vehicle:
VF Engineer'd e46
M3 500hp club

Default

Quote:
Originally Posted by v8eaterWRX View Post
lol I said ps fluid and ps belt dbags.....
Make sure it's automatic trans. fluid and not regular power steering fluid.
bObby is offline   Reply With Quote
Old 04-07-2009, 07:08 PM   #15
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

Quote:
Originally Posted by bObby View Post
Make sure it's automatic trans. fluid and not regular power steering fluid.
that was covered in the second sentence bobby
v8eaterWRX is offline   Reply With Quote
Old 04-07-2009, 07:09 PM   #16
v8eaterWRX
Scooby Guru
 
Member#: 108547
Join Date: Feb 2006
Chapter/Region: SWIC
Location: boondock camping
Vehicle:
2013 RAM 2500 4x4
6.7l Cummins

Default

Quote:
Originally Posted by racingfish View Post
u got lucky sir..... sometimes if it gets really contaminated (hoses swell, steering rack goes bad) it can be $$$
Ya it was not in there long. I developed a leaky pump and refilled it after a westside meet with some stuff from a gas station and failed to read it as it was dark. I ran it for about a month and noticed it was whining like a mofo and got the pump replaced.
v8eaterWRX is offline   Reply With Quote
Old 04-07-2009, 10:16 PM   #17
AZ05STi
Scooby Newbie
 
Member#: 191963
Join Date: Oct 2008
Chapter/Region: SWIC
Location: Phoenix,AZ
Vehicle:
. 05 AW STi R.I.P
97Brighton swap soon

Default

mine was making noise, turns out my ac compressor is no good so i just unhooked the belt
AZ05STi is offline   Reply With Quote
Old 04-10-2009, 03:44 PM   #18
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Is the little idler/tensioner pulley connected to the power steering? Can't remember, but those go out like crazy.
bobturismo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird noises when turning, popping noise HELP! idrum2loud Brakes, Steering & Suspension 13 07-07-2008 01:42 AM
weird noise from engine KillerTHC Normally Aspirated Powertrain 1 06-12-2001 06:01 AM
did intake mod, but now there's a weird noise! dj722 Southern California Impreza Club Forum -- SCIC 11 05-18-2001 12:10 PM
weird noise when down shifting from 3rd to 2nd Ghostrider Vancouver Impreza Club Forum -- VIC 7 03-31-2001 05:55 PM


All times are GMT -4. The time now is 06:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.