Welcome to the North American Subaru Impreza Owners Club Wednesday August 24, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-20-2016, 08:40 AM   #1
RYWRX
Scooby Newbie
 
Member#: 294559
Join Date: Sep 2011
Vehicle:
2006 WRX
WRB

Default Strange Noise - Cannot Figure it Out

Hey all! I'm trying to figure out my brothers' Baja. It's a 2006 Baja Turbo, 5 sped manual.

It has a very strange noise coming from the drivers side of the engine.It seems to only happen on sharp throttle above 2,000 RPM. It's a loud squeak or screech or whistle. It's very hard to explain but I took a video of it.

https://youtu.be/YyVvTUBN604

Please let me know what you think. Thanks!
* Registered users of the site do not see these ads.
RYWRX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-21-2016, 12:22 PM   #2
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

That engine sounds like it's running on steam
Baja_Gernaut is offline   Reply With Quote
Old 06-21-2016, 05:31 PM   #3
Patrikman
Scooby Specialist
 
Member#: 234499
Join Date: Jan 2010
Chapter/Region: MWSOC
Location: Astor Park
Vehicle:
2004 Outbrat XT
Regatta Red/Silverstone

Default

Boost leak. That TMIC looks pretty ratty, they've been know to leak at the seams. Check your hoses good too.
Patrikman is offline   Reply With Quote
Old 06-21-2016, 11:05 PM   #4
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

Thats sounds like a pulley or idle pulley. That engine looks kinda scary
Baja_Gernaut is offline   Reply With Quote
Old 06-23-2016, 12:15 PM   #5
RYWRX
Scooby Newbie
 
Member#: 294559
Join Date: Sep 2011
Vehicle:
2006 WRX
WRB

Default

@baja_Gernaut, I may as well change it over to coal. And I tried pulling the serpentine belts off, still has the noise. Replaced all of the timing components, still has it. It sounds like it's coming from the front.

@Patrikman, I will look into a boost leak, however, it seems to boost up well. I'll try connecting a gauge and checking that though.
RYWRX is offline   Reply With Quote
Old 07-01-2016, 10:51 AM   #6
Baja_Gernaut
Scooby Specialist
 
Member#: 229922
Join Date: Nov 2009
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2005 F-Inductd BAJA
rumble black

Default

Did you ever figure it out?
Baja_Gernaut is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.