Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-12-2009, 06:46 AM   #1
INFMIS
Scooby Newbie
 
Member#: 174494
Join Date: Mar 2008
Default oil pressure reading, help

Hey i have a new built motor, was priming the oil pump the other day by disconnecting injectors and coils and no spark plugs just cranking the engine over. i was holding 80psi oil pressure.


Is this what it should be?


Thanks
* Registered users of the site do not see these ads.
INFMIS is offline   Reply With Quote
Old 04-12-2009, 12:07 PM   #2
Fongers
Scooby Specialist
 
Member#: 118239
Join Date: Jun 2006
Chapter/Region: SCIC
Location: Beijing and Venice Beach
Vehicle:
2002 Built Wagon
Wife- 2004 Outback SE

Default

Sure I guess... wait what are you trying to accomplish here man?
Fongers is offline   Reply With Quote
Old 04-12-2009, 12:12 PM   #3
novacivic
Scooby Specialist
 
Member#: 117980
Join Date: Jun 2006
Chapter/Region: NESIC
Location: Rochester, NH
Vehicle:
2005 sti
wr blue

Default

sounds right for a cold engine during cranking
novacivic is offline   Reply With Quote
Old 04-12-2009, 12:26 PM   #4
turboL
Scooby Specialist
 
Member#: 111735
Join Date: Apr 2006
Chapter/Region: South East
Location: Philly for now
Vehicle:
96 Legacy2.0GTSOLD
Bimmer Tech

Default

yeah my freshly built motor with a shimmed pump holds 80 while cranking. 100 idling cold and about 35 idling warm. When its warm its at 90-100 at anything over 2k rpms.
turboL is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure reading, help INFMIS Impreza Forum 0 04-12-2009 06:45 AM
oil pressure readings/gauge choice help..... 1QUICKMF Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 11-06-2004 10:41 PM
Oil pressure readings on 2.2L n/a ? blkwag Normally Aspirated Powertrain 0 09-27-2002 02:41 PM
Oil Pressure readings and other problems! SpooledRex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 06-12-2002 12:34 AM
getting oil temp from oil pressure reading? initialWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 09-05-2001 06:18 AM


All times are GMT -4. The time now is 11:27 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.