Welcome to the North American Subaru Impreza Owners Club Sunday March 29, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Pre-2002 Factory Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-25-2009, 07:17 AM   #1
onslot19
Scooby Newbie
 
Member#: 191753
Join Date: Oct 2008
Chapter/Region: NESIC
Location: Windsor , CT
Vehicle:
2003 Baja, legacy ss
Baja Yellow & black trim

Unhappy ej22t legacy idle problem

i just swapped a new stock vf11 turbo because the other one i had in ther crapped out. my problem is since i installed the turbo my idle is racing to 3 grand. and it is pushing maximum boost??? i dont know why i hooked all vacuum line back up the same way and the stock b.ov the same way.



any input would be helpful
* Registered users of the site do not see these ads.
onslot19 is offline   Reply With Quote
Old 04-25-2009, 09:02 AM   #2
Matt Monson
Scooby Guru
 
Member#: 832
Join Date: Jan 2000
Chapter/Region: RMIC
Location: Teh Ghetto Garage, CO
Vehicle:
99 2.5RS, '85 911
'73 914 and 2012 BRZ

Default

Sticky wastegate?
Matt Monson is offline   Reply With Quote
Old 04-25-2009, 09:32 AM   #3
Abest10
Scooby Specialist
 
Member#: 190962
Join Date: Oct 2008
Chapter/Region: MWSOC
Location: Ohio
Vehicle:
00 STM RS
04 FXT

Default

Maybe a bad idle air control valve. Also you said you checked for vacuum leaks. Just double check. I know that's what happened on my buddy's 91 ss. He was idling at 2.5k rpms. Hope you figure it out. Good luck!!
Abest10 is offline   Reply With Quote
Old 04-25-2009, 10:33 AM   #4
Matt Monson
Scooby Guru
 
Member#: 832
Join Date: Jan 2000
Chapter/Region: RMIC
Location: Teh Ghetto Garage, CO
Vehicle:
99 2.5RS, '85 911
'73 914 and 2012 BRZ

Default

IAC wouldn't make it overboost like that. It's something related to the turbo itself or the routing of the lines.
Matt Monson is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird idling problem - Very high idle Oodles-of-Noodles Mid Atlantic Impreza Club -- MAIC 21 02-04-2010 10:25 PM
Crap Idle Problem, Can't hold idle, sometimes dies when I push clutch in Wrinkleboi Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 91 09-02-2008 09:40 PM
Help! '90 legacy L off-idle problem Sloewag'n Legacy Forum 15 01-13-2007 12:48 PM
EJ22T rough Idle/ stalls DrunkenDragon Pre-2002 Factory Turbo Powertrain 12 02-24-2006 10:32 AM
1990 Legacy Idle problem mhj Legacy Forum 2 08-14-2001 02:40 PM


All times are GMT -4. The time now is 06:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.