Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-24-2009, 08:53 PM   #1
HTKrallyXTREME
Scooby Newbie
 
Member#: 142501
Join Date: Mar 2007
Chapter/Region: South East
Location: Hollywood, Fl
Vehicle:
2008 Legacy spec.B
Quartz Silver Metallic

Question brakes not lighting up

Help me out guys.

the brake lights work but only when i hit the brakes hard.. when i just brake normally they dont light up at all..

i know its not a fuse issue because the brakes do work..

any help would be appreciated.. thanks
* Registered users of the site do not see these ads.
HTKrallyXTREME is online now   Reply With Quote
Old 04-24-2009, 08:57 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Misadjusted or defective brake light switch, at the top of the pedal linkage.
Mulder is offline   Reply With Quote
Old 04-24-2009, 09:11 PM   #3
HTKrallyXTREME
Scooby Newbie
 
Member#: 142501
Join Date: Mar 2007
Chapter/Region: South East
Location: Hollywood, Fl
Vehicle:
2008 Legacy spec.B
Quartz Silver Metallic

Default

So how can I fix that? Is it easy to take apart
HTKrallyXTREME is online now   Reply With Quote
Old 04-24-2009, 09:35 PM   #4
Micky
Scooby Newbie
 
Member#: 89757
Join Date: Jun 2005
Chapter/Region: International
Location: Chiba, Japan
Vehicle:
2004 Impreza STI
Black & dirty

Default

Quote:
Originally Posted by HTKrallyXTREME View Post
So how can I fix that? Is it easy to take apart
Turn the car upside down to get easy access to the underside of the dash.
Micky is offline   Reply With Quote
Old 04-24-2009, 10:02 PM   #5
HTKrallyXTREME
Scooby Newbie
 
Member#: 142501
Join Date: Mar 2007
Chapter/Region: South East
Location: Hollywood, Fl
Vehicle:
2008 Legacy spec.B
Quartz Silver Metallic

Default

wow man thanks ill be sure to do that....

a helpful response now please.. i got pulled over today and i wanna fix it asap
HTKrallyXTREME is online now   Reply With Quote
Old 04-24-2009, 10:45 PM   #6
Cougar4
Scooby Specialist
 
Member#: 53443
Join Date: Jan 2004
Location: Anchorage, AK
Vehicle:
2001 LL Bean Outback
Winestone

Default

The switch is mounted on the pedal like Mulder said. You can take them apart as far as I know. You will have to replace it most likely unless it not aligned correctly.
Cougar4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HID not lighting up at times!!?! jt0thevizzle Electrical & Lighting 8 04-27-2008 10:41 AM
Help! Side markers and Parking lights not lighting up...? stevey323 Electrical & Lighting 1 03-25-2008 02:04 PM
Cruise control button not lighting up... AK*WRX*2004 Electrical & Lighting 5 01-17-2006 01:55 AM
needle not lighting up? suby ej25 Tri-State Area Forum 6 02-21-2004 09:51 AM
cobalt gauges not lighting up nvrenuf Electrical & Lighting 3 04-05-2003 11:35 PM


All times are GMT -4. The time now is 01:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.