Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-29-2009, 06:08 PM   #1
ImPrEzZzZZA
Scooby Specialist
 
Member#: 8252
Join Date: Jul 2001
Location: oklahoma
Vehicle:
2002 WRX
Platinum Silver Metallic

Default Headlights won't turn on

I disconnected the security module the other day and my speedo was erratic like a metronome. I unhooked my turbo timer and it fixed the problem but my headlghts won't turn on. All fuses are ok and relays look fine. It's not my ballasts, as I plugged in an old haloge on and it still wouldn't light... Also, when I'm in reverse, my ABS light now comes on. I'm puzzled..
* Registered users of the site do not see these ads.
ImPrEzZzZZA is offline   Reply With Quote
Old 04-29-2009, 06:31 PM   #2
JavaBot
Scooby Guru
 
Member#: 156723
Join Date: Aug 2007
Chapter/Region: Tri-State
Location: Illadelph
Vehicle:
99rs Slvr City Buggy
'14 swp 5dr sport

Default

Did you tap into the headlight power part of the harness to power the turbo timer? If you broke the connection somewhere check that area first or you may have shorted something. When you flip the lights, does it click under the glove box?
JavaBot is offline   Reply With Quote
Old 04-29-2009, 06:59 PM   #3
ImPrEzZzZZA
Scooby Specialist
 
Member#: 8252
Join Date: Jul 2001
Location: oklahoma
Vehicle:
2002 WRX
Platinum Silver Metallic

Default

I'll double check. I do hear it click, I hear my ballast click too, so I know it's getting some power.
ImPrEzZzZZA is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windows won't go up, deck won't turn on!!! No blown Fuses 07imprezadrifter Electrical & Lighting 2 08-06-2009 11:03 AM
Need help! my headlight won't turn off! nycsubaruwrx Electrical & Lighting 4 11-27-2007 06:21 PM
My headlights won't turn off!! Please help!! Carlito2002WGN Newbies & FAQs 15 05-23-2007 04:08 PM
Laptop help needed. Won't turn on, or turns on then dies garface Off-Topic 35 08-22-2005 03:48 PM
Headlights won't turn off. Brad B. Mid West Subaru Owners Club Forum -- MWSOC 15 09-18-2002 12:01 PM


All times are GMT -4. The time now is 09:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.