Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-30-2009, 11:14 AM   #1
CSULBwagon
Scooby Newbie
 
Member#: 95428
Join Date: Sep 2005
Chapter/Region: SCIC
Location: Long Beach, CA
Vehicle:
02 WRX wagon STG2
Dirty Silver

Default Clicking under the dash

I have an 02 WRX with some mild engine mods that has been fine for 2 years. Now the car is acting up. When I try to start it all the lights go dimm and it wont turn over. If I keep trying it will like magic start to work again. Today the locks would not work, well they did but very weak. I just keep hearing a clicking from the fuse panel inside the dash. And that noise is only when things are going funny. What do you think it could be?
* Registered users of the site do not see these ads.
CSULBwagon is offline   Reply With Quote
Old 04-30-2009, 11:29 AM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

battery issue of some sort

bad battery/cable ends need clened...bad cables
Uncle Scotty is offline   Reply With Quote
Old 05-08-2009, 05:53 AM   #3
kaotic WeRX
Scooby Newbie
 
Member#: 188546
Join Date: Sep 2008
Chapter/Region: TXIC
Location: el paso tx
Vehicle:
03 stage 2 WRX
black

Default

Quote:
Originally Posted by Uncle Scotty View Post
battery issue of some sort

bad battery/cable ends need clened...bad cables

he is probably right, i had a similar clicking when using the brights or windows from under the dash too, and when i finally got my battery off and cleaned the terminals i haven't noticed it... but then again i may have just toned it out....
kaotic WeRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The unhooked green connector under the dash? fizzak Newbies & FAQs 6 12-22-2005 10:43 PM
The Green Harness under the dash? BillJC Electrical & Lighting 3 02-15-2003 08:15 PM
A Few disconnected Harness Under the dash above the footrest mo168 General Community 8 10-11-2002 01:35 PM
"Always on" power under the dash... where to tap? rogue Car Audio, Video & Security 8 04-06-2002 06:14 PM
('93-'01) Damn Noise under the dash! Can it be fixed? Clegg Impreza Forum 3 01-08-2002 12:12 AM


All times are GMT -4. The time now is 07:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.